Announcement

Collapse
No announcement yet.

Safari Font Issues... AGAIN

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Wayne Luke
    replied
    That user can turn off Smart Punctuation in their iOS Keyboard settings. It will affect everything these do on their device. Every site and every app. To do this they would go to Settings -> General -> Keyboard on their device.

    The issue will come up again in the future though as UTF-8 is the standard and your site doesn't support it. Having it converted will prevent the issue from happening in the future.

    Leave a comment:


  • amonline
    replied
    Originally posted by Wayne Luke View Post
    Yes. If you had provided the information that you were on vBulletin Cloud to begin with, we could have run the conversion already.
    Just finally figured out the ONLY member having an issue is one with iOS Safari set to “English (UK)”. No one else is having the issue.

    Recommendation?

    Edit: here we are testing it... my post is first and last... he lists what he’s testing.... so, it’s just this one member. I’m baffled.

    Click image for larger version

Name:	06E28DFE-FFD5-4AAC-9C20-E681DA6B51E0.jpeg
Views:	34
Size:	117.8 KB
ID:	4455096
    Last edited by amonline; Thu 18 Mar '21, 1:07am.

    Leave a comment:


  • amonline
    replied
    See below...

    Leave a comment:


  • Wayne Luke
    replied
    Yes. If you had provided the information that you were on vBulletin Cloud to begin with, we could have run the conversion already.

    Leave a comment:


  • amonline
    replied
    Originally posted by Wayne Luke View Post
    ... you can probably accomplish this simply by changing the HTML Character Set to UTF-8 from the old vBulletin 4.X default of ISO-8859-1...

    If that doesn't fix it, then your database isn't storing data in UTF-8. This can be cause by using older MySQL software and not using the proper character set and collation. We have provided scripts in the do_not_upload folder/dbtools directory to convert any database to UTF-8 as long as it meets the minimum requirements. Though, I recommend using MySQL 8 for the best support. The instructions for the dbtools scripts can be found here: https://forum.vbulletin.com/articles...database-tools
    It is set like this... has been forever.

    We're on Cloud. Do you have to run the conversion for us?

    Leave a comment:


  • Wayne Luke
    replied
    We provided a solution to this issue. It is actually a browser issue and not a vBulletin issue. The way to solve this issue is to convert your output to UTF-8. On English systems, you can probably accomplish this simply by changing the HTML Character Set to UTF-8 from the old vBulletin 4.X default of ISO-8859-1. You can do this in the AdminCP under Languages & Phrases -> Language Manager and then setting the HTML Character Set. We won't make this change for you because of your own legacy data and it can cause other issues. However, all new installs of vBulletin 5 for the past few years will use this character set. All new languages distributed by us use this character set. If it has appeared again, I suggest making sure your language is using UTF-8. If you use third-party language packs then make sure their developers use UTF-8.

    If that doesn't fix it, then your database isn't storing data in UTF-8. This can be cause by using older MySQL software and not using the proper character set and collation. We have provided scripts in the do_not_upload folder/dbtools directory to convert any database to UTF-8 as long as it meets the minimum requirements. Though, I recommend using MySQL 8 for the best support. The instructions for the dbtools scripts can be found here: https://forum.vbulletin.com/articles...database-tools

    Leave a comment:


  • amonline
    started a topic Safari Font Issues... AGAIN

    Safari Font Issues... AGAIN

    Is the Safari issue being worked on yet?

    Click image for larger version

Name:	2EF867BD-99F1-4B51-890E-A65D70D97FCB.png
Views:	71
Size:	23.8 KB
ID:	4452878

    This happened a year or so ago and was repaired. It’s been back for a couple/few months now. Tired of members complaining about it. 😉
    Attached Files

Related Topics

Collapse

Working...
X