Announcement

Collapse
No announcement yet.

Broken image gallery after updating to 5.6.4

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Broken image gallery after updating to 5.6.4

    Clicking one of the thumbnail images in a gallery will not display the image correctly, we recently upgraded from 5.6.3 to 5.6.4 and seemed to stop working after the upgrade.

    Seemingly a very large value is being loaded in the image container, so the image is being displayed far off screen (no matter what resolution monitor is used the image is off screen).

    Opened a support ticket but so far no solution, is anyone else experiencing the same issue?

  • #2
    Does this issue occur in a new style with no parent and doesn't include your custom header?
    Translations provided by Google.

    Wayne Luke
    The Rabid Badger - a vBulletin Cloud demonstration site.
    vBulletin 5 API

    Comment


    • #3
      Creating a new style seems to work, switching to an existing un-customised style that doesn't use the header doesn't.

      Comment


      • #4
        Custom style gallery's css template may be missing.
        There is no problem with my gallery.

        https://vbulletinturko.com

        Comment


        • #5
          So we edited the newly created style with our current customisations and the gallery will still work, however the breadcrumbs and close button for the gallery disappear (so something must have changed in the templates between versions).

          Is it possible that the previous update hasn't updated/merged the existing styles correctly? It seems odd that none of the previous styles work but a newly created (and modified one) does.

          Comment


          • #6
            Yes... Extensive work was done on the lightbox and gallery in vBulletin 5.6.4. Including changes in the templates, PHP, and JavaScript for those functions. This refactor was the majority of user facing work in vBulletin 5.6.4. In addition, the jQuery used by vBulletin overall has had its version increased.

            Unfortunately, we cannot plan for or implement changes with backwards compatibility towards site administrator customizations. We try to have as little impact on these as possible across all customers but that is not always possible. This is why we encourage customers that have extensive customizations to run a test/development installation with a copy of their database. This allows the customer to test new versions of the software before deploying it to production.

            When upgrading, not all templates will be able to be merged 100%. In the side of caution, we flag these and use the old version. This will impact functionality. The AdminCP will tell you about these flagged versions and you can manually fix them under Styles -> Find Updated Templates.
            Translations provided by Google.

            Wayne Luke
            The Rabid Badger - a vBulletin Cloud demonstration site.
            vBulletin 5 API

            Comment

            widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
            Working...
            X