Announcement

Collapse
No announcement yet.

Cookies

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Mark.B
    replied
    Originally posted by woodmj View Post
    Thanks for that MarkB

    Strange thing is that was what I had whilst it wasn't working but removing the 'www' it works OK.
    I've noticed however I write my site address in the address bar in Chrome (eg. www, http, https etc) it's always shortened to mydomain.com over SSL. Bit confused what's going on there?
    You can only use one single URL with vBulletin, and that is the one specified in the settings. Any others will need to be forwarded to the one in the settings.

    domain.com is not the same as www.domain.com. http is not the same as https. Browsers will treat the cookies for each as being separate and unrelated.

    vBulletin will also build its links from the URL settings.

    Thus if your settings have www but you start off loading non-www, any links you click will have www in them, you will have no cookie and thus you will be logged out. (Or at least have the appearance of being logged out).

    To resolve, choose either www or non-www, have this in the URL settings, and forward whichever one you did not choose into the one you did choose. Your host can assist with forwarding in this way.
    Last edited by Wayne Luke; Sun 25 Oct '20, 8:15am.

    Leave a comment:


  • woodmj
    replied
    Thanks for that MarkB

    Strange thing is that was what I had whilst it wasn't working but removing the 'www' it works OK.
    I've noticed however I write my site address in the address bar in Chrome (eg. www, http, https etc) it's always shortened to mydomain.com over SSL. Bit confused what's going on there?

    Leave a comment:


  • Mark.B
    replied
    Are both the URL settings in the admincp correct?

    Should be in the following format:

    Click image for larger version

Name:	image_2020-10-24_211155.png
Views:	100
Size:	18.9 KB
ID:	4449297

    Leave a comment:


  • woodmj
    started a topic Cookies

    Cookies

    Hi,
    Would anyone know what might stop VB5 from remembering Cookies?
    Problem arose when I enabled APC but I took it off but the Cookie problem still exist.
    Tried a Cookie reset with tools.php but that didn't help.
    Clearing my site Cookie in Chrome didn't help.
    My Cookie prefix appears the same in /config.php and /core/includes/config.php
    Even disabled APC in /etc/php/apache2/php.ini and rebooted the server but no joy.

Related Topics

Collapse

Working...
X