Announcement

Collapse
No announcement yet.

Time Date Numbers

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Rakehel
    replied
    That's a mouthful. I'll have another look at things. I appreciate the input & info.

    Leave a comment:


  • Wayne Luke
    replied
    - If you use a LOCALE, then you need to define all the time and date variables for the Language settings. It will not be able to inherit the defaults. When a Locale is used, PHP uses different functions to format dates.

    - If your database is UTF-8, then your character set should be UTF-8.

    - Ideally the database collation should be utf8mb4. However this isn't a collation issue. It is that the formatting for dates changed and some variables that could be used previously are no longer available to be used. Your images show that you need to update the date formatting for your site.

    - Older versions of vBulletin stored UTF-8 characters as HTML entities. If your data stored "curly quotes" they would have been converted to HTML entities. If these do not get decoded properly by your browser or for some reason they get double encoded in the database then the & can appear incorrectly. There is really no way to fix this except to edit and save the content so it has the correct value.

    Leave a comment:


  • Rakehel
    replied
    That's a lot of entries, "research" & testing. Only the Time Zone in the main ACP settings has been changed using the menu there.

    - Using the default, vB English language install, no added language packs, all of the edits listed in the Languages & Phrases/Language Manager need configured?

    - Or am I looking for the ISO code for the character set used in the database for the Language Manager config? (utf8_unicode_ci)

    - Or the collation type for the files in the database on the server should be converted to ____?

    There has been an issue for some time with the "&" character appearing where apostrophes should appear in words. It can appear in manual posts, RSS feeds, or Google calendar entries appearing on the main display. (Article posted here. Google calendar has its own encoding/formatting issues.)

    Hoping not to become a developer to run a simple discussion forum. (No offense to developers...worked with many on projects over the years, good people. My best friend is a developer. )

    Leave a comment:


  • Rakehel
    replied
    Thanks Wayne, I'll look closer.

    Leave a comment:


  • Wayne Luke
    replied
    You should update the time and date formats under Settings -> Options -> Time and Date Options and for your specific language overrides under Languages & Phrases -> Language Manager. How these are handled has changed. The help links in the options will link to the new formatting options. You can also test the formatting under Maintenance -> Diagnostics.

    Leave a comment:


  • Rakehel
    started a topic Time Date Numbers

    Time Date Numbers

    Just noted that time, date, some miscellaneous other numbers aren't displaying properly. Tried a database repair on the server, haven't edited Time Zone other than to select Eastern Time.

    The "3" in version "5.6.3" displays as an "S"?

    Firefox, Chrome, Edge, Opera, Pale Moon display the same.

    Is there a quick, easy answer to fix the issue? Not synched w/server? Character set used? phpMyAdmin displays utf8_unicode_ci , all tables.
    Attached Files

Related Topics

Collapse

Working...
X