Announcement

Collapse
No announcement yet.

Error after uploaded files

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Error after uploaded files

    I tried to run installation wizard after uploading Bulletin 5 Connect, but get this message:


    Parse error: syntax error, unexpected '?' in /home/XXXX/public_html/includes/vb5/frontend/applicationlight.php on line 245

  • #2
    Is this an upgrade or a brand new installation?

    If it is an upgrade, what version of vBulletin are you upgrading from and to?

    What is your php version? vBulletin 5.6.2 (the latest version at the time of writing) requires a minimum of php 7.2.
    MARK.B | vBULLETIN SUPPORT

    TalkNewsUK - My vBulletin 5.6.2 Demo
    AdminAmmo - My Cloud Demo

    Comment


    • #3
      The null coalescing operator used in this line of code was introduced in PHP 7.0. This error would be cause by using a version of PHP less than 7.0. The minimum required version of PHP for vBulletin 5.6.X is 7.2.

      If your server requires the use of an .htaccess AddHandler directive to set the PHP above a minimum, then the two lines for this needs to be added at the top of the provided .htaccess file. You would place this before the line that says <IfModule mod_rewrite.c>. Your hosting provider can tell you how to increase the version of PHP and provide the AddHandler lines if necessary.
      Translations provided by Google.

      Wayne Luke
      The Rabid Badger - a vBulletin Cloud demonstration site.
      vBulletin 5 API - Full / Mobile
      Vote for your favorite feature requests and the bugs you want to see fixed.

      Comment


      • #4
        Originally posted by Mark.B View Post
        Is this an upgrade or a brand new installation?

        If it is an upgrade, what version of vBulletin are you upgrading from and to?

        What is your php version? vBulletin 5.6.2 (the latest version at the time of writing) requires a minimum of php 7.2.
        Is is a new installation after the previous installation disappeared for some reason....


        It is this PHP version:
        • PHP-versjon: 7.3.6

        Comment


        • #5
          Anyone who can help me with this error?

          Comment


          • #6
            Originally posted by Tormod View Post
            Anyone who can help me with this error?
            See Wayne’s post above.
            MARK.B | vBULLETIN SUPPORT

            TalkNewsUK - My vBulletin 5.6.2 Demo
            AdminAmmo - My Cloud Demo

            Comment


            • Tormod
              Tormod commented
              Editing a comment
              Yes, but the PHP version is above 7.0. So this problem cannot be caused by that.

          • #7
            The code referenced is valid in PHP 7.2.0 and higher. Each directory can have a different PHP version on most servers. If you have an AddHandler directive in a different directory, it can report a different version of PHP. If you upgraded your version of PHP via cPanel, the .htaccess that does this will be erased when you upload the vBulletin files.

            Please upload the attached info.php file to your vBulletin root directory and load it in a browser. Paste a screenshot of the version here.
            Attached Files
            Translations provided by Google.

            Wayne Luke
            The Rabid Badger - a vBulletin Cloud demonstration site.
            vBulletin 5 API - Full / Mobile
            Vote for your favorite feature requests and the bugs you want to see fixed.

            Comment

            Related Topics

            Collapse

            Working...
            X