Announcement

Collapse
No announcement yet.

error-2 error_information_x-2

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • [Resolved] error-2 error_information_x-2

    I am trying to access my website from another computer and just after accepting the privacy policy this window appears informing me of this error ... Any ideas?

    EDIT: Apparently this only happens when I enter the web without writing the www; If I write them before, no error comes out.
    Attached Files
    Last edited by w4term4n; Mon 29 Jun '20, 11:08am.

  • #2
    The most common causes of this error the result of accessing the site from HTTP when it is an HTTPS site, including www when it isn't specified in the URL, or not including www when it is specified in the URL. All of these are valid scenarios on a web server and can actually show different parts of a site or data depending on how the server is configured. Furthermore, security best practices says that each of these sites are different when using secure HTTPonly cookies like vBulletin does. vBulletin doesn't know how to respond because the URL used doesn't have access to its APIs.

    If you don't need these specialized routes, then you should make sure that everyone is redirected to the URL specified as the Forum URL in the AdminCP. We provide a basic redirect in the default .htacces for switching from http to https. It does need to have its comment marks removed though. If you allow multiple domains or sub-domains (i.e. www) to access your site, you'll need to manually create those redirects so users end up at the correct location.
    Translations provided by Google.

    Wayne Luke
    The Rabid Badger - a vBulletin Cloud demonstration site.
    vBulletin 5 API - Full / Mobile
    Vote for your favorite feature requests and the bugs you want to see fixed.

    Comment


    • #3
      Originally posted by Wayne Luke View Post
      The most common causes of this error the result of accessing the site from HTTP when it is an HTTPS site, including www when it isn't specified in the URL, or not including www when it is specified in the URL. All of these are valid scenarios on a web server and can actually show different parts of a site or data depending on how the server is configured. Furthermore, security best practices says that each of these sites are different when using secure HTTPonly cookies like vBulletin does. vBulletin doesn't know how to respond because the URL used doesn't have access to its APIs.

      If you don't need these specialized routes, then you should make sure that everyone is redirected to the URL specified as the Forum URL in the AdminCP. We provide a basic redirect in the default .htacces for switching from http to https. It does need to have its comment marks removed though. If you allow multiple domains or sub-domains (i.e. www) to access your site, you'll need to manually create those redirects so users end up at the correct location.
      Perfect, in my case it fails when I enter without writing the 3 www, so all I have to do is redirect any url without www to url with www, correct?

      Comment


      • #4
        Originally posted by w4term4n View Post

        Perfect, in my case it fails when I enter without writing the 3 www, so all I have to do is redirect any url without www to url with www, correct?
        That is correct.
        Translations provided by Google.

        Wayne Luke
        The Rabid Badger - a vBulletin Cloud demonstration site.
        vBulletin 5 API - Full / Mobile
        Vote for your favorite feature requests and the bugs you want to see fixed.

        Comment


        • w4term4n
          w4term4n commented
          Editing a comment
          Thank you so much Wayne.

      • #5
        Originally posted by Wayne Luke View Post

        That is correct.
        Sorry to bother you again Wayne but I asked my current host to do the appropriate redirects to me and they run into trouble ...

        - When they have made the redirects when trying to enter a URL directly, the redirection does not take place (copy and paste in the address bar and then manually delete the 3 WWWs); for example: https://hispaddit.com/zona-cero/gene...eles-y-mas-por -time-limited # post20196

        - The host tells me the following:

        Hosting: Hello,

        Thanks for your reply.

        I have checked your .htaccess website and could see that 301 multi-redirect is already added for subpages. So, the pages you are trying to access directly load without WWW.

        To resolve that, you would need to disable the eixsting rules and add the new rule 301 with the full URL like: https://www.hispaddit.com/zona-cero/...egala-un-pack- cyberpunk-2077-with-wallpapers-posters-and-more-for-a-limited-time # post20196 (attachment provided by hosting 1)

        - Answer 2 of the hosting:

        I fully understand your concern. I have tried to update the rules, but there is an error loading 404. Could you please confirm the URL of the web page added with www in your vBulletin admin panel.

        You can check and verify it here: AdminCP >> vBulletin Options >> vBulletin Options >> Site Name / URL / Contact Details.

        If not, update the URLs and republish the links. It will automatically update with www.

        - Answer 3 of the hosting:
        I have checked the links on the .htaccess subpage and their default settings for https://hispaddit.com/. If I add the custom 301 code, a 404 loading error occurs. I could see that you have added a permanent redirect code for your subpages to your domain name. The best option is to contact the web developer and seek help, or you can ask the VBulletin application provider to review the script once.

        You can post this number here: https://forum.vbulletin.com/

        They will review the script and let you know. Also if you have any necessary requirements for www redirection to work you can let us know so we can check if it can be configured on the server for you. (attached file provided by hosting 2)
        Attached Files

        Comment


        • #6
          I have no idea what they are trying to do.


          A quick Google search shows that you need this code -

          Code:
          RewriteCond %{HTTP_HOST} !^www\.
          RewriteRule ^(.*)$ http://www.%{HTTP_HOST}/$1 [R=301,L]
          You would add it to the existing .htacess file and place it above the comment line that says main redirect. All of vBulletin's default redirects must remain in place.
          Translations provided by Google.

          Wayne Luke
          The Rabid Badger - a vBulletin Cloud demonstration site.
          vBulletin 5 API - Full / Mobile
          Vote for your favorite feature requests and the bugs you want to see fixed.

          Comment


          • #7
            Originally posted by Wayne Luke View Post
            I have no idea what they are trying to do.


            A quick Google search shows that you need this code -

            Code:
            RewriteCond %{HTTP_HOST} !^www\.
            RewriteRule ^(.*)$ http://www.%{HTTP_HOST}/$1 [R=301,L]
            You would add it to the existing .htacess file and place it above the comment line that says main redirect. All of vBulletin's default redirects must remain in place.
            Fixed, I have passed the link to this post, they have looked at it and it already works perfect. : D

            Comment

            Related Topics

            Collapse

            Working...
            X