Announcement

Collapse
No announcement yet.

Issue on date after upgrading to 5.6.2

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • [Resolved] Issue on date after upgrading to 5.6.2

    I'm reviewing everything and apparently everything works correctly except it doesn't show the post date correctly.

    Only the time is shown, not the day or month, I have not touched anything, I have only updated.
    Attached Files
    Last edited by w4term4n; Thu 25 Jun '20, 11:36am.

  • #2
    What data is in the field for Date And Time Options > Format For Date in the AdminCP Settings?

    Comment


    • #3
      Originally posted by In Omnibus View Post
      What data is in the field for Date And Time Options > Format For Date in the AdminCP Settings?
      I upload screenshots.
      Attached Files

      Comment


      • #4
        The new European Date Format is %d-%m-%y

        Try replacing the d-m-a with %d-%m-%y and let us know if the problem persists.

        Comment


        • #5
          Originally posted by In Omnibus View Post
          The new European Date Format is %d-%m-%y

          Try replacing the d-m-a with %d-%m-%y and let us know if the problem persists.
          The problem continues.
          Attached Files

          Comment


          • #6
            Time and Date formatting has changed in 5.6.2. This was done to make sure that the multiple methods of formatting a date in PHP and across operating systems is simplified. See:
            https://tracker.vbulletin.com/vbulle...sues/VBV-20120 and https://tracker.vbulletin.com/vbulle...sues/VBV-20119.

            Unfortunately, this means some of the more obscure formatting options no longer work. Especially on Windows servers. Make sure your date formats under Settings -> Options -> Date and Languages -> Language Manager -> Edit Language use supported formatting. You can diagnose dates and see the formatting options under Maintenance -> Diagnostics -> Test Date/Time Formats.
            Translations provided by Google.

            Wayne Luke
            The Rabid Badger - a vBulletin Cloud demonstration site.
            vBulletin 5 API - Full / Mobile
            Vote for your favorite feature requests and the bugs you want to see fixed.

            Comment


            • #7
              Originally posted by Wayne Luke View Post
              Time and Date formatting has changed in 5.6.2. This was done to make sure that the multiple methods of formatting a date in PHP and across operating systems is simplified. See:
              https://tracker.vbulletin.com/vbulle...sues/VBV-20120 and https://tracker.vbulletin.com/vbulle...sues/VBV-20119.

              Unfortunately, this means some of the more obscure formatting options no longer work. Especially on Windows servers. Make sure your date formats under Settings -> Options -> Date and Languages -> Language Manager -> Edit Language use supported formatting. You can diagnose dates and see the formatting options under Maintenance -> Diagnostics -> Test Date/Time Formats.
              Fixed, I've changed %x to %d/%b/%y; I wanted to put %a%d/%b/%y and but curiously I cannot because when it is Wednesday in Spanish it is written: MiƩrcoles and it appears with erroneous coding mi(?) xD; I have the UTF-8 encoding and it only fails there, in the rest of the web it works perfect, it gives me a little the same but well I liked it more, but no problem.
              Last edited by w4term4n; Thu 25 Jun '20, 11:42am.

              Comment

              widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
              Working...
              X