Announcement

Collapse
No announcement yet.

Random logouts

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Random logouts

    Hi !

    Recent vb4 -> vb5 upgrade.
    Experiencing forced logout moments after login. Both on the user and admin side.
    In the admin control panel I can log in and get the left meny (iframe) but the main content iframe will show the login dialog at the same time.
    1. vBulletin Version - vBulletin 5.6.1 Patch level 1
    2. PHP Version - 7.2.30-1+ubuntu16.04.1+deb.sury.org+1
    3. MySQL Version - 5.7.11-0ubuntu6
    4. Any Addons installed.
    5. Does the issue occur in a default style? Yes
    6. Does the issue occur using the English language provided? Yes
    7. Error message on the screen. - Login dialog shown
    8. Browser and Browser version used. - Google Chrome 81.0.4044.138
    9. Did you clear the browser cache and did the error continue? Yes, cleared all cookies
    10. A list of steps that can be used to recreate the issue. - see above
    11. Output of the error with vBulletin in Debug Mode.
    12. If the issue is an Invalid Server (500 server error) response, the web server and PHP logs that correspond with its timestamp.
    If relevant, the site is using CloudFlare for DNS/HTTPS

    Any ideas?

  • #2
    Are you using CloudFlare for Performance Caching? If so, you need to make sure that vBulletin is configured to handle it properly. This is done in the /core/includes/config.php file by uncommenting the CloudFlare lines.

    Find this code:

    PHP Code:
    //Default proxy settings for common proxy providers.  Uncommenting this will override any previous proxy
    //configuration (and thus only one of them can be used).
    /*
    //default configuration for Cloudflare proxy.
    $config['Misc']['proxyiplist'] = '103.21.*, 103.22.*, 103.31.*, 104.16.*, 108.162.*, 131.0.*, ' . 
        '141.101.*, 162.158.*, 172.64.*, 173.245.*, 188.114.*, 190.93.*, 197.234.*, 198.41.*, ' . 
        '2400:cb00:*, 2405:b500:*, 2606:4700:*, 2803:f800:*, 2c0f:f248:*, 2a06:98c0:*';

    $config['Misc']['proxyipheader'] = 'HTTP_CF_CONNECTING_IP';
    */ 
    Remove the /* and */ from the code block.
    Translations provided by Google.

    Wayne Luke
    The Rabid Badger - a vBulletin Cloud demonstration site.
    vBulletin 5 API - Full / Mobile
    Vote for your favorite feature requests and the bugs you want to see fixed.

    Comment

    Related Topics

    Collapse

    Working...
    X