Announcement

Collapse
No announcement yet.

vB 5.5.5 kein Adminzugang mehr

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • [Bug / Issue] vB 5.5.5 kein Adminzugang mehr

    Seit 11/2019 habe ich die Version 5.5.5 installiert, bei der ich auch bis zum Wochenende zu Forum und Adminbereich
    ohne Probleme Zugang hatte.

    Ohne ersichtlichen Grund bzw Änderung war der Adminzugang nicht mehr möglich.
    Alle Suche, den Fehler zu finden hatte keinen Erfolg.
    Also habe ich mit Restore die SW um 1 Woche zurückgespielt.
    Das Forum hat Zugang, der Adminbereich jedoch NICHT!

    Wer kennt dieses Problem, bzw. wie kann ich es abstellen?

    Wir haben im Test die aktuelle Version 5.6.1 neu aufgespielt, haben aber keinen sauberen Zugriff auf die Datenbank

    Installiert ist vB auf einem Webserver, PhP 7.2

    Vorab vielen Dank für die Lösung.


    Nachtrag
    Das ist die Fehlermeldung:

    Zugriff verweigert!
    Der Zugriff auf das angeforderte Verzeichnis ist nicht möglich. Entweder ist kein Index-Dokument vorhanden oder das Verzeichnis ist zugriffsgeschützt.
    Sofern Sie dies für eine Fehlfunktion des Servers halten, informieren Sie bitte den Webmaster hierüber.
    Error 403

    Last edited by Kati Muni; Wed 13 May '20, 11:46am.

  • #2
    Stellen Sie sicher, dass Ihr Server so konfiguriert ist, dass index.php ein Indexdokument ist. Möglicherweise müssen Sie sich dazu an Ihren Hosting-Anbieter wenden. Sie können auch weiter bei dem 403-Fehler helfen, den der Server zurückgibt, bevor er etwas von der vBulletin-Software verarbeitet.



    Make sure that your server is configured so that index.php is an index document. You may need to contact your hosting provider to do this. They would also be able to help further with the 403 error that the server is returning before it processes anything from the vBulletin software.
    Translations provided by Google.

    Wayne Luke
    The Rabid Badger - a vBulletin Cloud demonstration site.
    vBulletin 5 API

    Comment


    • #3
      Vielen Dank.
      Aber gibt es keine andere Möglichkeit, den Zugang neu zu konfigurieren?
      Die Index.php ist vorhanden.

      Mit dem Hoster bin ich seit Tagen auf Fehlersuche, sie finden die Ursache nicht. :-(

      Comment


      • #4
        Der Fehler kommt nicht von vBulletin. Es kommt vom Webserver. Was verursacht der 403? Dies ist nur in den Protokolldateien des Servers verfügbar.


        The error is not coming from vBulletin. It is coming from the webserver. What is causing the 403? This is only available in the log files of the server.
        Translations provided by Google.

        Wayne Luke
        The Rabid Badger - a vBulletin Cloud demonstration site.
        vBulletin 5 API

        Comment


        • #5
          Folgendes habe ich soeben per Zufall gefunden:

          Domain/forum/index.php = Zugang zum Forum, seit dem letzen Login war ich als Admin ja noch angemeldet.

          Seite bearbeiten auf "ON " gestellt

          zufällig "Style" aufgerufen und das erfragte Passwort eingegeben (gleiches wie User-PW)

          "Adminbereich-Zugang" angeklickt und ich landete im ADMIN-Bereich grosses Erstaunen!!!

          Der Browser zeigte nun
          Domain/forum/admincp/index.php

          Wie oben geschrieben, zufällig so gewählt


          So war es nicht und so kann der Weg nicht in Zukunft sein.

          Welche Lösung haben Sie?


          Comment


          • #6
            Wenn ich die Site in Ihrem Kundendatensatz mit / forum / besuche, muss ich der URL nicht index.php hinzufügen, um die Foren oder das AdminCP anzuzeigen. Ich erhalte eine Fehlermeldung, wenn ich / forum / nicht hinzufüge. Sie benötigen eine Umleitung in Ihrem Stammverzeichnis, um Benutzer automatisch in das Verzeichnis / forum zu senden. Ihr Hosting-Anbieter sollte dies für Sie tun können.




            When I visit the site on your customer record with /forum/ I do not need to add index.php to the URL to view the forums or the AdminCP. I do get an error if if I don't add /forum/. You need a redirect in your root directory to automatically send users into the /forum directory. Your hosting provider should be able to do this for you.
            Translations provided by Google.

            Wayne Luke
            The Rabid Badger - a vBulletin Cloud demonstration site.
            vBulletin 5 API

            Comment


            • #7
              Ich habe irrtuemlich bei den Einstellungen im Adminbereich den Pfad verändert und hinter der domainbezeichnung de./ "Forum" entfernt.
              Nun komme ich nicht mehr in den Adminzugang und lande auf der HP -Seite.

              In welcher Datei dann ich das eintragen bzw. aendern.

              Vielen Dank für eine vll kurzfristige Antwort, da das Forum geschlossen ist.
              Last edited by Kati Muni; Sun 28 Feb '21, 2:16am.

              Comment


              • #8
                VB 5.6.1

                Ich wiederhole meine Frage, da ich immer noch auf Antwort hoffe/warte:

                Ich habe irrtuemlich bei den Einstellungen im Adminbereich den Pfad verändert und hinter der domainbezeichnung de./ "Forum" entfernt.
                Nun komme ich nicht mehr in den Adminzugang und lande auf der HP -Seite.

                In welcher Datei kann ich das eintragen bzw. aendern.

                Vielen Dank für eine vll kurzfristige Antwort, da das Forum geschlossen ist.
                und ja, in welchem Verzeichnis finde ich die Datei.

                Ich muss wirklich dringend in den Adminbereich.

                Comment


                • #9
                  Die URL des Forums, welche man im Admin-Bereich ändern kann, steht in der Datenbank.
                  Man sollte diese eigentlich über die mitgelieferte tools.php, welche man in das Verzeichnis core/admin legt (und nach Abschluss definitiv wieder löscht!!!), ändern können.

                  Die Daten stehen in der Tabelle setting varname bburl und frontendurl, sind aber ggf. auch noch im datastore gespeichert!

                  Comment


                  • Kati Muni
                    Kati Muni commented
                    Editing a comment
                    Vielen Dank für die Antwort, nur kann ich in der Datenbank nichts ändern und die tools.php ist ja gelöscht.
                    bzw. wo finde ich diese eventuell?

                  • delicjous
                    delicjous commented
                    Editing a comment
                    Die tools.php liegt dem Package im do_not_upload Verzeichnis bei.
                widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
                Working...
                X