Announcement

Collapse
No announcement yet.

Optimize forum posting vb5.5.5

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Wayne Luke
    replied
    Settings -> Options -> Email Settings.

    Leave a comment:


  • 720
    replied
    Originally posted by andy-1 View Post
    Error found ... Board software setting in e-mail dispatch ... deactivated


    Skip the queue for new post emails
    Emails sent to moderators when new posts are created are sent immediately instead of being added to the queue. This ensures immediate notification, but can lead to a noticeable delay in saving the post.

    This only applies if the emails are in the queue by default.
    Where did you find these settings, please?

    Leave a comment:


  • andy-1
    replied
    Mail delivery was the right clue

    Posting time now 2 second

    THX
    Last edited by andy-1; Tue 14 Jan '20, 8:14am.

    Leave a comment:


  • andy-1
    replied
    Error found ... Board software setting in e-mail dispatch ... deactivated


    Skip the queue for new post emails
    Emails sent to moderators when new posts are created are sent immediately instead of being added to the queue. This ensures immediate notification, but can lead to a noticeable delay in saving the post.

    This only applies if the emails are in the queue by default.

    Leave a comment:


  • Wayne Luke
    replied
    I don't know what the purpose of posts #5 and #6 are for. They provide nothing meaningful to help solve your issue.

    Do you have slow query logging turned on in MySQL? If so, what are the slow queries logged there?

    What is the complete Waterfall from loading the page and posting?

    Do non-Admins have the same problem?

    How many notifications does that channel have? Select * from subscribediscussions where discussionid=X. You can find X for the channel by looking at the node id in the Channel Manager.

    Does many replies do the topics in question have? Topics with more than 1000 replies will be significantly slower than smaller topics.

    Leave a comment:


  • andy-1
    replied
    Why doesn't the saving happen in the background and the posting is released with a refresch?

    Leave a comment:


  • andy-1
    replied
    Hi

    Using the default theme, posting a topic or creating visitor message takes 2min. Though, I'll try to upgrade both php and mysql then report my findings.

    Something to note, when I press the post button, count to 3 then refresh the browser, the content is there. The issue is that, the response takes too long to return to "/content/text/ POST"
    Update:

    We've used Newrelic to spot the issue. The issue was when it was sending out the notification email. Long story short, we swiched to postfix to send the email and it's now blazing fast. Thanks for the support, Wayne!
    that's exactly my problem

    Leave a comment:


  • andy-1
    replied
    no tapatalk
    28 sek one post vb 5.5.5

    mysql 5.7.28
    Attached Files

    Leave a comment:


  • andy-1
    replied
    switched to php 7.4
    not helped
    Last edited by andy-1; Tue 14 Jan '20, 5:35am.

    Leave a comment:


  • andy-1
    replied
    Now try to loog as described by them in another thread

    Edit the /core/includes/xml/logger.php file. Change this:
    Code:
    <!-- <logger name='api'> <level value="trace" /> <appender_ref ref="filelog" /> </logger> -->
    To:
    Code:
    <logger name='api.content_text'> <level value="trace" /> <appender_ref ref="filelog" /> </logger>
    Then open your /core/includes/config.php file and change:
    Code:
    // $config['Misc']['debuglogging'] = true;
    to:
    Code:
    $config['Misc']['debuglogging'] = true;
    Create some text posts. This should create a logfile on your server called vbdebuglog.log. What is the contents of that file?
    Last edited by andy-1; Tue 14 Jan '20, 6:17am.

    Leave a comment:


  • Wayne Luke
    replied
    MySQL Version Datenbank-Client Version: libmysql - mysqlnd 5.0.12-dev
    This is the PHP Client Library version and isn't very relevant at the moment. What is the actual version of MySQL installed on the server?

    Does the problem happen if Tapatalk is disabled?

    Leave a comment:


  • andy-1
    replied

    vBulletin Version 5.5.5
    PHP Version 7.3.13-1+ubuntu18.04.1+deb.sury.org+1
    MySQL Version Datenbank-Client Version: libmysql - mysqlnd 5.0.12-dev
    Any Addons installed Tapatalk, Third Party Login - Google, Third Party Login - Twitter, vBulletin File Scanner
    Does the issue occur in a default style? yes
    Does the issue occur using the English language provided? yes
    Error message on the screen' no
    Browser and Browser version used.chrome, edge,firefox
    Did you clear the browser cache and did the error continue? yes


    Apache/2.4.41 (Ubuntu)


    $config['Misc']['debuglogging'] = true;
    Last edited by andy-1; Mon 13 Jan '20, 11:35am.

    Leave a comment:


  • Wayne Luke
    replied
    Sounds like a server configuration issue. It doesn't take 24 seconds to post here.

    Please answer the questions here: https://forum.vbulletin.com/forum/vb...obtain-support

    Leave a comment:


  • andy-1
    started a topic [Bug / Issue] Optimize forum posting vb5.5.5

    Optimize forum posting vb5.5.5

    Posting takes 24 seconds !!!!!!

    and gets longer with vb 5.5.5

    Is that just my problem or was there already here?

Related Topics

Collapse

Working...
X