Announcement

Collapse
No announcement yet.

Static HTML Content not displaying / Login popup does not work in Edge on Windows 10.

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Static HTML Content not displaying / Login popup does not work in Edge on Windows 10.

    Two problems:

    1) None of the content in the static html modules is displaying in Chrome. The code is all in the boxes, but it doesn't render. What shows in place of the content is:

    Click Edit to configure this module.

    2) The login popup works in Chrome but not in Edge. So, I can log in using Chrome but no Edge.

    https://www.justonelook.org/forum/
    1. vBulletin Version: 5.5.4 Patch Level 2.
    2. PHP Version - PHP Version 7.2.24
    3. MySQL Version - 5.7.25-log
    4. Any Addons installed - no
    5. Does the issue occur in a default style? yes
    6. Does the issue occur using the English language provided? yes
    7. Error message on the screen for the login popup error: This content can’t be shown in a frame

      There is supposed to be some content here, but the publisher doesn’t allow it to be displayed in a frame. This is to help protect the security of any information you might enter into this site
    8. Browser and Browser version used:
      Chrome Version 79.0.3945.88 (Official Build) (64-bit)
      Microsoft Edge 44.18362.449.0
      Windows 10
    9. Did you clear the browser cache and did the error continue? Yes
    10. A list of steps that can be used to recreate the issue.

      1. Log into the forum using Chrome and there is no content in the boxes.
      2. Try to log in using Edge and the popup does not display
    11. If the issue is an Invalid Server response, the web server and PHP logs that correspond with its timestamp.

      PHP VersionBulletin Version

      You can find your MySQL version under Maintenance -> Diagnostics -> Server Variables -> ySQL Settings

    You can find your PHP version in the AdminCP under Maintenance -> View PHPInfo

    You can find your addons in the Admin CP under Hooks & Products -> Manage Products.

    To create a new default style go to Styles & Templates -> Style Manager and click Add New Style. Set "Parent" to none, give it a name and save.
    Last edited by

  • #2
    Log in form works for me on your site with Edge 44.17763.831.0 and 79.0.309.56 beta.
    VB 5.6.4
    PHP 7.4
    MySQL 5.7.24

    Comment


    • justonelook2
      justonelook2 commented
      Editing a comment
      Thank you for your reply. Please see my reply to Wayne Luke below.

  • #3
    Your server is blocking iframes for Edge. In the AdminCP you can go to "Settings -> Options -> Cookie and HTTP Header Options" and set "anti-clickjacking headers" to "Allow all frames." If the issue still occurs, contact your hosting provider about the issue.

    What is the content of your HTML modules?

    When using static HTML modules -
    • Do not use <html>, <head>, <meta>, or <body> tags. Only include the actual HTML content.
    • If your Static HTML relies on jQuery, you should defer this Javscript until vBulletin loads jQuery. Do not load your own version of jQuery.
    • While using the <style> tag and inline CSS is allowed, a better practice would be to include your CSS within the css_additional.css template.
    • Make sure you're using valid HTML 5 tags. Don't use <font>, <color>, <center>, or other obsolete tags.
    • HTML 5 does not require closed tags as it is not based on XML. These tags are like <br /> or <img />. Instead use the HTML variants of <br> and <img>.
    Translations provided by Google.

    Wayne Luke
    The Rabid Badger - a vBulletin Cloud demonstration site.
    vBulletin 5 API

    Comment


    • #4
      Hello, Wayne.

      Thank you for your reply.

      Reading another topic I found out what the problem was. Somehow the Disable PHP, Static HTML, and Ad Module rendering got set to YES. So I set it to NO and everything is displaying fine now.

      But I still don't know what to do with the Login box. It does not work properly on Microsoft Edge 44.18362.449.0, although it apparently works correctly on Edge 44.17763.831.0 and 79.0.309.56 beta as stated by OrganForum.

      Apparently, Flash Player is disabled by default in Edge. Mine was anyway. The weird thing is that when I enabled Adobe Flash Player in the browser the login box appeared.


      Comment


      • #5
        Originally posted by justonelook2 View Post
        Hello, Wayne.
        Apparently, Flash Player is disabled by default in Edge. Mine was anyway. The weird thing is that when I enabled Adobe Flash Player in the browser the login box appeared.
        Seems like a bug in your version of Edge. We don't use Flash in the software. The login box does use an iFrame currently. We're changing that in 5.6.0.
        Translations provided by Google.

        Wayne Luke
        The Rabid Badger - a vBulletin Cloud demonstration site.
        vBulletin 5 API

        Comment

        Related Topics

        Collapse

        Working...
        X