Announcement

Collapse
No announcement yet.

MariaDB for vbulletin 5

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • MariaDB for vbulletin 5

    Currently running vbulletin 5 (and one vbulletin 4 forum) on MariaDB 10.3 going to upgrade to MariaDB 10.4 to see if this helps with a certain issue having at a mybb forum on the same VPS. Will MariaDB 10.4 be fine for the vb5 and vb4 forums?

  • #2
    We don't actually test MariaDB. We take their advertisement as a drop in replacement for MySQL at face value. If they deviate from that, then things can break as vBulletin is written exclusively for MySQL's SQL variant.

    MariaDB tends to be a year or two behind MySQL releases. Is 10.4 based on MySQL 5.7 or 8.X? We support both of those. However, some of the database field names in the software have become reserved words in MySQL 8.0.X so you might have problems with vBulletin 4. We have deployed workarounds in vBulletin 5.5.6 for these changes. That said, I haven't looked at the release notes for MariaDB 10.4 to give a conclusive answer.
    Translations provided by Google.

    Wayne Luke
    The Rabid Badger - a vBulletin Cloud demonstration site.
    vBulletin 5 API

    Comment


    • #3
      I upgraded to MariaDB 10.6.5 and encountered no issues with my bulletin 5.6.5 and 4.2.5 sites.

      Comment

      Related Topics

      Collapse

      Working...
      X