Announcement

Collapse
No announcement yet.

''Hide User Customization'' button not working

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • ''Hide User Customization'' button not working

    Hey guys,

    So we allow users to customize their profile pages. However a user reported to me that they were unable to hide the user profile customization as when they hit the ''Hide User Customization'' button. I was able to replicate this on

    I can see in the usergroup settings where you can allow usergroups whether they can customize their profiles, but nothing with regards to allowing or denying the ability to Hide/Show a user customization.

    I must be missing something. Any idea ?

    Thanks,
    P

  • #2
    Any feedback on this ?

    Comment


    • #3
      There is no setting to turn off the ability to hide profile customization. People may be turning this off for accessibility purposes.
      Translations provided by Google.

      Wayne Luke
      The Rabid Badger - a vBulletin Cloud demonstration site.
      vBulletin 5 API

      Comment


      • #4
        Originally posted by Wayne Luke View Post
        There is no setting to turn off the ability to hide profile customization. People may be turning this off for accessibility purposes.
        Thanks.

        The issue we have been having is that users when clicking to hide the users customization, the page refreshes but the customization are still showing and the button is still showing ''Hide User Customization'' as if nothing has happened, which evidently is the case as the customization will not hide. I am going to get some user screen-casts to further diagnose what the issue could be. Will pop them here if nothing is obvious.

        Thanks !

        Comment


        • #5
          Hi panzerscope ,

          You can restrict user access to this show/hide checkbox with some CSS & phrase management workarounds.

          Click image for larger version

Name:	other-user-cust.PNG
Views:	52
Size:	12.5 KB
ID:	4428160

          To hide the checkbox
          Code:
          input#usercustomizations_87[type=checkbox] {
              display: none;
          }
          To (change or hide) the phrase in AdminCP > Languages & Phrases > Search in Phrases > "Show other user customizations"

          usersetting_showusercss

          Click image for larger version

Name:	phrases.PNG
Views:	129
Size:	12.1 KB
ID:	4428157

          To hide the phrase place a blank space in the new phrase box or change it to say something like "User customizations are not available"

          Likewise for the help text phrase search for
          "Other users can make customizations to some of their pages, such as their profile page. With this option you can choose to hide these customizations."

          use_can_make_customizations

          Click image for larger version

Name:	phrases-2.PNG
Views:	48
Size:	17.2 KB
ID:	4428158

          Then remove or change the phrase text so it doesn't appear on the page or gives different information that's relevant to your forum.

          This leaves the label "Other User Customizations" which is harder to target using CSS as it does not have a unique identifier.

          I was up against this problem yesterday, trying to target a label using the text content via CSS but could not find a way of doing so.

          Click image for larger version

Name:	other-user-label.PNG
Views:	52
Size:	9.7 KB
ID:	4428159

          Hope this helps.

          Aly

          Comment


          • #6
            Originally posted by AlyGreen View Post
            Hi panzerscope ,

            You can restrict user access to this show/hide checkbox with some CSS & phrase management workarounds.

            Click image for larger version

Name:	other-user-cust.PNG
Views:	52
Size:	12.5 KB
ID:	4428160

            To hide the checkbox
            Code:
            input#usercustomizations_87[type=checkbox] {
            display: none;
            }
            To (change or hide) the phrase in AdminCP > Languages & Phrases > Search in Phrases > "Show other user customizations"

            usersetting_showusercss

            Click image for larger version

Name:	phrases.PNG
Views:	129
Size:	12.1 KB
ID:	4428157

            To hide the phrase place a blank space in the new phrase box or change it to say something like "User customizations are not available"

            Likewise for the help text phrase search for
            "Other users can make customizations to some of their pages, such as their profile page. With this option you can choose to hide these customizations."

            use_can_make_customizations

            Click image for larger version

Name:	phrases-2.PNG
Views:	48
Size:	17.2 KB
ID:	4428158

            Then remove or change the phrase text so it doesn't appear on the page or gives different information that's relevant to your forum.

            This leaves the label "Other User Customizations" which is harder to target using CSS as it does not have a unique identifier.

            I was up against this problem yesterday, trying to target a label using the text content via CSS but could not find a way of doing so.

            Click image for larger version

Name:	other-user-label.PNG
Views:	52
Size:	9.7 KB
ID:	4428159

            Hope this helps.

            Aly
            Nice ! Thanks I will keep this in mind should everything else fail.

            Comment


            • #7
              Hi panzerscope

              Update to hiding the checkbox solution. You may be past needing this but I thought to update the solution to help others.

              The CSS needs an adjustment.

              Found on trying this for real, the checkbox numbers were unique for each user so you needed to target a less unique name attribute, that only occurs once on the profile page for any user.

              Old CSS
              Code:
              input#usercustomizations_87[type=checkbox]
              Revised CSS
              Code:
              input[type=checkbox][name="other_customizations"] { /* Hide User Customizations checkbox on Profile > Account tab */
                  display: none;
              }
              Aly

              Comment

              Related Topics

              Collapse

              Working...
              X