Announcement

Collapse
No announcement yet.

Can not reset password...'Could not convert string character encoding, one of 'mbstring' or 'iconv' must be installed'

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Can not reset password...'Could not convert string character encoding, one of 'mbstring' or 'iconv' must be installed'

    Hello Everybody,

    If I click on link emailed to me to reset my password....
    I enter new password twice & I click to reset new password I get the following error...
    An unexpected error was returned: 'Could not convert string character encoding, one of 'mbstring' or 'iconv' must be installed'

    I install mbstring & iconv on my server, I checked & repaired mysql DB, then I restart the server and I still get the same error.

    I was hacked a while back and I'm sure it is part of the Hack.

    vb5.4.2
    PHP7.3.11
    Apache v2.4.41 (cgi-fcgi)
    MySQL 5.7

    Thank You for Your Time!!!!!
    RUBE
    Thank You for Your Time!
    RUBE

  • #2
    I don't think your version of vBulletin is fully compatible with PHP 7.3. Please upgrade to vBulletin 5.5.5. Does the error continue after that?

    For the best performance and user experience, it is imperative to upgrade to the latest version of vBulletin. Each version improves PHP compatibility, enhances the API, and refactors old code. Plus they improve performance and security.
    Translations provided by Google.

    Wayne Luke
    The Rabid Badger - a vBulletin Cloud demonstration site.
    vBulletin 5 API - Full / Mobile
    Vote for your favorite feature requests and the bugs you want to see fixed.

    Comment


    • #3
      Thank You Sir,
      I will give that a try!
      Thank You for Your Time!
      RUBE

      Comment


      • #4
        Hello,

        We upgraded forum to VB Version 5.5.5, Also before upgrade noticed 2 suspicious/malicious files that have been removed.
        The forum is still giving the same error. Does anybody have any ideas on how to correct this?

        I'm hoping when this gets fixed it will take care of all forum members passwords.
        Thank You for Your Time!
        RUBE

        Comment


        • #5
          "one of 'mbstring' or 'iconv' must be installed'"

          Are you absolutely certain one of these is installed?
          The error is suggesting that they aren't, even if your host thinks they are.
          MARK.B | vBULLETIN SUPPORT

          TalkNewsUK - My vBulletin 5.5.6 Demo
          AdminAmmo - My Cloud Demo

          Comment


          • #6
            Hello Wayne Luke & Mark B.,

            I apologize, I thought I installed them correctly? Oh Well.

            I went back to server settings & installed mbstring and iconv.
            This time they installed and everything works fine now.

            Thank You Everybody for Your Time!!!!!

            This is why I have the username RUBE!
            RUBE
            Thank You for Your Time!
            RUBE

            Comment

            Related Topics

            Collapse

            Working...
            X