Announcement

Collapse
No announcement yet.

BBCODE Autolinking Issue

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • BirdOPrey5
    replied
    Hello, "Disable Automatic Link Parsing Within This BB Code" still needs to be set to yes, that is the correct setting. Not sure how things could be changed without editing the editor.

    Leave a comment:


  • panzerscope
    replied
    Thanks Wayne for the details, sounds good to me. Will try those suggestions later to see if it remedies the BBCODE Autlinking issue and report back.

    Leave a comment:


  • Wayne Luke
    replied
    Primarily general bug fixes. It has been a few years since we have updated the editor. It should include better mobile support and support for newer browsers. The developers are looking into a few new features but can't discuss them until they are implemented.

    Leave a comment:


  • panzerscope
    replied
    Thanks Wayne.

    I will give this go and report back !

    On an unrelated note...what sort of upgrades could we see to the new editor ?

    Leave a comment:


  • Wayne Luke
    replied
    A few things to try.
    1. Go into the AdminCP and turn off remote JQUERY under settings -> Options -> Server Settings and Optimization Options. Does this solve the issue?
    2. Next disable any javascript or ad blocking extensions in your browser. Does this solve the issue?
    3. Disable all third-party addons. Does this solve the issue?
    4. Finally:
      1. Turn your forums off.
      2. Delete the /js/ directory on your site.
      3. Upload a new copy of the /js/ directory from your version of vBulletin.
      4. Turn your forums on.

    If none of these resolve the issue, you will need to provide server access. Or you can try the 5.5.6 Alpha in a test directory when it is released to customers. 5.5.6 will contain a new and upgraded version of the editor.

    Leave a comment:


  • panzerscope
    replied
    Hey guys,

    Thanks for the workarounds. What I will say is that setting the "Disable Automatic Link Parsing Within This BB Code" to "NO" honestly makes no difference at all to my case. While there are workarounds, as I am sure you can agree this creates extra steps in order to achieve something that use to be as simple as insert tags, paste link and submit. So in my opinion the feature so far as ease of use has lost some value. Will there be a way to restore the ''simplicity'' of this function again in the future ? Or are we forever slave to the browser behavior ?

    Cheers,
    P

    Leave a comment:


  • David Grove
    replied
    You can also use Ctrl + Shift + V to force plain text when pasting (depends on OS and browser). You could also use source mode to ensure it pastes as plain text. Those are just a couple more alternatives.

    Leave a comment:


  • BirdOPrey5
    replied
    I see the issue, I am not certain it is a vBulletin issue. I will consult with the developers. The problem is as soon as the URL is posted into the editor it turns into a hyperlink (it's blue.) However if you choose to "post as plain text" in pastes in black (as plain text) and everything works as expected. I assume it is a browser change causing the issue. You will want to "paste as plain text" to get around the issue for now.

    Not all browsers show the "paste as plain text" option in my experience, in fact few seem to. However if you copy the URL from Notepad for example you don't get this issue so clearly the browser URL bar is adding extra code telling us that this is a hyperlink that is causing the issue.

    Leave a comment:


  • David Grove
    replied
    Originally posted by panzerscope View Post
    Within my BBCODE config, I actually have it setup to Disable BB Code Within This BB Code, which I thought was what would fix this issue for me as you would expect it to kill the URL BBCODE that the system puts in automatically, alas it does not.
    Edit your [FB] bbcode and set "Disable Automatic Link Parsing Within This BB Code" to "NO".

    Note: You'll have to manually edit any existing posts that are incorrect, but that should work for any new posts.

    Leave a comment:


  • panzerscope
    replied
    Bug report for this has been issued: https://tracker.vbulletin.com/vbulle...sues/VBV-19739

    Leave a comment:


  • panzerscope
    replied
    Hey Wayne,

    Were you able to see any obvious reason for this ? If not I can open a support ticket referencing this thread.

    Thanks,
    P

    Leave a comment:


  • panzerscope
    replied
    Hello Wayne,

    I was not meaning to be as forthright as the post does indeed come off. I appreciate you looking into a solution and for the temporary work around. I was just surprised that the feature no longer worked. Just for a frame of reference, the parsing issue was not an issue prior to having to restore the forums after the zero day exploit. So either the restore is responsible or the patch, but I very much doubt the latter. As I say, I appreciate you looking into the issue.

    If access is required to my site if you are unable to replicate, let me know and I will open a support ticket

    Cheers,
    P

    Leave a comment:


  • Wayne Luke
    replied
    I was trying to troubleshoot the issue, not provide a solution. Please hold your unrighteous indignation while I work to find a solution. I only have so much time every day and to be frank, this issue isn't really a major priority.

    You're welcome to log it as a bug and it will go through the review process.

    Leave a comment:


  • panzerscope
    replied
    In fact while this works, it is not optimal as it disables half of the editor when in this mode. This adds needless additional steps in order to use the BBCODE. It would be much simpler to find out why the system no longer removed the linking !

    Leave a comment:


  • panzerscope
    replied
    Thanks that seems to work, but has something changed ? We could always successfully pull this off by just inserting the link inside the BBCODE on the front end as the back-end settings would make sure the link was not parsed.

    Leave a comment:

Related Topics

Collapse

Working...
X