Announcement

Collapse
No announcement yet.

Moderated Guest Posts in Articles

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Mohammed Abu Risha
    commented on 's reply
    I posted a comment and it worked.

  • may
    replied
    Originally posted by Wayne Luke View Post
    Click image for larger version

Name:	2019-08-22_15-02-53.png
Views:	50
Size:	27.0 KB
ID:	4420585

    And the "Can Create" permissions at the bottom? They need to be able to create Text content at least.
    That's it. Thanks a lot, for this info I searched for

    Leave a comment:


  • ringnews24
    replied
    Originally posted by Wayne Luke View Post
    Click image for larger version

Name:	2019-08-22_15-02-53.png
Views:	50
Size:	27.0 KB
ID:	4420585

    And the "Can Create" permissions at the bottom? They need to be able to create Text content at least.
    Spot on with your instructions. It was that one option that fixed everything.

    Thanks mate.

    Leave a comment:


  • Wayne Luke
    replied
    You probably want to set "Can Create Topics" to no as well. Otherwise, guests will be able to create articles.

    Leave a comment:


  • Wayne Luke
    replied
    Click image for larger version

Name:	2019-08-22_15-02-53.png
Views:	50
Size:	27.0 KB
ID:	4420585

    And the "Can Create" permissions at the bottom? They need to be able to create Text content at least.

    Leave a comment:


  • ringnews24
    replied
    Originally posted by Wayne Luke View Post

    What are the permissions for guest users on the Article Channels and its children?
    There is no categories. Just Article channel with the below permissions in the images
    Attached Files

    Leave a comment:


  • Wayne Luke
    replied
    Originally posted by zweeper View Post
    With the letter/number captcha it works fine, dont know why the reCAPTCHA is not working here.
    Please start your own topic for this issue and provide the server information asked for in the "Required Information" sticky.

    Another additional question: When a guest comments and needs an approval for his post, why do I not get a "red notification" as moderator?
    Instead it is hiding in "moderations" when I open the notification tab.

    In this way, I will never see if I need to approve a guest comment or not (or i will daily check this place out manually).
    I believe there is an open improvement request for this issue.

    Leave a comment:


  • Wayne Luke
    replied
    Originally posted by ringnews24 View Post
    Error message: You are not authorized to create this post.
    What are the permissions for guest users on the Article Channels and its children?

    Leave a comment:


  • zweeper
    replied
    With the letter/number captcha it works fine, dont know why the reCAPTCHA is not working here.

    Another additional question: When a guest comments and needs an approval for his post, why do I not get a "red notification" as moderator?
    Instead it is hiding in "moderations" when I open the notification tab.

    In this way, I will never see if I need to approve a guest comment or not (or i will daily check this place out manually).

    Leave a comment:


  • zweeper
    replied
    It seems to work for me, but suddenly it says always the reCAPTCHA is wrong (but it was solved correctly with green hook). Any idea?

    Example, try to comment any article: https://www.bolidenforum.de/artikel/...tonomes-fahren


    will end up like attachment

    Attached Files

    Leave a comment:


  • ringnews24
    replied
    My sites now live and I've done the above and guest can't post.

    Any ideas?

    Thanks

    Error message: You are not authorized to create this post.

    https://www.koboxingforum.com/
    Last edited by ringnews24; Thu 22nd Aug '19, 6:17am.

    Leave a comment:


  • ringnews24
    replied
    Originally posted by Wayne Luke View Post
    1. In the AdminCP go to Usergroups -> Channel Permissions.
    2. Scroll down to Articles
    3. Set the permissions for the Guest usergroup to be able to reply and comment in this channel.
    4. To set their posts to always moderated, set the "Skip Moderation Queue" permissions to No in this channel.
    I just keep getting the message you are not authorised to make this post. But, I'll try it again once we move to VB5 this week.

    For some reason on the demo its not working after I did what you said.

    Leave a comment:


  • Wayne Luke
    replied
    1. In the AdminCP go to Usergroups -> Channel Permissions.
    2. Scroll down to Articles
    3. Set the permissions for the Guest usergroup to be able to reply and comment in this channel.
    4. To set their posts to always moderated, set the "Skip Moderation Queue" permissions to No in this channel.

    Leave a comment:


  • ringnews24
    started a topic Moderated Guest Posts in Articles

    Moderated Guest Posts in Articles

    I want to allow guests to be able to reply to articles but not post on the forum or blog.

    I'm having a look at usergroup guests, but there is no option to allow guets to reply to articles.

    The only option there is Can Reply to Topics which covers articles, blogs and articles.

    Can guests be set to reply to articles only?

Related Topics

Collapse

Working...
X