Announcement

Collapse
No announcement yet.

PHP curl_exec warning

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • PHP curl_exec warning

    Hello,
    I'm getting the fellowing error on my Installation:
    Code:
    *650 FastCGI sent in stderr: "PHP message: PHP Warning:  curl_exec() has been disabled for security reasons in /core/vb/vurl/curl.php on line 344" while reading response header from upstream
    I know that I can remove it from the disabled functions in the php-fpm config but since I don't want to enable it, is there any particular disadvantage?

    Thanks for your assistance.

  • #2
    cURL is used as the preferred method to secure communications with external services like third-party logins (Facebook, Google, Twitter) and Paid Subscription Providers. Could be used to secure uploads from external sites as well. I am not sure about that. With this disabled, you won't be able to obtain full functionality with the software. However, the system should catch this error. What exactly is being done when the error is thrown?

    If you don't want to use cURL then your best option would be to uninstall the entire cURL library from PHP if you don't want to use it. Then we should be able to detect that it is missing and try a different processing route. Doesn't make sense to have the library installed if you're going to exclude the most important function in it.
    Last edited by Wayne Luke; Fri 9th Aug '19, 8:39am.
    Translations provided by Google.

    Wayne Luke
    The Rabid Badger - a vBulletin Cloud customization and demonstration site.
    vBulletin 5 Documentation - Updated every Friday. Report issues here.
    vBulletin 5 API - Full / Mobile
    I am not currently available for vB Messenger Chats.

    Comment

    widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
    Working...
    X