Announcement

Collapse
No announcement yet.

High cpu load from vbcron.php

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • BulliM
    commented on 's reply
    Thank you.

  • Wayne Luke
    replied
    You would have to manually publish articles on the front-end but there is no other location that would need to be disabled in the AdminCP.

    Leave a comment:


  • BulliM
    replied
    Since Zero-Day I've running our forums on a new server. I deleted all old files and recreated the site completly, as you recommended. So trending.php is reactivated.

    First, all works fine for about three weeks. Then it starts again. All half hours, cpu load runs high by about 60%. Then I've testet all scheduled tasks out and I think, I know now, what task caused the high load. It is this one, but only on half hours like 0.30, 1.30, 2.30 3.30 and so on.

    Klicke auf die Grafik für eine vergrößerte Ansicht  Name: scheduled_task_cpuload.png Ansichten: 0 Größe: 4,8 KB ID: 4426690

    Wayne Luke Do I have to deactivate this function anywhere else in admincp, when I deactivate this task in scheduled tasks?

    Leave a comment:


  • BulliM
    replied
    I did. Will see if it helps. Thanks so far!

    Leave a comment:


  • Wayne Luke
    replied
    If you're not using the Trending Topics module, then you can rename the script for this. Rename it to something like trending.php.bak and disable it in the Scheduled Tasks Manager. It won't be processed

    You can find the file in /core/includes/cron/.

    Leave a comment:


  • BulliM
    replied
    Update Trending Topic Stats

    Two times now.

    Leave a comment:


  • Wayne Luke
    replied
    Which task is being run when the issue occurs? It should be listed in the Schedule Task Log.

    Leave a comment:


  • BulliM
    commented on 's reply
    I already did. BTW: It is my tutorial on your site.

  • delicjous
    commented on 's reply
    You could disable the ajax cron task in settings. https://vbulletin-forum.de/articles/...3%BChren-plesk

  • BulliM
    replied
    I've done some tests now. First of all: Thereis no difference between old and new vbcron.php. Both are working similar.

    Then I've run all scheduled tasks by hand. They're running quite fast and without any errors. Then I've created a scheduled task, which creates a file. This task runs without other tasks at the same time. Running by hand works well and fast, but running by vbcron.php, file creation needs six minutes more! So thereis something responsible for a delay.

    Question: Runs vbcron.php only enabled scheduled tasks or also disabled scheduled tasks?

    Leave a comment:


  • BulliM
    commented on 's reply
    I'll try. thx

  • Wayne Luke
    replied
    Seems the file was refactored in 5.5.2. I don't know exactly why at this time though. You could try the 5.5.1 file and see if it still works. I'll have to discuss the issue with the developers.

    Leave a comment:


  • BulliM
    started a topic High cpu load from vbcron.php

    High cpu load from vbcron.php

    I use 'vbcron.php' * for the cronjobs in our forums. At full hours (eg. 1.00, 12.00) server have a PHP load of almost 100%. This results in pages are loaded slowly. I cannot explain, why this happens. I've updated to php 7.3 months ago. There're no errors in logs, cannot find anything is wrong. Server Settings and Optimization Options -> Enable Scheduled Tasks -> Off.

    Since I change back to vB software based "cronjobs", the problem is gone. But now the jobs are not executed, as it was before changing to vbcron.php. Of course I enabled scheduled tasks in AdminCP.

    My questions:

    Has anyone else that problem?
    Is this a bug?


    * Not only actual vbcron.php, least since three builds.
widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
Working...
X