Announcement

Collapse
No announcement yet.

Hooks in Admin Says Disable in Config

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Hooks in Admin Says Disable in Config

    Hooks in Admin Says Disable in Config but it is not disabled, it is enabled but still getting this message, please advise.

  • #2
    In /core/includes/config.php find this line:

    Code:
    $config['Misc']['debug'] = true;
    Change it to:
    Code:
    // $config['Misc']['debug'] = true;
    Translations provided by Google.

    Wayne Luke
    The Rabid Badger - a vBulletin Cloud customization and demonstration site.
    vBulletin 5 Documentation - Updated every Friday. Report issues here.
    vBulletin 5 API - Full / Mobile
    I am not currently available for vB Messenger Chats.

    Comment


    • #3
      That is the way it is in config but still says the message. ? hmmm

      Comment


      • #4
        What does the debug line in your /config.php file say? (the one in your vBulletin Root directory).

        The switch is being thrown somewhere in order to display that message.
        Translations provided by Google.

        Wayne Luke
        The Rabid Badger - a vBulletin Cloud customization and demonstration site.
        vBulletin 5 Documentation - Updated every Friday. Report issues here.
        vBulletin 5 API - Full / Mobile
        I am not currently available for vB Messenger Chats.

        Comment


        • #5

          Comment


          • #6
            I wouldn't be able to tell you why it happening other than one of those two values is being set to TRUE in one of your files somewhere for some reason. In a default installation, the only two places we set that are those two files.
            Translations provided by Google.

            Wayne Luke
            The Rabid Badger - a vBulletin Cloud customization and demonstration site.
            vBulletin 5 Documentation - Updated every Friday. Report issues here.
            vBulletin 5 API - Full / Mobile
            I am not currently available for vB Messenger Chats.

            Comment


            • #7
              Originally posted by Wayne Luke View Post
              I wouldn't be able to tell you why it happening other than one of those two values is being set to TRUE in one of your files somewhere for some reason. In a default installation, the only two places we set that are those two files.
              Maybe I am missing something, here is the text in my config

              // ******** SPECIAL SETTINGS ********
              // The following are settings/permissions that are not normally used but
              // are here for reference. Please be careful using them. Do not enable or
              // uncomment without understanding what they do first.

              // This allows you to disable modifications and extensions to the software.
              // If your site is not functioning well after installing or using a third
              // party modification, please enable this.
              define("ENABLE_HOOKS", true);

              Comment


              • #8
                I am sorry. I have been talking about the wrong thing this whole time and have completely spaced on your issue. I would like to blame the drugs from my emergency surgery on Easter but that probably isn't the case here.

                There is no constant/variable ENABLE_HOOKS in vBulletin. The constant is DISABLE_HOOKS. To enable them, you simply comment out the line like this:

                Code:
                // This allows you to disable modifications and extensions to the software.
                // If your site is not functioning well after installing or using a third
                // party modification, please enable this.
                // define("DISABLE_HOOKS", true);
                Make sure there is no line setting DISABLE_HOOKS to true in either of your config.php files.
                Translations provided by Google.

                Wayne Luke
                The Rabid Badger - a vBulletin Cloud customization and demonstration site.
                vBulletin 5 Documentation - Updated every Friday. Report issues here.
                vBulletin 5 API - Full / Mobile
                I am not currently available for vB Messenger Chats.

                Comment


                • #9
                  No worries, the setting as mentioned is correct as you will see in my pic, but the line that helped me is
                  "Make sure there is no line setting DISABLE_HOOKS to true in either of your config.php files."

                  That made me search and I found it again at the top of my config file for some reason, deleted it and it is fixed, thank you

                  Comment

                  Related Topics

                  Collapse

                  Working...
                  X