Announcement

Collapse
No announcement yet.

The requested URL /forum/auth/login-form was not found on this server.

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • The requested URL /forum/auth/login-form was not found on this server.

    I did a fresh install of my Linux Ubuntu server and Vbulletin 5.4.5.
    Everything is working fine but I am having problems with the .htaccess / URL / paths.
    The hyperlinks are not working. I forgot something but I don't know what.

    my forum is running under www/forum/

    See here the .htaccess file


    <IfModule mod_rewrite.c>
    RewriteEngine On

    # In some cases where you have other mod_rewrite rules, you may need to remove the
    # comment on the following RewriteBase line and change it to match your folder name.
    # This resets the other mod_rewrite rules for just this directory
    # If your site was www.example.com/forum, the setting would be /forum/
    RewriteBase /forum

    #To redirect users to the secure version of your site, uncomment the lines below
    #RewriteCond %{HTTPS} !=on
    RewriteRule .* https://%{SERVER_NAME}%{REQUEST_URI} [R=301,L]

    # Send css calls directly to the correct file VBV-7807
    RewriteRule ^css.php$ core/css.php [NC,L]

    # Redirect old install path to core.
    RewriteRule ^install/ core/install/ [NC,L]

    # Main Redirect
    RewriteCond %{REQUEST_URI} !\.(gif|jpg|jpeg|png|css)$
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule ^(.*)$ index.php?routestring=$1 [L,QSA]

    # Because admincp is an actual directory.
    RewriteRule ^(admincp/)$ index.php?routestring=$1 [L,QSA]

    </IfModule>

    <IfModule mod_deflate.c>
    AddOutputFilterByType DEFLATE application/atom+xml \
    text/javascript \
    application/x-javascript \
    application/javascript \
    application/json \
    application/rss+xml \
    application/vnd.ms-fontobject \
    application/x-font-ttf \
    application/xhtml+xml \
    application/xml \
    font/opentype \
    image/svg+xml \
    image/x-icon \
    text/css \
    text/html \
    text/plain \
    text/x-component \
    text/xml
    </IfModule>

    <IfModule mod_expires.c>
    ExpiresActive On
    ExpiresByType application/x-javascript A1209600
    ExpiresByType text/javascript A1209600
    ExpiresByType application/javascript A1209600
    ExpiresByType text/css A31536000
    ExpiresByType image/x-icon A2592000
    ExpiresByType image/icon A2592000
    ExpiresByType application/x-ico A2592000
    ExpiresByType application/ico A2592000
    ExpiresByType image/gif A2592000
    ExpiresByType image/jpeg A1209600
    ExpiresByType image/jpg A1209600
    ExpiresByType image/png A1209600
    ExpiresByType application/x-shockwave-flash A1209600
    ExpiresByType font/ttf A2592000
    ExpiresByType font/otf A2592000
    ExpiresByType font/x-woff A2592000
    ExpiresByType image/svg+xml A2592000
    ExpiresByType font/truetype A2592000
    ExpiresByType font/opentype A2592000
    ExpiresByType application/x-font-woff A2592000
    ExpiresByType application/vnd.ms-fontobject A2592000
    </IfModule>

    <IfModule mod_headers.c>
    Header set Connection keep-alive
    <filesmatch "\.(ico|flv|gif|swf|eot|woff|otf|ttf|svg)$">
    Header set Cache-Control "max-age=2592000, public"
    </filesmatch>
    <filesmatch "\.(jpg|jpeg|png)$">
    Header set Cache-Control "max-age=1209600, public"
    </filesmatch>
    <filesmatch "\.(eot|woff|otf|ttf|svg)$">
    Header set Cache-Control "max-age=2592000, public"
    </filesmatch>
    # css and js should use private for proxy caching https://developers.google.com/speed/...geProxyCaching
    <filesmatch "\.(css)$">
    Header set Cache-Control "max-age=31536000, private"
    </filesmatch>
    <filesmatch "\.(js)$">
    Header set Cache-Control "max-age=1209600, private"
    </filesmatch>
    </IfModule>

    #don't allow some files that shouldn't really be present to be directly accessed.
    #note that attachements should never be directly accessed by the webserver because
    #we have permissions on the that are checked in the PHP code.
    <FilesMatch "(^#.*#|\.(bak|config|dist|inc|ini|log|gz|tar|zip|sh|sql|sw[op])|~)$">
    Order allow,deny
    Deny from all
    Satisfy All
    </FilesMatch>

    My default.conf file under apache is:

    <VirtualHost *:80>
    ServerName meydan1967.net
    ServerAlias www.meydan1967.net

    RedirectPermanent / https://www.meydan1967.net/

    ErrorLog ${APACHE_LOG_DIR}/error.log
    CustomLog ${APACHE_LOG_DIR}/access.log combined



    </VirtualHost>

    <VirtualHost _default_:443>
    ServerName meydan1967.net
    ServerAlias www.meydan1967.net

    DocumentRoot /var/www/html


    SSLEngine on
    SSLCertificateFile /etc/net.crt
    SSLCertificateKeyFile /etc/net.key
    SSLCertificateChainFile /etc/bundle.crt


    ErrorLog ${APACHE_LOG_DIR}/error.log
    CustomLog ${APACHE_LOG_DIR}/access.log combined

    </VirtualHost>

    What did I forget to do?
    Last edited by Sergio61; Tue 8th Jan '19, 11:31pm.

  • #2
    Assuming you have renamed the htaccess.txt file to .htaccess, make sure AllowOverride is set to all in httpd.conf. If you change this value you will need to restart Apache afterwards.
    MARK.B | vBULLETIN SUPPORT

    TalkNewsUK - My vBulletin 5.5.2 Demo
    AdminAmmo - My Cloud Demo

    Comment


    • Sergio61
      Sergio61 commented
      Editing a comment
      The main page is now loading good. Now I need to fix the rewrite issue. I can't get anywhere from the homepage.
      Do you have any other suggestions?

  • #3
    Originally posted by Mark.B View Post
    Assuming you have renamed the htaccess.txt file to .htaccess, make sure AllowOverride is set to all in httpd.conf. If you change this value you will need to restart Apache afterwards.
    Yes I have .htaccess file in the forum folder without .txt.
    I have enabled mod_rewrite.
    I added AllowOverride All in apache2.conf file.
    Restarted the server but no luck.


    apache2.conf file:



    <Directory /var/www/>
    Options Indexes FollowSymLinks
    AllowOverride All
    Require all granted
    </Directory>

    Comment


    • #4
      Originally posted by Mark.B
      Can you log in to admincp?
      Are teh three URL settings correct? (One must have /core at the end).
      No I am not able to log in unfortunately.

      I have to access admincp by the https://www.meydan1967.net/forum/core/admincp/ URL, then I am getting a login screen, but after trying to login it goes back to https://www.meydan1967.net/forum/login.php?do=login and saying the site is not working.

      I enabled the default config file.
      I enabled the mod_rewrite function.
      AllowOverride is set to Yes in apache2.conf file.

      SSL is working, yesterday the forums homepage was working but now I not after changing the collation of the database.


      Used the tools.php file to check :

      Change location of site. (This is the vboptions[frontendurl] setting)
      Currently: https://www.meydan1967.net/forum

      Comment


      • #5
        I fixed it. my default.conf was not set up properly

        Comment


        • #6
          Glad you got it sorted and thanks for coming back to let us know.
          MARK.B | vBULLETIN SUPPORT

          TalkNewsUK - My vBulletin 5.5.2 Demo
          AdminAmmo - My Cloud Demo

          Comment

          Related Topics

          Collapse

          Working...
          X