Announcement

Collapse
No announcement yet.

Error Invalid SQL: INSERT INTO adminlog

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Error Invalid SQL: INSERT INTO adminlog

    Everywhere in my admincp i am getting this error. My server cpu was getting too busy with mysql. so i decided to do some changes and re import the database. But now I am getting this error.

    I have vbulletin 5.4.4 and will try to upgrade.

    Error Invalid SQL: INSERT INTO adminlog (`userid`,`dateline`,`script`,`action`,`extrainfo`,`ipaddress`) VALUES('425',1546947013,'prefix.php','','','111.200.111.111') /**adminlog**/;

    Kayıt izi:
    ## /var/www/html/forum/core/vb/database.php(1189) Exception Thrown #0 /var/www/html/forum/core/vb/database/mysqli.php(201): vB_Database->halt()
    #1 /var/www/html/forum/core/vb/database.php(542): vB_Database_MySQLi->execute_query(true, Object(mysqli))
    #2 /var/www/html/forum/core/vb/db/query/insert.php(115): vB_Database->query_write('Invalid SQL:\r\nI...')
    #3 /var/www/html/forum/core/vb/db/query/insert.php(98): vB_dB_Query_Insert->doInserts()
    #4 /var/www/html/forum/core/vb/db/assertor.php(301): vB_dB_Query_Insert->execSQL()
    #5 /var/www/html/forum/core/includes/adminfunctions.php(3106): vB_dB_Assertor->assertQuery('vBForum:adminlo...', Array)
    #6 /var/www/html/forum/core/admincp/prefix.php(43): log_admin_action('')
    #7 /var/www/html/forum/includes/api/interface/collapsed.php(142): require_once('/var/www/html/f...')
    #8 /var/www/html/forum/includes/vb5/frontend/controller/relay.php(33): Api_Interface_Collapsed->relay('admincp/prefix....')
    #9 /var/www/html/forum/index.php(74): vB5_Frontend_Controller_Relay->admincp('prefix.php')
    #10 {main}
    Last edited by Wayne Luke; Tue 8 Jan '19, 1:18pm.

  • #2
    Updating has no changes. I have still the same error.

    Comment


    • #3
      Upgrading wouldn't fix an error like this. The only time upgrading will fix a database error is when you try using a new version's files on the database from an older version.

      Did you receive an email with the complete error to your technical email address as specified in the /core/includes/config.php file? I only ask because I can copy and paste the query above and it runs fine on vBulletin 5. So there is something else causing the error and the easiest way to tell is with the entire error message.

      What version of MySQL are you using?

      What is the structure of your adminlog table?
      Translations provided by Google.

      Wayne Luke
      The Rabid Badger - a vBulletin Cloud demonstration site.
      vBulletin 5 API

      Comment


      • #4
        Originally posted by Wayne Luke View Post
        Upgrading wouldn't fix an error like this. The only time upgrading will fix a database error is when you try using a new version's files on the database from an older version.

        Did you receive an email with the complete error to your technical email address as specified in the /core/includes/config.php file? I only ask because I can copy and paste the query above and it runs fine on vBulletin 5. So there is something else causing the error and the easiest way to tell is with the entire error message.

        What version of MySQL are you using?

        What is the structure of your adminlog table?
        I did a fresh install of my linux server. It was having more issues.

        Comment


        • #5
          Originally posted by Sergio61 View Post

          I did a fresh install of my linux server. It was having more issues.
          Then we can't resolve the above issue. All traces of what may have caused it would be removed with a fresh install.
          Translations provided by Google.

          Wayne Luke
          The Rabid Badger - a vBulletin Cloud demonstration site.
          vBulletin 5 API

          Comment

          Related Topics

          Collapse

          Working...
          X