Announcement

Collapse
No announcement yet.

vbulletin5 http to https with OpenSSL problem

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • vbulletin5 http to https with OpenSSL problem

    hello

    I am running vb5 on apache server and I want to apply https using OpenSSL.
    so I set SSL configuration on my apache server and it works! (wiki site also running on apache and https works well on wiki site)
    and to apply vb5, I changed site URL / Login / Core address in adminCP options,

    after changing address, forum index and admincp page works well, but login page is not working.

    when I clicked Login page appears below login picture


    only admin account can login forum using this route
    go to admincp -> login -> click 'Site Home Page'

    using this route, forum is working well on https.

    Only login page is not wokring.. so nomal user can't login my forum

    how can I fix it?

    ++

    access login page directly using
    (https)forumaddress/auth/login-form
    it redirect
    (https)forumaddress/auth/login-form?vb_login_redirected=1&url=aHR0cHM6Ly9mb3J1bS5pZGlzLmNvLmty

    ++

    (https)forumaddress/auth/login-form?vb_login_redirected=1&url=aHR0cHM6Ly9mb3J1bS5pZGlzLmNvLmty

    aHR0cHM6Ly9mb3J1bS5pZGlzLmNvLmty decoding result is loginURL in AdminCP.

    it's correct..

    Last edited by idis; Wed 12th Dec '18, 5:09pm.

  • #2
    Can't solve the issue with the lack of information. Make sure your login URL matches the Frontend URL. Make sure the Core URL is also https and has /core at the end.

    That is literally all the configuration that vBulletin has in regards to HTTP vs. HTTPS. Everything else is server configuration.
    Translations provided by Google.

    Wayne Luke
    The Rabid Badger - a vBulletin Cloud customization and demonstration site.
    vBulletin 5 Documentation - Updated every Friday. Report issues here.
    vBulletin 5 API - Full / Mobile
    I am not currently available for vB Messenger Chats.

    Comment


    • idis
      idis commented
      Editing a comment
      yes. changed URL setting is uploaded first picture.

      I changed 3 URL only http:// to https://

      but it's not working.

    • Wayne Luke
      Wayne Luke commented
      Editing a comment
      The first loaded picture tells me nothing informative because all the information I need is blacked out. I just have to take your word for it. You'll have to ask your hosting provider why that URL is not redirecting properly.

Related Topics

Collapse

Working...
X