Announcement

Collapse
No announcement yet.

Invalid page when i protected admincp with cpanel

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Invalid page when i protected admincp with cpanel

    i get Invalid page when i protected admincp with cpanel user name and password

    When a user attempts to access the protected directory through a browser, the site will prompt them to enter a username and password. The name that you choose for the protected directory will also display.

    When i finish i get

    Invalid Page URL. If this is an error and the page should exist, please contact the system administrator and tell them how you got this message.

  • #2
    my .htaccess

    Code:
    <IfModule mod_rewrite.c>
        RewriteEngine On
    
        # In some cases where you have other mod_rewrite rules, you may need to remove the 
        # comment on the following RewriteBase line and change it to match your folder name. 
        # This resets the other mod_rewrite rules for just this directory
        # If your site was www.example.com/forum, the setting would be /forum/
        #RewriteBase /
    
        #To redirect users to the secure version of your site, uncomment the lines below 
        #RewriteCond %{HTTPS} !=on
        #RewriteRule .* https://%{SERVER_NAME}%{REQUEST_URI} [R=301,L]
    
        # Send css calls directly to the correct file VBV-7807
        RewriteRule ^css.php$ core/css.php [NC,L]
    
        # Redirect old install path to core.
        RewriteRule ^install/ core/install/ [NC,L]
    
        # Main Redirect
        RewriteCond %{REQUEST_URI} !\.(gif|jpg|jpeg|png|css)$
        RewriteCond %{REQUEST_FILENAME} !-f
        RewriteCond %{REQUEST_FILENAME} !-d
        RewriteRule ^(.*)$ index.php?routestring=$1 [L,QSA]
    
        # Because admincp is an actual directory.
        RewriteRule ^(admincp/)$ index.php?routestring=$1 [L,QSA]
    
    </IfModule>
    
    <IfModule mod_deflate.c>
        AddOutputFilterByType DEFLATE application/atom+xml \
                              text/javascript \
                              application/x-javascript \
                              application/javascript \
                              application/json \
                              application/rss+xml \
                              application/vnd.ms-fontobject \
                              application/x-font-ttf \
                              application/xhtml+xml \
                              application/xml \
                              font/opentype \
                              image/svg+xml \
                              image/x-icon \
                              text/css \
                              text/html \
                              text/plain \
                              text/x-component \
                              text/xml
    </IfModule>
    
    <IfModule mod_expires.c>
        ExpiresActive On
        ExpiresByType application/x-javascript A1209600
        ExpiresByType text/javascript A1209600
        ExpiresByType application/javascript A1209600
        ExpiresByType text/css A31536000
        ExpiresByType image/x-icon A2592000
        ExpiresByType image/icon A2592000
        ExpiresByType application/x-ico A2592000
        ExpiresByType application/ico A2592000
        ExpiresByType image/gif A2592000
        ExpiresByType image/jpeg A1209600
        ExpiresByType image/jpg A1209600
        ExpiresByType image/png A1209600
        ExpiresByType application/x-shockwave-flash A1209600
        ExpiresByType font/ttf A2592000
        ExpiresByType font/otf A2592000
        ExpiresByType font/x-woff A2592000
        ExpiresByType image/svg+xml A2592000
        ExpiresByType font/truetype A2592000
        ExpiresByType font/opentype A2592000
        ExpiresByType application/x-font-woff A2592000
        ExpiresByType application/vnd.ms-fontobject A2592000
    </IfModule>
    
    <IfModule mod_headers.c>
        Header set Connection keep-alive
        <filesmatch "\.(ico|flv|gif|swf|eot|woff|otf|ttf|svg)$">
            Header set Cache-Control "max-age=2592000, public"
        </filesmatch>
        <filesmatch "\.(jpg|jpeg|png)$">
            Header set Cache-Control "max-age=1209600, public"
        </filesmatch>
        <filesmatch "\.(eot|woff|otf|ttf|svg)$">
            Header set Cache-Control "max-age=2592000, public"
        </filesmatch>
        # css and js should use private for proxy caching https://developers.google.com/speed/docs/best-practices/caching#LeverageProxyCaching
        <filesmatch "\.(css)$">
            Header set Cache-Control "max-age=31536000, private"
        </filesmatch>
        <filesmatch "\.(js)$">
            Header set Cache-Control "max-age=1209600, private"
        </filesmatch>
    </IfModule>
    
    #don't allow some files that shouldn't really be present to be directly accessed.
    #note that attachements should never be directly accessed by the webserver because
    #we have permissions on the that are checked in the PHP code.
    <FilesMatch "(^#.*#|\.(bak|config|dist|inc|ini|log|gz|tar|zip|sh|sql|sw[op])|~)$">
        Order allow,deny
        Deny from all
        Satisfy All
    </FilesMatch>

    Comment


    • #3
      You haven't renamed the admincp folder have you? It must be called admincp.
      MARK.B | vBULLETIN SUPPORT

      TalkNewsUK - My vBulletin 5.6.3 Demo
      AdminAmmo - My Cloud Demo

      Comment


      • #4
        Did you put the directory protection on the /admincp/ directory or the /core/admincp/ directory? I would try /core/admincp/ first.

        Comment


        • #5
          Originally posted by Mark.B View Post
          You haven't renamed the admincp folder have you? It must be called admincp.
          i dont renamed admincp

          i just protection on the /admincp/

          and i get Invalid page

          Comment


          • #6
            Originally posted by Joe D. View Post
            Did you put the directory protection on the /admincp/ directory or the /core/admincp/ directory? I would try /core/admincp/ first.
            i try /core/admincp/ first. i protected but not working

            Comment


            • #7
              I recommend not using cPanel to protect the AdminCP. When you use cPanel, it changes the default and required .htaccess file and causes problems with internal redirects.

              We provide two methods to protect your AdminCP within the software. Both are enabled within the /core/config.php. The recommended method is to use Two-Factor Authentication in addition to a mobile device (it doesn't need an internet connection once the app is installed). The second is to use IP Restriction by listing your IP Address in the config.php file.
              Translations provided by Google.

              Wayne Luke
              The Rabid Badger - a vBulletin Cloud demonstration site.
              vBulletin 5 API

              Comment

              Related Topics

              Collapse

              Working...
              X