Announcement

Collapse
No announcement yet.

Special Character issue on vb5.4.4 after upgraded from vb4.1.10

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • [Bug / Issue] Special Character issue on vb5.4.4 after upgraded from vb4.1.10

    Hi, brief info for what i did for my upgrade from vb4.1.10 to vb5.4.4

    1. mysqldump vb4.1.10 data and rsync it to new server and restore back
    2. copy fresh vb5.4.4 files to new server by using fliezilla ftp tool
    3. run upgrade.php and encountered 1 time screen no refresh and i resume back the upgrade.php with no error.
    4. After done upgrade. can access to admincp and access main forum
    5. encountered database collation issue - user profile page return error page
    6. changed all my database tables to utf8-generial-ci from phpmyadmin. usergroup issue solved
    7. Encountered copy and paste issue when content involving special chacracters like ' and ".
    8. Change character set at language manager to UTF-8 from ISO-8859-1
    9. also uncomment charset utf8 in include.config.php

    New server info, dedicated server, mysql 5.6.38-1, php ea-php71, centos 7.5


    current issue

    1. My Vbulletin 5.4.4 got the "Please enter message text" error when a guest was trying to register a new account and hit the complete signup button. New user can be seen in user list but user did not get any welcome message. I deleted the username in welcome email message field from admincp --> option --> user registration options. No more "Please enter message text" error message. But also no welcome message. i found out that the pm title and pm body in welcome PM can not take special characters like { ' ". if i put only text and number. no error and pm can send through

    2. in many posts but not all. i saw many ’. it suppose to be '. Also have other strange characters

    3. when ever i copy and post a paragraph that contain ' or " or some other special characters, not all are pasted. seems like the paragraph got cut after the special characters

    4. in admincp - stype template. my html code got cut as well when i paste. cut after special character "

    5. copy or move selected posts only to new thread - but the entire posts in the thread was copied or moved over

    6. copy or move 10 selected posts to existing thread - 1st post was moved as post, the other 9posts become comments under the first post.


    P/S: not sure 5 and 6 issues also related to special character. because the result always not consistent. Some posts can move with no issue.

    Thanks in advance for the help
    Last edited by holymannn; Wed 24th Oct '18, 4:29pm.

  • #2
    First... Undo #9 - also uncomment charset utf8 in include.config.php

    Comment this line out.

    1. The {} characters are already special and used in phrases. They denote variable tokens that the software should replace with valid data. You shouldn't use them in either titles or phrase text.

    2. This is actually a "Smart Apostrophe". It curls inward. If you are not using English, then you will most likely need to set a proper UTF-8 Locale for your language.

    3. Same issue as #2. Many UTF-8 characters actually contain the ASCII byte for end of file. Quotations are among these.

    4. Same issue as #2

    5. Exact steps are necessary to tell if this is a user issue or a fault in the software.

    6. This is by current design.
    Translations provided by Google.

    Wayne Luke
    The Rabid Badger - a vBulletin Cloud demonstration site.
    vBulletin 5 API - Full / Mobile
    Vote for your favorite feature requests and the bugs you want to see fixed.

    Comment


    • #3
      Originally posted by Wayne Luke View Post
      First... Undo #9 - also uncomment charset utf8 in include.config.php

      Comment this line out.

      1. The {} characters are already special and used in phrases. They denote variable tokens that the software should replace with valid data. You shouldn't use them in either titles or phrase text.

      2. This is actually a "Smart Apostrophe". It curls inward. If you are not using English, then you will most likely need to set a proper UTF-8 Locale for your language.

      3. Same issue as #2. Many UTF-8 characters actually contain the ASCII byte for end of file. Quotations are among these.

      4. Same issue as #2

      5. Exact steps are necessary to tell if this is a user issue or a fault in the software.

      6. This is by current design.
      done undo #9

      1. arent {1} {2} default phrase form vbulletin 5 right? {1} is username, while {2} is site name. the code is hi {1}, welcome to {2}. i wish the send welcome pm to new member and greet them with correct username.

      2, 3 and 4 issue just gone. i dont know why

      5. i have opened a ticket for this and put in detail steps

      6. this is abit weird. i dont wish my post that copy over coverted to comment. i want those posts that copied over remain as posts. any workaround? posible to convert comment back to post?

      Comment


      • #4
        Originally posted by holymannn View Post
        1. arent {1} {2} default phrase form vbulletin 5 right? {1} is username, while {2} is site name. the code is hi {1}, welcome to {2}. i wish the send welcome pm to new member and greet them with correct username.
        No.. {1} is the first variable. {2} is the second variable. {3} is the third. Etc.... They can have different values for each and every phrase depending on context.

        vBulletin 5.4.5 will provide shortcodes for {username}, {sitename}, and others that can be used in phrases.

        Translations provided by Google.

        Wayne Luke
        The Rabid Badger - a vBulletin Cloud demonstration site.
        vBulletin 5 API - Full / Mobile
        Vote for your favorite feature requests and the bugs you want to see fixed.

        Comment


        • #5
          Originally posted by Wayne Luke View Post
          First... Undo #9 - also uncomment charset utf8 in include.config.php

          Comment this line out.

          1. The {} characters are already special and used in phrases. They denote variable tokens that the software should replace with valid data. You shouldn't use them in either titles or phrase text.

          2. This is actually a "Smart Apostrophe". It curls inward. If you are not using English, then you will most likely need to set a proper UTF-8 Locale for your language. (my site is using english)

          3. Same issue as #2. Many UTF-8 characters actually contain the ASCII byte for end of file. Quotations are among these.

          4. Same issue as #2

          5. Exact steps are necessary to tell if this is a user issue or a fault in the software.

          6. This is by current design.
          Hi Wayne,

          Sorry, issue 3 still happened on some users when they copy text that content "Smart Apostrophe" from other place and paste it in my forum and post got cut off. Is there a way to force "Smart Apostrophe" become normal apostrophe?

          Comment

          Related Topics

          Collapse

          Working...
          X