Announcement

Collapse
No announcement yet.

Major problem after following manual to create test installation environment (main site broken)

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • [Bug / Issue] Major problem after following manual to create test installation environment (main site broken)

    So, i was following the routines found in https://www.vbulletin.com/docs/html/upgrade_testsite to put up an test environment to try out a solution for another issue.

    In step 2 this text is found:

    "Warning:

    ***DO NOT CLOSE YOUR BROWSER AFTER THE ABOVE STEP***"

    The problem is that i was automatically logged off after i updated the URL:s. And i was not able to come back to the settings after the backup was generated.

    So, the main site was broken i was not able to fix it. So, now im importing the backup from tonight and hopefully i get it working again.

    I have created test sites before (in vBulletin 4.2.5) and that have worked. But something must have changed in the routines up to vBulletin 5.4.4.

    Is this a common problem? Is the routines in the manual faulty? What is the correct wat to create a test site in vBulletin 5.4.4?

    Additional info:
    IIS 10
    PHP 7.2.7
    MySQL 5.7.20
    vBulletin 5.4.4
    Main forum is in root /
    testvb in folder /testvb/
    Last edited by Mr B; Tue 16th Oct '18, 11:39pm.

  • #2
    You shouldn't be logged off. Though when you change the URL, the correct URL to use changes.

    I recommend following these steps.
    1. Make a copy of your current database.
    2. Upload the vBulletin files to a new directory in your server.
    3. Edit .htaccess find the line: # RewriteBase / and change it to read: RewriteBase /vbtest/
    4. Rename config.php.bkp to config.php
    5. Edit /config.php and change the cookie prefix value to something unique.
    6. Rename /core/includes/config.php.new to config.php
    7. Edit /core/includes/config.php to include your database.
    8. Change the cookie prefix in /core/includes/config.php to match the value in /config.php
    9. Upload tools.php from your do_not_upload folder to the core/install directory of your new test install.
    10. Run tools.php in your browser. (yourdomain/pathtotestinstall/core/install/tools.php)
    11. Choose the tool to change the location of your site to the new URL.
    12. Delete /core/install


    To fix the URL on your live site -
    1. Upload /core/install/
    2. Upload tools.php to your /core/install directory.
    3. Load tools.php in your browser (yourdomain/pathtovbulletin/core/install/tools.php
    4. Update the location of the site.
    5. Delete /core/install
    Both should work properly. Will look into updating the manual as time is available.
    Translations provided by Google.

    Wayne Luke
    The Rabid Badger - a vBulletin Cloud demonstration site.
    vBulletin 5 API - Full / Mobile
    Vote for your favorite feature requests and the bugs you want to see fixed.

    Comment


    • #3
      Originally posted by Wayne Luke View Post
      You shouldn't be logged off. Though when you change the URL, the correct URL to use changes.

      I recommend following these steps.
      1. Make a copy of your current database.
      2. Upload the vBulletin files to a new directory in your server.
      3. Edit .htaccess find the line: # RewriteBase / and change it to read: RewriteBase /vbtest/
      4. Rename config.php.bkp to config.php
      5. Edit /config.php and change the cookie prefix value to something unique.
      6. Rename /core/includes/config.php.new to config.php
      7. Edit /core/includes/config.php to include your database.
      8. Change the cookie prefix in /core/includes/config.php to match the value in /config.php
      9. Upload tools.php from your do_not_upload folder to the core/install directory of your new test install.
      10. Run tools.php in your browser. (yourdomain/pathtotestinstall/core/install/tools.php)
      11. Choose the tool to change the location of your site to the new URL.
      12. Delete /core/install


      To fix the URL on your live site -
      1. Upload /core/install/
      2. Upload tools.php to your /core/install directory.
      3. Load tools.php in your browser (yourdomain/pathtovbulletin/core/install/tools.php
      4. Update the location of the site.
      5. Delete /core/install
      Both should work properly. Will look into updating the manual as time is available.
      Thanks Wayne! I will try your alternative solution out when some other issues are fixed.

      I know that i shouldnt be logged off. But i was that directly when i pushed the save-button and couldnt log in again. I have followed the manuals procedure many times in vBulletin 4 and it have worked every time. This was the first time in vBulletin 5 so i dont know if it has worked before. I will not test again until i know for sure that it works.

      I tried the tools.php to fix the main site but it did not work. So, it ended up in restoring the backup to get it working again.

      Comment


      • #4
        Wayne Luke does it matter if the test version of vBulletin is under folder /vbtest/ or /testvb/ ? The manual says /testvb/ and you says /vbtest/

        Comment


        • #5
          Originally posted by Mr B View Post
          Wayne Luke does it matter if the test version of vBulletin is under folder /vbtest/ or /testvb/ ? The manual says /testvb/ and you says /vbtest/
          It's fine either way. As long as it's obvious it's a test copy, and as long as it isn't viewable to the public (note: you need to set .htaccess protection for this, as simply having it closed isn't sufficient).
          MARK.B | vBULLETIN SUPPORT

          TalkNewsUK - My vBulletin 5.5.6 Demo
          AdminAmmo - My Cloud Demo

          Comment

          Related Topics

          Collapse

          Working...
          X