Announcement

Collapse
No announcement yet.

Special characters dissapear

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • [Bug / Issue] Special characters dissapear

    Hi,

    Since we've migrated vBulletin5 from Ubuntu to Windows we're experiencing issues with special characters like , , , , etc.
    On Ubuntu we were running Apache and PHP7.0 (I think). On the Windows machine we're running IIS10, PHP7.2 and probably a slightly newer MySQL version.

    Hopefully one could help me to solve this.

  • #2
    Go to Language Manager in the AdminCP. Languages & Phrases -> Language Manager.

    Edit your Language by clicking on the [Edit Settings] link.
    Change the HTML Character Set from whatever it is currently to UTF-8 (exactly like this).
    Save the page.

    If that doesn't fix it, then make sure that your MySQL databases have the exact same collation and character sets defined.
    Translations provided by Google.

    Wayne Luke
    The Rabid Badger - a vBulletin Cloud demonstration site.
    vBulletin 5 API - Full / Mobile
    Vote for your favorite feature requests and the bugs you want to see fixed.

    Comment


    • #3
      Hi Wayne,

      Unfortunately this doesn't help.
      Strange thing is. In privatemessages the characters dissapear. In forum posts they're replaces by a question mark.

      Comment


      • #4
        Solved this.
        Nowadays MySQL used utf8md4 als default connection collation. After changing this to utf8 the problem was resolved.

        Comment

        Related Topics

        Collapse

        Working...
        X