Announcement

Collapse
No announcement yet.

Incorrect user and redirect paths

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • [Bug / Issue] Incorrect user and redirect paths

    We have installed vbulletin on server A. Server B is configured to use /forum/ which /forum/ points to Server A. Our vBulletin URL and Login URL are as follows:

    Code:
    // vBulletin URL
    https://www.example.com/forum
    // core
    https://www.example.com/forum/core
    Everything seems to work. When an admin is on an user profile page and clicks the edit button (that pencil), it takes us to the admincp but displays a blank page. The error is that of mixed content, the page is trying to load:

    Code:
    // in console, it's blocking:
    http://www.example.com/admincp/user.php?do=edit&u=<userid>
    Two things here:
    1. It's loading http instead of https
    2. where is the /forum/
    I cannot think of a setting to change. In our .htaccess file, if I uncomment:

    Code:
    # RewriteBase /forum/
    our site breaks. Was that really meant to be uncommented and sort the error it faces when uncommented?

  • #2
    Add the following to your headinclude template:

    <meta http-equiv="Content-Security-Policy" content="upgrade-insecure-requests">

    Does that remedy the mixed content error?

    You have modified your software so much it is impossible to know what to do about the routing without actually looking at it.

    Comment


    • #3
      You may recall we mentioned some time ago that you should not edit the php files that handle routing. This is exactly the sort of reason why.

      You should take a backup of the files and database and restore a complete set of default files.
      MARK.B | vBULLETIN SUPPORT

      TalkNewsUK - My vBulletin 5.5.4 Demo
      AdminAmmo - My Cloud Demo

      Comment


      • #4
        Sorry but nothing to do with that file: routing.php. I've also reverted all changes and same issue. Before I ask questions, I revert all changes.

        Comment


        • #5
          Go to Settings -> Options -> Site Name / URL / Contact Details. Make sure that Always use Forum URL as Base Path is set to Yes.
          Translations provided by Google.

          Wayne Luke
          The Rabid Badger - a vBulletin Cloud customization and demonstration site.
          vBulletin 5 Documentation - Updated every Friday. Report issues here.
          vBulletin 5 API - Full / Mobile
          I am not currently available for vB Messenger Chats.

          Comment

          Related Topics

          Collapse

          Working...
          X