Announcement

Collapse
No announcement yet.

Last Post Column is empty on forum homepage for some users (5.4.1)

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • [Bug / Issue] Last Post Column is empty on forum homepage for some users (5.4.1)

    So here's the situation. On my forum, everything is working good, but we have a few issues that I'm unable to figure out. The biggest issue is that on the forum homepage, it lists the forums and the last column is the "Last Post", which is supposed to list the last post on that forum. If you are NOT logged in, it shows them. If you are logged in, though, some people are seeing them and some aren't. One thing I did notice: When you are logged in, if the forum has no new posts (since you last logged in), that's when the last post doesn't show. But it's only with some users. I assume that there's some permission issue, but I'm unable to find any permission for seeing the last post here. Can anyone help to get me to fix this so that the last post of the forum shows up for EVERY user, no matter what? Thanks!

  • #2
    This will happen if the user cannot see the last post. This can be due to not having permissions to view content in that channel or the last post has been deleted or needs to be approved.

    To help alleviate the read marking issues that can be associated with this, make sure that your Read Marking is set to Database (Automatic Marking).

    Settings -> Options -> General Settings -> Topic/Forum Read Marking Type
    Translations provided by Google.

    Wayne Luke
    The Rabid Badger - a vBulletin Cloud customization and demonstration site.
    vBulletin 5 Documentation - Updated every Friday. Report issues here.
    vBulletin 5 API - Full / Mobile
    I am not currently available for vB Messenger Chats.

    Comment


    • #3
      Thank you for that. I just verified in the settings that that option is already checked. Thanks for pointing me in the right direction. My issue was that the user was assigned to a user group (multiple user groups actually) that didn't have the permission to view Topic Content. I turned it on for them and it worked. Thanks so much!

      Comment

      widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
      Working...
      X