Announcement

Collapse
No announcement yet.

Can't get blogs working (permissions issue?)

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Can't get blogs working (permissions issue?)

    We upgraded to 5.4.3 this past weekend from 5.4.2. Previous installation was 4.2.3. Everything seems to work except blogs. I would like certain usergroups to be able to create blogs, but they keep getting "Sorry, you are not authorized to view this page" when clicking on "Create a New Blog".

    I have reset the permissions on the blogs channel, ensured that the usergoup in question has permission to create channels in that channel and made sure the top level permissions match too. The usergroup also has permission to create channels and blogs in the usergroup manager. I think I have tried pretty much every combination I have found may make sense, but it still doesn't work. The Admin (me) can create blogs without issue.

    I know that's not much information to go on, but I really am at a loss what to try next. Any thoughts / inputs much appreciated.

    Just in case it's relevant, here is the server info:
    Click image for larger version

Name:	sw forum.PNG
Views:	18
Size:	24.4 KB
ID:	4397679

  • #2
    DO they have the "Can Create Channel" permission on the Home Channel? They need to be able to create channels in order to create blogs and usergroups. How many channels can they create? I think the default value is 5 (Usergroups -> Usergroup Manager to see the value).

    Would need to see the entire set of permissions for a group that is affected.

    What are the permissions for the Channel * groups (Owner, Moderator, Member). These should be reverted back to the defaults that we ship with.
    Translations provided by Google.

    Wayne Luke
    The Rabid Badger - a vBulletin Cloud customization and demonstration site.
    vBulletin 5 Documentation - Updated every Friday. Report issues here.
    vBulletin 5 API - Full / Mobile
    I am not currently available for vB Messenger Chats.

    Comment


    • #3
      Can Create Channel and Can Create Blog were both already active for the usergroups in question. Can Create Channel was also already active for the Home Channel. Permissions for the Channel * Groups were unmodified from the original installation. What was missing was a number of channels they could create. The field was empty. I have now inserted 5 and will see if they can now use the blogs.

      Thanks very much for your help.

      Comment


      • #4
        Just a quick post to confirm this solved the problem. Many thanks again to Wayne for the help.

        Comment

        Related Topics

        Collapse

        Working...
        X