Announcement

Collapse
No announcement yet.

Adding images not functional in advance editor

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Adding images not functional in advance editor

    I have a user that can upload attachements (images) to a post, but cannot insert images using the button in the advanced editor.
    Click image for larger version

Name:	image_7550.png
Views:	8
Size:	70.3 KB
ID:	4395015

    I have checked his permissions and the channel permissions and cannot find a reason that this is not working.

    P.S. He can add images from the advanced editor in another channel. I copied the entire set of permissions for that channel to the channel with the issue and nothing changed
    PP.S. I can add images (as admin) without and issues, so I am assuming there is another set of permissions somewhere that I haven't yet found?

  • #2
    The Add Image as Attachment and the Insert Image button in the editor toolbar use the same processes to insert images into the text. They are duplicates of each other. However, the Javascript is a different in each case. This sounds like something on the user's machine is conflicting with the Javascript in this instance. When he tries to insert an image via the Editor Toolbar, are any error messages logged in his browser's console?
    Translations provided by Google.

    Wayne Luke
    The Rabid Badger - a vBulletin Cloud customization and demonstration site.
    vBulletin 5 Documentation - Updated every Friday. Report issues here.
    vBulletin 5 API - Full / Mobile
    I am not currently available for vB Messenger Chats.

    Comment


    • #3
      Thanks for this input, Wayne. He can post without issues in other channels of the forum -- it is just in this one channel that the issue appears to exist. He has not sent me any additional error information.

      I have told him to clear cookies and cache and try again and will let you know what happens.

      Comment


      • #4
        The user in question has run some trials as follow:
        I have done the following tests:

        1) I have tried Chrome, Firefox and Safari. The Upload Images tab does not show.
        2) I have tried Chrome, Firefox and Safari with a Private Browsing window. The Upload Images tab does not show.
        3) I have cleared Cookies and Cache in Firefox and Safari. The Upload Images tab does not show.
        4) I have accessed the forum (Full Browser) via iPad using Safari. The Upload Images tab does not show.

        Sometimes, during these tests, the Upload Images tab showed for half second or less and then really fast it disappeared. Of all the tests I have done this has happened twice. It is like system detecting something and then taking it away. They seemed to have showed randomly. With no particular pattern. Not after having cleared cookies or cache.
        As noted previously, this is only happening in one channel and not the others he has access to. The only difference in permissions to the other channels is that he cannot start a topic in the channel.

        Thanks again for your advice and support.

        Comment

        Related Topics

        Collapse

        Working...
        X