Announcement

Collapse
No announcement yet.

vB-5.4.2: dailyDigest fails with node_permission_section error 'subscriptions'

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • [Bug / Issue] vB-5.4.2: dailyDigest fails with node_permission_section error 'subscriptions'

    Hello,

    I'm running the latest vBulletin ver. 5.4.2.
    We have a daily digest running, which crashes with the follwing message in vB5_Route_Subscription->__construct(Array, Array, '', ''):

    Code:
    Exception: API Error
    Error: node_permission_section
    Args:
    array (
    0 => 'subscriptions',
    )
    Although I'm unsure, this seems to be the relevant code:
    Code:
      
     [COLOR=#000080][B]if [/B][/COLOR]([COLOR=#660000]$this[/COLOR]->[COLOR=#660e7a][B]arguments[/B][/COLOR][[COLOR=#008000][B]'tab'[/B][/COLOR]] == [COLOR=#008000][B]'subscriptions' [/B][/COLOR][COLOR=#000080][B]AND [/B][/COLOR]![COLOR=#660000]$userInfo[/COLOR][[COLOR=#008000][B]'showSubscriptions'[/B][/COLOR]]) {    [COLOR=#000080][B]throw new [/B][/COLOR]vB_Exception_NodePermission([COLOR=#008000][B]'subscriptions'[/B][/COLOR]); } [COLOR=#000080][B][/B][/COLOR]
    Code:
    Stacktrace:
    #0 /kunden/XXX/webseiten/core/vb5/route.php(1094): vB5_Route_Subscription->__construct(Array, Array, '', '')
    #1 /kunden/XXX/webseiten/core/includes/functions_digest.php(337): vB5_Route::buildUrl('subscription|fu...', Array, Array, '')
    #2 /kunden/XXX/webseiten/core/includes/cron/digestdaily.php(28): exec_digest(2)
    #3 /kunden/XXX/webseiten/core/includes/functions_cron.php(248): include_once('/kunden/XXX...')
    #4 /kunden/XXX/webseiten/core/vb/api/cron.php(34): exec_cron()
    #5 [internal function]: vB_Api_Cron->run()
    #6 /kunden/XXX/webseiten/core/vb/api/wrapper.php(199): call_user_func_array(Array, Array)
    #7 /kunden/XXX/vbcron-abs.php(38): vB_Api_Wrapper->__call('run', Array)
    #8 /kunden/XXX/vbcron-abs.php(38): vB_Api_Wrapper->run()
    #9 {main}
    Something seems to be wrong with the user / user settings. Can you please tell give me a hint, at what to look at?

    Thanks a lot.

    Stefan
    Last edited by m97forum; Thu 21 Jun '18, 8:15am.

  • #2
    This is a known issue - https://tracker.vbulletin.com/vbulle...sues/VBV-13074

    Seems you had fixed it on previous versions here:
    https://www.vbulletin.com/forum/foru...sometimes-only
    Translations provided by Google.

    Wayne Luke
    The Rabid Badger - a vBulletin Cloud demonstration site.
    vBulletin 5 API

    Comment


    • #3
      Hello Wayne,

      well, it's running for the most part. But this seems to be a special condition.
      I know, that this is running for userid = 75 (a user that seems to have subscribed to that topic) and the lookups are working as well, giving me $userInfo['showSubscriptions'] = 0.
      Since I dont know, which user setting is meant here exactly, I cannot check other users or give it another try somehow.

      Can you please explain what is being checked here (i.e. what does that condition mean)?

      Thanks.
      Stefan

      Comment


      • #4
        I don't know what it is doing here. I haven't had time to dig through the code and figure it out.
        Translations provided by Google.

        Wayne Luke
        The Rabid Badger - a vBulletin Cloud demonstration site.
        vBulletin 5 API

        Comment

        Related Topics

        Collapse

        Working...
        X