Announcement

Collapse
No announcement yet.

https certificate?

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • https certificate?

    hi read other topic about https certificate don't apply to me
    i am testing on my test forum before i apply on my live forum
    my host give me a free ssl certificate follow the guide https://www.vbulletin.com/forum/arti...forum-to-https

    all went ok get a little error clear my broser still get problem with Microsoft Edge browser saying Not Secure https://xxxxxxx
    with Google chrome all is ok don't get no error
    can you gives a tip on how ti fix this
    thanks

    Click image for larger version

Name:	Capture.PNG
Views:	83
Size:	190.2 KB
ID:	4393738
    Click image for larger version

Name:	Capture1.PNG
Views:	58
Size:	407.5 KB
ID:	4393739
    voyger.: In Almighty God I trust, everyone else has to provide evidence."

    vBulletin Version 5.5.5

  • #2
    Your Core URL should also point to https.

    Comment


    • #3
      Originally posted by Fleiding View Post
      Your Core URL should also point to https.
      hi
      if you look the picture the core URL is point to https
      done as the guide,why with Google crome is ok and with
      Microsoft Edge browser saying Not Secure
      https ?
      vBulletin 5
      Go to vBulletin Options > vBulletin Options > Site Name / URL / Contact Details.
      Edit these three settings: 'vBulletin URL'; 'Login URL'; 'Core URL' and add the 's' into the URL.
      For example, if your URL is http://www.contoso.com/forum, change it to https://www.contoso.com/forum
      NOTE: Do not remove the word 'core' at the end of the core URL. You will break your site!
      voyger.: In Almighty God I trust, everyone else has to provide evidence."

      vBulletin Version 5.5.5

      Comment


      • #4
        Your core URL is missing https.

        All three URLs need to reference https but you must not remove core from the third one.
        MARK.B | vBULLETIN SUPPORT

        TalkNewsUK - My vBulletin 5.6.4 Demo
        AdminAmmo - My Cloud Demo

        Comment


        • #5
          thanks Mark and Fleiding for the tip
          my mistake don't know what i was thinking..lovely now work like a treat very happy

          now i can implement to my live forum
          voyger.: In Almighty God I trust, everyone else has to provide evidence."

          vBulletin Version 5.5.5

          Comment


          • #6
            Originally posted by voyger View Post
            if you look the picture the core URL is point to https
            It isn't though. You have the Forum Name (why?), vBulletin Url, and Login URL set to HTTPS. The Core directory is not.

            When you hover over the Not Secure in Edge, what isn't secure? You should also see this in the browser's developer tools. If you have hard coded image urls in your CSS, these will all need to be updated as well. AS well as any third-party Javascript inclusion.

            Translations provided by Google.

            Wayne Luke
            The Rabid Badger - a vBulletin Cloud demonstration site.
            vBulletin 5 API

            Comment


            • #7
              hi again
              installed the https corticate on test forum working ok

              installed
              the https corticate on my live forum which is similar to test forum
              got a problem on the front page error "Not Secure https" how do i fix
              third-party Javascript ?
              can you gives step by step how to do it pleas
              thanks
              voyger.: In Almighty God I trust, everyone else has to provide evidence."

              vBulletin Version 5.5.5

              Comment


              • #8
                Settings -> Options -> Server Settings and Optimization Options. Set "Use Remote jQuery" to None.

                If you have addons that include their own javascript or include javascript in individual modules (ad, html, php), each would have to be updated manually.
                Translations provided by Google.

                Wayne Luke
                The Rabid Badger - a vBulletin Cloud demonstration site.
                vBulletin 5 API

                Comment


                • #9
                  thanks wayne for the tip
                  set
                  Remote jQuery" to None. didn't fix my prob still got Not secure https look like the error is only on the front page
                  will have a look the module let you know

                  thanks
                  voyger.: In Almighty God I trust, everyone else has to provide evidence."

                  vBulletin Version 5.5.5

                  Comment


                  • #10
                    I believe that if you click on the Not Secure, it should tell you what the problem is down to the actual file. If not, try this site:
                    https://www.whynopadlock.com/

                    I see insecure images coming from tinypic.com. It looks like the images in your Channel Descriptions. Moving these to your local server under https would clear up the issue.
                    Translations provided by Google.

                    Wayne Luke
                    The Rabid Badger - a vBulletin Cloud demonstration site.
                    vBulletin 5 API

                    Comment


                    • #11
                      thanks wayne for helping
                      follow your suggestion delete the picture from tinypic those error gone now
                      still got Not secure https

                      tested on link https://www.whynopadlock.com/

                      look like
                      got two more warning error look picture

                      Click image for larger version

Name:	Capture.PNG
Views:	66
Size:	168.4 KB
ID:	4397686

                      what they say to Add the following code to the .htaccess file in my webhosting account:

                      Code:
                      RewriteCond %{HTTP_HOST} sat-lodge\.it [NC]
                      RewriteCond %{SERVER_PORT} 80
                      RewriteRule ^(.*)$ https://sat-lodge.it/$1 [R,L]
                      Click image for larger version

Name:	Capture1.PNG
Views:	61
Size:	173.1 KB
ID:	4397687

                      i am not sure if this is correct can you advise pleas

                      thanks
                      voyger.: In Almighty God I trust, everyone else has to provide evidence."

                      vBulletin Version 5.5.5

                      Comment


                      • #12
                        There is similar code in the .htaccess that we distribute to force .htaccess on Apache 2.4 and higher. If that doesn't work, you'll have to discuss the required code with your hosting provider. Your hosting provider would have to update your TLS protocol. That is outside the vBulletin system.

                        Neither of these should prevent a secure connection if using https.

                        I show your site as Secure when it first loads. Then your addons start using AJAX to retrieve information and the Secure status goes away. It could be either the Top 10 Stats or Chatbox. You might want to discuss this with the creators of those addons.
                        Translations provided by Google.

                        Wayne Luke
                        The Rabid Badger - a vBulletin Cloud demonstration site.
                        vBulletin 5 API

                        Comment


                        • #13
                          thanks wayne
                          today try to suss out the problem is look you are wright something is wrong with the front page

                          as the sub forum there is no error as you said could be the
                          Chatbox
                          the Top 10 Stats or the smile under the chatbox

                          this is the log from the server


                          PHP Code:
                          Loading mixed display content "https://sat-lodge.it/core/images/smilies//ciaociao.gif" (unsecuredon a secure page [morejquery.js511433
                          Loading mixed display content 
                          "http://sat-lodge.it/core/images/smilies//ciaociao.gif" (unsecuredon a secure page [morejquery.js511433
                          Loading mixed display content 
                          "https://sat-lodge.it/core/images/smilies/drinks.gif" (unsecuredon a secure page [morejquery.js511433
                          Loading mixed display content 
                          "http://sat-lodge.it/core/images/smilies/drinks.gif" (unsecureon a secure page [morejquery.js511433
                          Loading mixed display content 
                          "http://sat-lodge.it/core/images/smilies//ciaociao.gif" (unsecuredon a secure page [more]
                          jquery.js511433
                          Loading mixed display content 
                          "http://sat-lodge.it/core/images/smilies/drinks.gif" (unsecuredon a secure page [more
                          delete this smile from the server core but still no joy

                          never the less thanks for helping
                          regards to all the team
                          voyger.: In Almighty God I trust, everyone else has to provide evidence."

                          vBulletin Version 5.5.5

                          Comment


                          • #14
                            Make sure your smilie URLs are relative in the AdminCP under Smilies -> Smilie Manager. For the default smilies, they should just have the file name. For custom smilies, the directory and file name, i.e. /category1/smile12.png.
                            Translations provided by Google.

                            Wayne Luke
                            The Rabid Badger - a vBulletin Cloud demonstration site.
                            vBulletin 5 API

                            Comment


                            • #15
                              hi wayne
                              let you know with my surprise this morning fix for herself the lock in bar is there,the Not secure gone
                              can't explain how is fix LOL

                              regards
                              voyger.: In Almighty God I trust, everyone else has to provide evidence."

                              vBulletin Version 5.5.5

                              Comment

                              Related Topics

                              Collapse

                              Working...
                              X