Announcement

Collapse
No announcement yet.

Users can't register - 500 error

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • #16
    The router (part of the script that tells it what pages to load based on the URL) uses REQUEST_URI. Should only be used if your have a PORT specified in the URL though.

    I'll have to try and set up IIS this weekend and test this. I don't have an IIS server configured currently and cannot recreate the issue with Apache. This means I have to update Windows 10 on my machine. I am not currently running Windows 10 Pro. So it will be time consuming.
    Translations provided by Google.

    Wayne Luke
    The Rabid Badger - a vBulletin Cloud demonstration site.
    vBulletin 5 API - Full / Mobile
    Vote for your favorite feature requests and the bugs you want to see fixed.

    Comment


    • #17
      And I doubled checked and that patch has already been applied. So that's not the issue either. heavy sigh.

      Comment


      • #18
        I've installed IIS 10 (only version available for my copy of Windows) on my local workstation. From there, setup PHP 7.2.4 as a FastCGI Handler within IIS and created an Application Pool for vBulletin. I am using MySQL 8.0.11 as my database since it was already installed. After that, I installed vBulletin 5.4.2 Beta 1 since I had it downloaded. Unfortunately, I am not able to recreate your issue. I think there is something off in the configuration of your server.

        In your already existing ticket please relay the values for your Module Mapping within IIS. It should look like the image below -
        Click image for larger version

Name:	2018-05-26_11-45-33.png
Views:	23
Size:	34.4 KB
ID:	4392173


        However, you may need to upgrade IIS to work with later versions of PHP and MySQL. IIS 7 is pretty old and could be out of date.
        Translations provided by Google.

        Wayne Luke
        The Rabid Badger - a vBulletin Cloud demonstration site.
        vBulletin 5 API - Full / Mobile
        Vote for your favorite feature requests and the bugs you want to see fixed.

        Comment


        • #19
          If you don't need IIS specific functionality on your site, you might want to look into WAMPServer or XAMPP to run your website under Windows.
          Translations provided by Google.

          Wayne Luke
          The Rabid Badger - a vBulletin Cloud demonstration site.
          vBulletin 5 API - Full / Mobile
          Vote for your favorite feature requests and the bugs you want to see fixed.

          Comment


          • #20
            RESOLVED::: I have my forum working now, with latest version of both vBulletin and PHP 7.1.

            For informational purposes, I did the following:

            1. I rolled everything (database, vBulletin files & PHP install) to prior to my previous update (the update that appeared to cause the issue). At that point I verified that the register page would load.

            2. I left PHP as is (7.0) and updated to latest version of vBulletin. After the update I verified that the register page would load.

            3. I updated to latest version of PHP 7.0. After the update I verified that the register page would load.

            4. I then updated to PHP 7.1, and at that point the register page went back to giving the 500 error.

            4a. Verified that IIS 7.0 setting for fastcgi handler was correct (and it was). And that the php.ini edits for IIS were correct: fastcgi.impersonate = 1
            fastcgi.logging = 0
            cgi.fix_pathinfo=1
            cgi.force_redirect = 0
            Had to edit the php.ini file to correct these (uncommented and set appropriate values). Tried the register page again and it threw 500 error.
            4b. At this point I started Googling again and found a referenced to the fact that Notepad (installed default in Windows) sometimes causes problems when editing .ini files, and a suggestion to use Notepad++ (or other editor). I don't believe that I actually used Notepad, but I did use Wordpad, so to be safe I deleted all existing PHP files, downloaded a new copy of everything and edited the php.ini files with Notepad++.
            Once I did that, vBulletin no longer throws the 500 error on the Register page, and I am now at the most current PHP version. My conclusion is that it must have been an invisible error in the php.ini file caused by WordPad editing.??? At any rate, it's working. Thanks.

            Comment


            • #21
              Notepad and Wordpad will add a hidden BOM character in UTF-8 files. In addition, the current version of Notepad doesn't understand Linux linefeeds so that can make a mess of things as well.

              We always recommend Notepad++, Visual Studio Code, or the Atom editor. All are available for free and will properly handle files with text content. I am glad that you were able to resolve the issue.
              Translations provided by Google.

              Wayne Luke
              The Rabid Badger - a vBulletin Cloud demonstration site.
              vBulletin 5 API - Full / Mobile
              Vote for your favorite feature requests and the bugs you want to see fixed.

              Comment

              Related Topics

              Collapse

              Working...
              X