Announcement

Collapse
No announcement yet.

ReCaptcha Error

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • ReCaptcha Error

    Unregistered members must verify the reCAPTCHA robot tick box before they can search our forums. It worked fine until recently but they are now getting a message:

    Image verification unsuccessful due to incorrect reCAPTCHAâ„¢ parameters. Contact the admin.

    We are using v2 so not sure what can be wrong, any ideas? I've even tried re creating the Public and Private keys but it makes no difference.
    __________________________________________
    We don't stop playing because we grow old;
    we grow old because we stop playing.
    GBS

  • #2
    Also, unregistered members could click on new posts and it worked fine. Now it just takes them to the search page. With the above recaptcha error message.

    I think this is since the latest update as it's only just being mentioned.
    __________________________________________
    We don't stop playing because we grow old;
    we grow old because we stop playing.
    GBS

    Comment


    • #3
      For the first issue, did you verify your keys are valid at Google?

      For the second issue, technically this is how it should work if you are using CAPTCHA on searching. You can remove the CAPTCHA check on searching under Settings -> Options -> Human Verification Options.
      Translations provided by Google.

      Wayne Luke
      The Rabid Badger - a vBulletin Cloud demonstration site.
      vBulletin 5 API - Full / Mobile
      Vote for your favorite feature requests and the bugs you want to see fixed.

      Comment


      • #4
        Originally posted by Wayne Luke View Post
        For the first issue, did you verify your keys are valid at Google?

        For the second issue, technically this is how it should work if you are using CAPTCHA on searching. You can remove the CAPTCHA check on searching under Settings -> Options -> Human Verification Options.
        No I didn't verify the keys, they had always worked before. I just got the keys and entered them in the vBulletin options boxes

        I'm sure new posts was working before for unregistered users.

        The reason we added captcha to search was after reading bots can cause server issues by searching too much. Do you think there is no need to have it on?
        __________________________________________
        We don't stop playing because we grow old;
        we grow old because we stop playing.
        GBS

        Comment


        • #5
          I just tried the search (on your cloud site) as a guest, I used ReCaptcha without issue and got search results I'd expect. I searched for "tires."

          Is more than one user complaining about this issue?

          Comment


          • #6
            Thanks Joe. There were two new members who mentioned it just after they joined, while they were still moderated members, once they became registered users it worked OK. I've tried myself, logged out and get this message. I've just tried again now, it happens when you click "today's posts" without entering any search criteria.

            I guess if search works for you then people are seeing the message and not even trying. I didn't try myself. But the message shouldn't be there should it? It must mean something:


            Click image for larger version  Name:	Screen Shot 2018-02-27 at 16.58.07.png Views:	1 Size:	50.0 KB ID:	4387205
            Last edited by MrsTiggywinkle; Tue 27 Feb '18, 8:11am.
            __________________________________________
            We don't stop playing because we grow old;
            we grow old because we stop playing.
            GBS

            Comment


            • #7
              The error above is because the search box shown in the header doesn't show the human verification.
              Translations provided by Google.

              Wayne Luke
              The Rabid Badger - a vBulletin Cloud demonstration site.
              vBulletin 5 API - Full / Mobile
              Vote for your favorite feature requests and the bugs you want to see fixed.

              Comment


              • #8
                Originally posted by Wayne Luke View Post
                The error above is because the search box shown in the header doesn't show the human verification.
                It does once you do a search, but you are right it doesn't show on the top/front page.

                What's best to do, just turn off captcha for search? I see it's not used on here.
                __________________________________________
                We don't stop playing because we grow old;
                we grow old because we stop playing.
                GBS

                Comment


                • #9
                  If you want to allow guest to use the search box and the New Posts links, you will need to turn it off. That is why we ship with it off on new installs. Bots don't typically do keyword searches.
                  Translations provided by Google.

                  Wayne Luke
                  The Rabid Badger - a vBulletin Cloud demonstration site.
                  vBulletin 5 API - Full / Mobile
                  Vote for your favorite feature requests and the bugs you want to see fixed.

                  Comment

                  Related Topics

                  Collapse

                  Working...
                  X