Announcement

Collapse
No announcement yet.

How do I disable/hide the button "Upload Attachments"?

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • webcms
    replied
    Hiding buttons of a WYSIWYG HTML editor is done through editing its JavaScript config file. PHP code should be able to dynamically configure that file.

    Leave a comment:


  • webcms
    replied
    If you drag and drop a file into the editor, the attachment buttons reappear at the bottom of the editor like from a cookie! Bummer

    Before you develop any module, you should first implement a switch to turn it on/off - and then develop the module - so we are in control. At least that's the way it is done traditionally before implementing any feature that is a resource drain.
    Last edited by webcms; Sat 22 Feb '20, 2:01am.

    Leave a comment:


  • ndoktoruser
    replied
    I really didn't like the error being displayed to the user.

    Your solution worked like magic.
    Thank you!

    Leave a comment:


  • Wayne Luke
    replied
    There is no mechanism built-in to hide it. Actually trying to upload an attachment should give an error.

    However, you can hide it with Custom CSS. Add this line to your css_additional.css template:
    Code:
    [data-panel="b-content-entry-panel__content--attachment"] {display:none;}

    Leave a comment:


  • ndoktoruser
    replied
    I've logged in as a regular member. This user is part of "registered users" only, but I can still see the option of uploading attachments.

    Leave a comment:


  • In Omnibus
    replied
    If you're logged in as an administrator you will always see the attachments options. Try logging in as a regular member and see if you still see them.

    Leave a comment:


  • How do I disable/hide the button "Upload Attachments"?

    I have tried two things:

    First, I went to AdminCP -> Usergroups -> User Management, then I set the following options:
    * Maximum number of Attachments per post: 0
    * Can upload Attachments: no
    * Can create Attachments: no

    Second, I went to AdminCP -> Attachment -> Attachment Rights, then I set "no" to the option "can upload this data type" of every single data type.

    Even so, when I create a post, the option "Upload Attachments" is still there.

    So, how can I disable/hide the button "Upload Attachments"?


    Note: my system isn't in English, so the options might have a slightly different name.

Related Topics

Collapse

Working...
X