Announcement

Collapse
No announcement yet.

Where is the friendly url settings in Options?

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Wayne Luke
    replied
    Originally posted by rag_gupta View Post
    In case of time take to load a page is there any difference in CPU/DB load when I try to load a tag URL or a forum url:

    Code:
    https://www.vbulletin.com/forum/forum/vbulletin-5-connect/vbulletin-5-connect-questions-problems-troubleshooting/vbulletin-5-support-issues-questions
    
    VS
    
    https://www.adminammo.com/search?searchJSON=%7B%22prefix%22%3A%5B%2270%22%5D%7D
    If anything, the first URL would use more CPU resources as the system figures out the route and builds the appropriate page. The server has to convert all those channels into variables to find the proper page. This also requires database queries.

    In the second URL, it has the page (search) and the variables to feed the system already. It can just feed the variables to the appropriate classes.

    Leave a comment:


  • Wayne Luke
    replied
    Originally posted by rag_gupta View Post
    Why is tags url so unfriendly then?

    Code:
    https://www.adminammo.com/search?searchJSON=%7B%22prefix%22%3A%5B%2270%22%5D%7D
    Temporary search URLs, shouldn't be indexed anyway. Even if it is, the options in vBulletin 4 came out of the need to index dynamic URLs which the search engines had a problem with. That is up until 2010 or so. Today, they have no problems indexing any URLs even dynamic URLs or those created by javascript. Things are different now. Even having keywords in your URL isn't very important these days. People abused it and the search engines discount them or even disregard them in ranking algorithms.

    Friendly URLs don't help people. They never did. People don't remember URLs. If they need to follow a discussion they will subscribe to it or bookmark it.

    Leave a comment:


  • rag_gupta
    replied
    In case of time take to load a page is there any difference in CPU/DB load when I try to load a tag URL or a forum url:

    Code:
    https://www.vbulletin.com/forum/forum/vbulletin-5-connect/vbulletin-5-connect-questions-problems-troubleshooting/vbulletin-5-support-issues-questions
    
    VS
    
     https://www.adminammo.com/search?searchJSON=%7B%22prefix%22%3A%5B%2270%22%5D%7D

    Leave a comment:


  • Mark.B
    replied
    Itís a search URL and thatís the format they use. There is currently no way to change this.

    Leave a comment:


  • rag_gupta
    replied
    Why is tags url so unfriendly then?

    Code:
    https://www.adminammo.com/search?searchJSON=%7B%22prefix%22%3A%5B%2270%22%5D%7D

    Leave a comment:


  • Wayne Luke
    replied
    Those options are irrelevant in vBulletin 5. All URLs are already "Friendly" out of the box. That page you're looking at is not a vBulletin 5.X documentation page. It is a vBulletin 4 version page. You can tell this because the breadcrumb display is broken and there is no navigation in the left column.

    Here is the proper vBulletin 5 Manual - https://www.vbulletin.com/docs/html?...rsion=50304601

    You can see the most up to date settings (built off of 5.4.0) in my personal documentation project here: http://vb5support.com/admin_control_...ttings/options

    Leave a comment:


  • rag_gupta
    started a topic Where is the friendly url settings in Options?

    Where is the friendly url settings in Options?

    As described in here: https://www.vbulletin.com/docs/html/...ofriendly_urls

    I'm unable to find it.

Related Topics

Collapse

  • fionix
    shorten url - vbulletin 5.1.7
    by fionix
    Hi,

    I was just wondering how you get the URL shorten in Vbulletin 5.1.7 ?

    From what I can see you have it done here at vbulletin.com - see url below... there is this number (which...
    Wed 22nd Apr '15, 3:28am
  • excentryk
    404 redirection
    by excentryk
    How can I redirect my old url to main page - I'd like to redirect 404 error to home page. (Invalid Page URL. If this is an error and the page should exist, please contact the system administrator and...
    Tue 20th Feb '18, 5:42am
  • CorbinH
    Installing SSL
    by CorbinH
    Hi at vB,
    I am planning to update our site Australian Photoholics Forum "ausph.com" to SSL.
    Last time we tried this, we broke our site which was down for a week!
    Everyone here...
    Wed 24th Oct '18, 1:36am
Working...
X