Announcement

Collapse
No announcement yet.

No file uploaded and no local file found. The test cannot continue

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • No file uploaded and no local file found. The test cannot continue

    My forum is new and I just got someone to register. They registered successfully but aren't able to upload the avatar.

    Upon checking and uploading the image in Maintenance > Diagnostics > Upload ------ I get the following results.
    Pertinent PHP Settings
    file_uploads: On
    open_basedir: None
    upload_tmp_dir: None
    upload_max_filesize: 20.00 MB
    Results
    No file uploaded and no local file found. The test cannot continue.
    Upon checking the Settings > Options > Server Settings & Optimization Options

    I've open_basedir Upload Enabled set to YES

    open_basedir Temporary Directory set to /tmp

    Although there wasn't any tmp directory which I created in the /home/mysite/public_html/ and gave it the permission of 777

    Edited the php.ini which is present in /home/mysite/public_html/ and added the following lines:
    open_basedir = "/home/mysite/:/usr/lib/php:/home/mysite/public_html/tmp/"
    upload_tmp_dir = "/home/mysite/public_html/tmp"

    Restarted the Apache web server after editing the php.ini file.

    No idea if I did the last step correctly or not because in PHPmyinfo file, open_basedir still shows as None.

    Could someone please help me resolve this avatar uploading problem which is getting originated through any of the above settings.

    Please help.

  • #2
    Your open_basedir temporary directory is incorrectly set. It needs an absolute path. You have not given permission to use /tmp in the php.ini file.
    Translations provided by Google.

    Wayne Luke
    The Rabid Badger - a vBulletin Cloud customization and demonstration site.
    vBulletin 5 Documentation - Updated every Friday. Report issues here.
    vBulletin 5 API - Full / Mobile
    I am not currently available for vB Messenger Chats.

    Comment


    • #3
      Originally posted by Wayne Luke View Post
      Your open_basedir temporary directory is incorrectly set. It needs an absolute path. You have not given permission to use /tmp in the php.ini file.
      Yes, possibly it is the case. Because when I enabled the open_basedir and upload_tmp_dir in php.ini file they were just empty without any path, ofcourse.

      So I just used the recommendations that I got by searching for similar problems that others had and used the similar path. And possibly that could be the reason why it is still not working.

      Is there any way to get the correct open_basedir and upload_tmp_dir path?

      Comment


      • #4
        There is no single "correct" open_basedir or upload_tmp_dir path. They are dependent on the server configuration and what your Web Server user has access to. You should contact the server administrator and/or hosting provider for more help with these values.
        Translations provided by Google.

        Wayne Luke
        The Rabid Badger - a vBulletin Cloud customization and demonstration site.
        vBulletin 5 Documentation - Updated every Friday. Report issues here.
        vBulletin 5 API - Full / Mobile
        I am not currently available for vB Messenger Chats.

        Comment


        • #5
          I have full server access including WHM as we have VPS.

          Okay, I changed the upload_tmp_dir to /home/mysite/public_html/tmp and it started working.

          Now the diagnostics says this - No errors occurred while opening the uploaded file for reading.

          Last edited by keyuramin; Tue 9th Jan '18, 3:16am.

          Comment

          Related Topics

          Collapse

          Working...
          X