Announcement

Collapse
No announcement yet.

Problem searching with swedish charactes

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Problem searching with swedish charactes

    I have a problem searching for words with swedish characters. Like dvärggurami and svärdbärare. I know there is those words in the forum.


  • #2
    You can do an easy test in this forum and search for dvärggurami and you will find nothing.

    Comment


    • #3
      I think it's the problem with the Umlaut characters. You could try to change your language Date / Time Formatting "Locale" at your language.../admincp/language.php?do=modify&.
      If you use now sv_SV you have to change it to sv_SV.UTF-8. Then rebuild the searchindex at .../admincp/misc.php?do=chooser& .

      Try to search any word with a swedish character. It should work again.
      I have a short tutorial in german here: https://vbulletin-forum.de/articles/...umlaute-fehlen
      vBulletin-Forum.de closed!

      Comment


      • #4
        Did the answer from delicjous work Christian Alfredsson ? I have the same problem with my site and i dont want to rebuild the search index (it takes about 2 days) if it is not needed.

        Comment


        • delicjous
          delicjous commented
          Editing a comment
          Last time I tried was almost a year ago, but it should work. You could use the searchindex.php - File (in your vB5 -packagefolder do_not_upload) and run that within commandline . Should be a little faster.

      • #5
        delicjous , im still struggeling with this issue. Was your solution on a Windows Server with IIS or something else? Im not able to enter the sv_SE.UTF-8 or sv-SE.UTF-8. Im recieving errors like "The locale 'sv-SE.UTF-8' could not be located on this server." and i cant figure it out the correct settings for Windows Server 2016 with IIS 10...

        Comment


        • #6
          Nop, I don't use windows server. Mr B are your forum run in sweden? You need to set this to sv-SE.UTF-8 for sweden, de_DE.UTF8 for germany ..... You find a list on your language-settingspage.
          vBulletin-Forum.de closed!

          Comment


          • #7
            Originally posted by delicjous View Post
            Nop, I don't use windows server. Mr B are your forum run in sweden? You need to set this to sv-SE.UTF-8 for sweden, de_DE.UTF8 for germany ..... You find a list on your language-settingspage.
            Darn, i have tested the most settings that are found in the linked documents in the settings page. None have worked correctly. sv-SE.UTF-8 is not valid on the server. I then recieving the error message above. Im out of ideas at the moment. Yes, the server are in sweden. Windows server 2016 with IIS10.

            Ive also installed a new testvb and the problem is there also. All åäö is missing in the "words" db table. So, for example the fish "gädda" is indexed as "gdda" in the "words" table. The same problem is here on vBulletins forum. If you search for "gädda" you will find nothing. But if you search for "gdda" you will find this thread.

            Comment


            • #8
              Yes, because they don't use special characters in english and don't matter I think...It is working! Search for Württemberg at http://vbulletin-forum.de and you will get a result.
              vBulletin-Forum.de closed!

              Comment


              • #9
                Originally posted by delicjous View Post
                Yes, because they don't use special characters in english and don't matter I think...It is working! Search for Württemberg at http://vbulletin-forum.de and you will get a result.
                Got 0 results when searching your forum for "Württemberg".

                So, maybe there is some kind of unique setting for swedish locale on windows server. The search worked in vBulletin 4.2.5 so something in search indexing is changed from 4.2.5 to 5.4.4. In 4.2.5 we had sv_SE as Locale but that is not valid in 5.4.4.

                Comment


                • delicjous
                  delicjous commented
                  Editing a comment
                  :-) Sorry....you see that only if you are registered. "Beitragszähler" is one you also see at a guest. But it is working, so it could be a problem with your win-server?!? I don't know

              • #10
                I had the same problem with Swedish character search and had Sphinx search installed. There is settings for how åäöÅÄÖ characters are to be treated in the search and it works nice.

                Comment


                • #11
                  Originally posted by pmquist View Post
                  I had the same problem with Swedish character search and had Sphinx search installed. There is settings for how åäöÅÄÖ characters are to be treated in the search and it works nice.
                  pmquist , are you running your board on a windows server with iis? Do you use a swedish language pack for vBulletin? Can you please post/share your language related settings in the config.php file and also the language related settings in the english and swedish language packs in vBulletin settings in the admincp? Also, what type of collation do you use in the database for the db, tables and columns? Is it latin1, utf8 or maybe utf8mb4?

                  This seems to be a bugger to solve, and the help from vBulletin is rather limited.

                  if Sphinx search solves the issue the we probably go for that. But the built in search function should work... the vBulletin documentation does not mention that Sphinx is a must.

                  Please help with the questions

                  Best regards from Anders

                  Comment

                  widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
                  Working...
                  X