Announcement

Collapse
No announcement yet.

Blog comment permissions

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • petes80
    replied
    Hi Wayne

    Thank you for your continued help, it's very much appreciated. However you seem to have drifted away from the core issue I was having. I know guest/not logged in users can't post comments. This is correct and what I want. I was trying to fix the issue that a SUPER MODERATOR could not post when logged in.

    However I have fixed the issue now. I basically set everything to "Yes" which then allowed comments to be posted. Then I switched the options back to "No" one by one until I found the one that was causing it not to post. It turns out the issue was the setting "Can create text/post". This was set to "No" before. Setting this to "Yes" solved the problem.

    Leave a comment:


  • Wayne Luke
    replied
    I see "You must be logged in to post a comment". So it seems the system is working. Guests cannot post comments in vBulletin.

    Leave a comment:


  • petes80
    replied
    Hi Wayne

    Yes that's exactly what I've got. Blog is the original parent category and is not acting as a channel (it won't let me change it to a channel anyway). eCommverse Blog is a child channel of that one and IS acting as a channel. This is where I've actually posted the blog. You can see it here:

    https://ecommverse.co.uk/blogs

    At this point, I don't care about the navigation structure, I'm just trying to resolve the issue that people can't leave a comment because it comes up with an error message saying they don't have permissions. I posted 5 images in my previous post above which shows the permissions of the Super Moderator usergroup, the structure of the blog/child relationship, the channel permissions for the Super Moderator, and the permissions from the front end set up of the blog channel. Please tell me what setting is causing people not to be able to comment. Or let me know if you want me to screenshot any other permissions/options.

    Leave a comment:


  • Wayne Luke
    replied
    You have to have a sub-channel of Blogs.

    Blogs - Not act as Channel. Can never hold content. It can only hold other blogs.

    MyBlog - Child of Blogs, Act as Channel. This is where you're actual content goes.

    If you only want the one blog, then update the navigation bar to point to it.

    Leave a comment:


  • petes80
    replied
    I've just rebuilt the blog and I get exactly the same problem. Image showing the permissions are attached to this post.

    Leave a comment:


  • petes80
    replied
    OK, the initial channel called "Blogs" was set as to not act as a channel. The sub-channel was set to act as a channel. I actually only need 1 blog channel so I removed the "sub channel" and tried to set the parent channel "Blogs" to be a channel rather than a category. However everytime I try and change it, I get the error message "You cannot convert a channel that is not empty." However it is empty. There are no blogs or child categories at all.

    I don't get it.

    Leave a comment:


  • Wayne Luke
    replied
    Categories are not supported in vBulletin 5 blogs. In the AdminCP under Channel Management -> Channel Manager make sure that "Act as Channel" is set to yes for this blog. Categories do not allow posts to be made in them.

    What are the Blog's permissions? To see the necessary ones, you need to travel to the blog on the front end and click the gear icon under the blog's image. Click on Permissions and Privacy. If comments are set to "Subscribers" then the Super Moderator has to join the Blog in order to be able to post comments. You can override this by setting the "Can Always Reply" permission for that usergroup on the Blog Channel. This is under Channel Management -> Channel Permissions. This should be set in a default installation for the Super Moderator group but it may have changed.

    Leave a comment:


  • petes80
    replied
    Thanks for your reply. I've reset all of the user permissions and channel permissions for any user with the word "Channel" in. However this still hasn't resolved the problem, I still get a no permissions error.

    If it helps, the user I'm testing this on is set to the user group "Super Moderator" only. The "Can Comment" and "Can Reply to Topics" options are set to yes in the usergroup settings and the "Home" channel settings. The "Blog" channel is actually set to a category, and also has both "Can Comment" and "Can Reply to Topics" set to yes. The actual blog channel inherits the permissions so therefore also has these set to yes. I simply don't get it! It shouldn't be this hard to give a user permissions to comment on a blog!

    Leave a comment:


  • Wayne Luke
    replied
    Have you changed the channel permissions on any of the usergroups with "Channel" in their name? If so, restore those permissions to their default by clicking on "Reset" in the Channel Permissions Manager.

    Leave a comment:


  • petes80
    replied
    Ignore that last question, I've found the settings for the blog and "Allow comments to be posted" is ticked. "Moderate comments before posting" is unticked. The "View" option is set to "Everyone" and "Comment" is also set to "Everyone".

    Despite the above, no-one can post a comment except me. I'm an administrator, and the creator of the blog. No-one else has permission to post a comment, despite "Can comment" being ticked in all the permissions settings I can find.

    Leave a comment:


  • petes80
    replied
    Hi

    I don't know the answer to that. I assume I would have ticked it or left it ticked but I don't know. Where do I get to these settings again? I can't find the right place.

    Leave a comment:


  • MrsTiggywinkle
    replied
    In the settings for the actual blog itself (when you create it) are the settings set to allow comments? This isn't in admin but in the blog.

    permissions and privacy > allow comments (this should be ticked)

    Leave a comment:


  • petes80
    started a topic Blog comment permissions

    Blog comment permissions

    Hi

    I've created a blog on my forum but I can't get the permissions right to allow other forum users to comment. I've checked the User permissions and "Can comment" is set to Yes. I've also checked the Channel Permissions and it's also set to yes on the blog channel, and the 'Home' channel which is it's parent. The user is in just a single user group so it's not a double user group issue. However nothing I do allows the user to post the comment. I'm sure there's just a setting somewhere else, but I can't find it anywhere. Any help would be much appreciated.

    Kind regards
    Pete

Related Topics

Collapse

Working...
X