Announcement

Collapse
No announcement yet.

Secuity Patch causes display errors on sharing media links

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • [Bug / Issue] Secuity Patch causes display errors on sharing media links

    As title says. On my forums (5.3.4) I've added the security patch. Now all sharing media link images (Facebook, Twitter) displayed with a 100% width. Tested on my mirror with clean vb default style.

    Klicke auf die Grafik für eine vergrößerte Ansicht  Name: vberror.png Ansichten: 1 Größe: 10,7 KB ID: 4383565

  • #2
    Link? The security patch changes are backend changes. I don't think it will cause a frontend issue on CSS.

    GIPHY for vB5 AutoLinker Auto-Create Flag Report Topic Social Icons in Postbit Clear Cache Cron DragDrop Upload Topic AJAX AutoUpdate Custom Avatars Selector Stop Links in Posts...and more!

    Comment


    • #3
      This site is running the patch. As stated above, the patch shouldn't have any visible effect on the site. I don't know how this would be caused. You only uploaded the patch files and nothing else?

      You can try running /core/includes/upgrade.php to rebuild styles from the files.
      Translations provided by Google.

      Wayne Luke
      The Rabid Badger - a vBulletin Cloud demonstration site.
      vBulletin 5 API - Full / Mobile
      Vote for your favorite feature requests and the bugs you want to see fixed.

      Comment


      • #4
        Couldn't get it running yet. Already try to find out, what the problem is. This problem effects both servers (normal/ test mirror). On both servers running Nginx and ImageMagick with different PHP-Versions. I set vbulletin default style to default style, delete own bbcodes, clear system and browser cache, try different browsers - without success. I try further...

        Comment


        • #5
          Found just one error: https://mysite.de/css.php?styleid=34...&ts=1513758924 (including default theme) couldn't get loaded. Is already empty, but there is nothing else I can find.

          EDIT: There're some other css files cannot loaded. E.g. css_editor.css or css_b_sharing_menu.css. Error 404 !

          I think, there's a problem on Nginx and css files. Tested that? All css files loaded as html files cannot loaded.

          Klicke auf die Grafik für eine vergrößerte Ansicht  Name: vb_css_4040_2.png Ansichten: 1 Größe: 12,5 KB ID: 4383620
          Last edited by BulliM; Thu 21st Dec '17, 12:05am.

          Comment


          • #6
            When I try to load such an css file direclty I get that error message:

            Klicke auf die Grafik für eine vergrößerte Ansicht  Name: vb_css_404_3.png Ansichten: 1 Größe: 10,9 KB ID: 4383622

            Some of that (html 404) css files directly delivered as html file:

            Klicke auf die Grafik für eine vergrößerte Ansicht  Name: vb_css_404_4.png Ansichten: 2 Größe: 441,4 KB ID: 4383628

            So it is probably a template rendering problem with Nginx and css files after patching.
            Last edited by BulliM; Thu 21st Dec '17, 1:06am.

            Comment


            • #7
              Please run the upgrade.php file to rebuild your styles.
              Translations provided by Google.

              Wayne Luke
              The Rabid Badger - a vBulletin Cloud demonstration site.
              vBulletin 5 API - Full / Mobile
              Vote for your favorite feature requests and the bugs you want to see fixed.

              Comment


              • #8
                There is no upgrade.php - not even an install directory. I just overwrite with the patch files. I've already rebuilded styles in admincp with general update tools. Doesn't fix the problem, that css files delivered as html files. It is a rendering problem.
                Last edited by BulliM; Thu 21st Dec '17, 8:09am.

                Comment


                • #9
                  Your issue is completely unrelated to the patch. The patch did not cause it. The patch has absolutely nothing to do with the style of your site or loading CSS on the site.

                  When you downloaded vBulletin, it included an upload/core/install directory. You will need to upload this directory and run upgrade.php.
                  Translations provided by Google.

                  Wayne Luke
                  The Rabid Badger - a vBulletin Cloud demonstration site.
                  vBulletin 5 API - Full / Mobile
                  Vote for your favorite feature requests and the bugs you want to see fixed.

                  Comment


                  • #10
                    Originally posted by Wayne Luke View Post
                    Your issue is completely unrelated to the patch. The patch did not cause it. The patch has absolutely nothing to do with the style of your site or loading CSS on the site.
                    What you want to tell me? That the error doesn't have to do with the security patch?

                    Why css files loaded and delivered as html files? Look at my screenshots! I think, it causes because nginx configuration is different to apache configuration. What server vBulletin use?

                    Comment


                    • #11
                      I now run a full upgrade from 5.3.4 to 5.3.4 Patch Level 1 on my test server. Problem is NOT solved, as expected.

                      Comment


                      • #12
                        Originally posted by BulliM View Post

                        What you want to tell me? That the error doesn't have to do with the security patch?

                        Why css files loaded and delivered as html files? Look at my screenshots! I think, it causes because nginx configuration is different to apache configuration. What server vBulletin use?
                        We use Apache. We don't actually provide explicit technical support NGINX or test under NGINX. We expect people using NGINX to know how to configure their servers properly. It is not a beginner's tool.

                        Still the patch covers two issues... The first is an unserialize issue and.the second only occurs on Windows Servers. If you're using Windows, you shouldn't be using NGINX. Neither issue should affect the display of CSS. Nothing was changed in the templates. Nothing was changed on how CSS is delivered by the software. Under any server.

                        If /core/css.php exists on your server, then you need to investigate your server configuration to understand why NGINX can't see the file and its query string and is returning a 404 error. That isn't caused by the software. If the file doesn't exist, then all CSS would be missing.
                        Last edited by Wayne Luke; Thu 21st Dec '17, 9:11am.
                        Translations provided by Google.

                        Wayne Luke
                        The Rabid Badger - a vBulletin Cloud demonstration site.
                        vBulletin 5 API - Full / Mobile
                        Vote for your favorite feature requests and the bugs you want to see fixed.

                        Comment


                        • #13
                          Originally posted by Wayne Luke View Post

                          We expect people using NGINX to know how to configure their servers properly. It is not a beginner's tool.
                          My Nginx server is configured accurately.

                          What you tell me, is not true. The patch includes "core/vb/library/template.php". You've changed something, that's responsible for my error.

                          I now need access to an original vB 5.3.4. without patch for a rollback. Can I please have access to?

                          Comment


                          • #14
                            Try this patch.
                            Attached Files
                            Translations provided by Google.

                            Wayne Luke
                            The Rabid Badger - a vBulletin Cloud demonstration site.
                            vBulletin 5 API - Full / Mobile
                            Vote for your favorite feature requests and the bugs you want to see fixed.

                            Comment


                            • #15
                              Seems to work. I'll try now on real server.
                              EDIT: Works fine! Makes my day! Big hug! Thank you and Merry Christmas!
                              Last edited by BulliM; Thu 21st Dec '17, 10:18am.

                              Comment

                              widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
                              Working...
                              X