Announcement

Collapse
No announcement yet.

What version of php to use, and why is your vb_test.php script throwing errors?

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • What version of php to use, and why is your vb_test.php script throwing errors?

    I am attempting to set up a new site for VB Connect 5.3.3, on a new shared hosting plan. It has php 7.0.25 enabled.

    Your pre-installation vb_test.php script is throwing errors:
    Deprecated: Methods with the same name as their class will not be constructors in a future version of PHP; mysql has a deprecated constructor in /home/thepre01/public_html/vb_test.php on line 68

    Deprecated: Methods with the same name as their class will not be constructors in a future version of PHP; mysql_result has a deprecated constructor in /home/thepre01/public_html/vb_test.php on line 104


    Fatal error: Uncaught Error: Call to undefined function set_magic_quotes_runtime() in /home/thepre01/public_html/vb_test.php:21 Stack trace: #0 {main} thrown in /home/thepre01/public_html/vb_test.php on line 21

    I can change the version of php on the site using the control panel.

    I tried the two earlier versions they have, which are 5.5.38 and 5.6.32, and they both still throw this error when running vb_test.php:
    Deprecated: Function set_magic_quotes_runtime() is deprecated in /home/thepre01/public_html/vb_test.php on line 21.


    What version of php should I use and why is your test script throwing errors on this server?

  • #2
    You can use up to PHP 7.1.9. Will report the issues to the test script to the developers.
    Translations provided by Google.

    Wayne Luke
    The Rabid Badger - a vBulletin Cloud customization and demonstration site.
    vBulletin 5 Documentation - Updated every Friday. Report issues here.
    vBulletin 5 API - Full / Mobile
    I am not currently available for vB Messenger Chats.

    Comment


    • #3
      It is recommended to use PHP 7. The first error is pointing to the use of mysql_select_db() which is deprecated in PHP 7. I guess they did not update the vb_test.php test script for PHP 7 compatibility.

      GIPHY for vB5 AutoLinker Auto-Create Flag Report Topic Social Icons in Postbit Clear Cache Cron DragDrop Upload Topic AJAX AutoUpdate Custom Avatars Selector Stop Links in Posts...and more!

      Comment


      • #4
        I was actually able to fix the issues with the vb_test.php script and have attached a fixed version here: http://tracker.vbulletin.com/browse/VBV-17920

        Translations provided by Google.

        Wayne Luke
        The Rabid Badger - a vBulletin Cloud customization and demonstration site.
        vBulletin 5 Documentation - Updated every Friday. Report issues here.
        vBulletin 5 API - Full / Mobile
        I am not currently available for vB Messenger Chats.

        Comment


        • #5
          Thank you, I downloaded it and tested - no more errors. I am running php 7.1.11. Anyway, I went ahead a few days ago and installed it anyway and it went without a hitch, leap of faith. I do think you guys make good software...

          Comment


          • #6
            We found out the problem with the script found in the /go/test location is out of date. The one included with the vBulletin Download Package is the correct one. The other copy will be updated to the proper version this week as far as I am aware. Thanks for pointing out the issue.
            Translations provided by Google.

            Wayne Luke
            The Rabid Badger - a vBulletin Cloud customization and demonstration site.
            vBulletin 5 Documentation - Updated every Friday. Report issues here.
            vBulletin 5 API - Full / Mobile
            I am not currently available for vB Messenger Chats.

            Comment

            Related Topics

            Collapse

            Working...
            X