Announcement

Collapse
No announcement yet.

Error when accessing the forum

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • [Resolved] Error when accessing the forum

    Hello,


    Our forum, vbulletin version 5.2.5 "works" together with a CMS.
    The header is transferred from the CMS to the forum.
    The login process takes place in the CMS, after the forum has been called up this data must be transferred to the forum.

    The following facts.
    The vbulletin version 5.2.5 was installed by colleagues as an update for vbulletin version 4.2.5, the path to the forum was http://test.die_seite_en/forum5.
    A few days ago I saved the directory of the forum vbulletin version 5.2.5 "/var/www/die_seite_de/html/forum5" to work on some customizations.
    Not the database.
    A few days later I wanted to restore the backed up version, before restoring the backed up version, I have the directory where I worked
    renamed to "/var/wwww/die_seite. de/html/forum5_adaptation".
    The backed up version was created in the directory "/var/wwww/die_seite. de/html/forum5".
    When you access the forum http://test.die_seite. de/forum5, the page is destroyed and no forum posts are displayed.
    The following entry is in the log file:

    Code:
    [Tue Oct 17 10:39:30 2017] [error] [client xxx.xxx.xxx.xxx]
        PHP Fatal error:  Uncaught exception 'Exception' with message 'invalid_query_parameters for saveDbCache' in
        /var/www/die_seite_de/html/forum5/core/vb/db/query/method.php:174\nStack trace:\n#0 /var/www/die_seite_de/html/forum5/core/vb/db/assertor.php(290):
        vB_dB_Query_Method->execSQL()\n#1 /var/www/die_seite_de/html/forum5/core/vb/cache/db.php(390):
        vB_dB_Assertor->assertQuery('saveDbCache', Array)\n#2 [internal function]:
        vB_Cache_Db->shutdown()\n#3 /var/www/die_seite_de/html/forum5/core/vb/shutdown.php(91):
        call_user_func(Array)\n#4 /var/www/die_seite_de/html/forum5/core/vb/vb.php(503):
        vB_Shutdown->shutdown()\n#5 [internal function]: vB::shutdown()\n#6 {main}\n  thrown in /var/www/die_seite_de/html/forum5/core/vb/db/query/method.php on line 174


    The following parameters are in the config
    Code:
    //    ****** Cookie Settings ******
    $config['cookie_prefix'] = 'bb';
    
     // You can ignore this setting for right now.
    $config['cookie_enabled'] = true;
    $config['Database']['dbtype'] = 'mysqli';
    
    $config['Database']['dbname'] = 'forum_datenbank_vb5';
    
    $config['Misc']['forumpath'] = '/var/www/die_seite_de/html/forum5';
    $config['core_path'] = '/var/www/die_seite_de/html/forum5/core';
    
    $config['Misc']['baseurl'] = 'http://test.die_seite_de/forum5';
    
    $config['Mysqli']['charset'] = 'utf8';
    
    $config['Misc']['debug'] = true;
    
    $config['Misc']['debuglogging'] = true;

    The database has remained unchanged.

    Can someone help me?
    What went wrong with the recovery?

    greetings
    Last edited by user918; Wed 8 Nov '17, 6:00am.

  • #2
    Please unset the values for forumpath and baseurl in your config.php files.

    core_path should equal this line:
    Code:
    $config['core_path'] = realpath(dirname(__FILE__)) . '/core';
    Then upgrade to vBulletin 5.3.3. There have been hundreds of issues resolves since 5.2.5. After upgrading does the issue continue?
    Translations provided by Google.

    Wayne Luke
    The Rabid Badger - a vBulletin Cloud demonstration site.
    vBulletin 5 API - Full / Mobile
    Vote for your favorite feature requests and the bugs you want to see fixed.

    Comment


    • #3
      Hi,

      so I've updated the forum from vb 5.2.5 to vb 5.3.3.
      The update has taken the following measures.
      1. backup from database version 5.2.5.
      2. a new database for vb 5.3.3 creates "forum_vb533".
      3. the MySQL dump of vb 5.2.5 into the database "forum_vb533".
      4. go to http://test.die_seite.de/forum533/co...makeconfig.php.
      4. upgrade script executed: http://test.die_seite.de/forum533/co...ll/upgrade.php, the upgrade has been completed completely finished.
      5. then I wanted to enter the admin area via http://test.die_seite.de/forum533/core/admincp/
      Unfortunately, I can't log in!
      No error message is displayed!


      Next, I started the forum itself: http://test.die_seite.de/forum533/ and I get a message under the window
      "Log in or Register" error message:

      HTML Code:
      Error :Deine Eingabe konnte aufgrund eines fehlenden Security-Tokens nicht verarbeitet werden.
      den Administrator und beschreibe was du getan hast, bevor diese Fehlermeldung erschien.br /> on line 638 in 
      /var/www/die_seite_de/html/forum5/includes/vb5/applicationabstract.php
      Step 0: showErrorPage() called on line 276 in /var/www/die_seite_de/html/forum5/includes/vb5/applicationabstract.php 
      Step 1: handleException() called 
      Exception API Error
      Controller: interred
      Method: InterredCSS
      Error(s): 
      array (
        0 => 
        array (
          0 => 'Deine Eingabe konnte aufgrund eines fehlenden Security-Tokens nicht verarbeitet werden.<br />
      <Falls dieser Fehler unerwartet auftrat, kontaktiere bitte <a href="%1$s">den Administrator</a> und beschreibe was du getan hast, bevor diese Fehlermeldung erschien.br />',
        ),
        1 => 
        array (
          0 => 'exception_trace',
          1 => '## /var/www/die_seite_de/html/forum5/core/vb/api.php(513) Exception Thrown 
      #0 /var/www/die_seite_de/html/forum5/core/vb/api/wrapper.php(116): vB_Api->checkApiState(\'InterredCSS\')
      #1 [internal function]: vB_Api_Wrapper->__call(\'InterredCSS\', Array)
      #2 [internal function]: vB_Api_Wrapper->InterredCSS()
      #3 /var/www/die_seite_de/html/forum5/core/vb/api/logwrapper.php(68): call_user_func_array(Array, Array)
      #4 [internal function]: vB_Api_Logwrapper->__call(\'InterredCSS\', Array)
      #5 [internal function]: vB_Api_Logwrapper->InterredCSS()
      #6 /var/www/die_seite_de/html/forum5/includes/api/interface/collapsed.php(198): call_user_func_array(Array, Array)
      #7 /var/www/die_seite_de/html/forum5/includes/vb5/template/runtime.php(546): Api_Interface_Collapsed->callApi(\'interred\', \'InterredCSS\', Array, false, true)
      #8 /var/www/die_seite_de/html/forum5/includes/vb5/template.php(340) : eval()\'d code(182): vB5_Template_Runtime::parseData(\'interred\', \'InterredCSS\')
      #9 /var/www/die_seite_de/html/forum5/includes/vb5/template.php(340): eval()
      #10 /var/www/die_seite_de/html/forum5/includes/vb5/template/cache.php(134): vB5_Template->render(false)
      #11 /var/www/die_seite_de/html/forum5/includes/vb5/template.php(362): vB5_Template_Cache->replacePlaceholders(\'<!-- ##template...\')
      #12 /var/www/die_seite_de/html/forum5/includes/vb5/applicationabstract.php(460): vB5_Template->render()
      #13 /var/www/die_seite_de/html/forum5/includes/vb5/applicationabstract.php(276): vB5_ApplicationAbstract::showErrorPage(Array, false)
      #14 [internal function]: vB5_ApplicationAbstract::handleException(Object(vB5_Exception))
      #15 {main}',
        ),
      )
      on line 550 in /var/www/die_seite_de/html/forum5/includes/vb5/template/runtime.php

      The message in germany:
      Deine Eingabe konnte aufgrund eines fehlenden Security-Tokens nicht verarbeitet werden.
      den Administrator und beschreibe was du getan hast, bevor diese Fehlermeldung erschien
      Translated to EN:
      Your entry could not be processed due to a missing security token.
      the administrator and describe what you did before this error message appeared

      Entries in the file forum533/core/includes/config.php

      PHP Code:
      $config['Database']['dbtype'] = 'mysqli';
      $config['Database']['dbname'] = 'forum_vb533';
      $config['Misc']['forumpath'] = '';
      $config['Misc']['baseurl'] = ''
      $config['Misc']['debug'] = true;
      $config['Misc']['debuglogging'] = true

      How does version 5.3.3 still use the paths of version 5.2.5?
      Or where should / must I adjust the path or information?

      greetings

      Comment


      • #4
        Your security token is expired. Please delete the cookies for the site, clear your browser cache and reload the page.
        Translations provided by Google.

        Wayne Luke
        The Rabid Badger - a vBulletin Cloud demonstration site.
        vBulletin 5 API - Full / Mobile
        Vote for your favorite feature requests and the bugs you want to see fixed.

        Comment


        • #5
          I have implemented your recommendation in three browsers.
          In
          • FireFox 52.4.0 - FireFox 52.4.0
          • Internet Explorer 11 (11.0.9600.18816)
          • Pale Moon, version: 27.5.1 (64-bit)

          where Pale Moon was reinstalled by me.
          I still get the same error message, I can't log in to the admin area.
          Attempt to log in to the admin area no errors are displayed!

          Comment


          • #6
            Does the issue happen with the English Language using a default style?

            Also, you shouldn't need to run makeconfig.php on an upgrade from vBulletin 5. Just overwrite the files on the server with the new ones and run upgrade.php.

            Without access to the server, it will be difficult to ascertain where the problem is. The URL provided doesn't work.
            Translations provided by Google.

            Wayne Luke
            The Rabid Badger - a vBulletin Cloud demonstration site.
            vBulletin 5 API - Full / Mobile
            Vote for your favorite feature requests and the bugs you want to see fixed.

            Comment


            • #7
              Does the issue happen with the English Language using a default style?
              I haven't tried that.

              Also, you shouldn't need to run makeconfig.php on an upgrade from vBulletin 5. Just overwrite the files on the server with the new ones and run upgrade.php.
              Yes, this file is not required for upgrades, see below.

              Without access to the server, it will be difficult to ascertain where the problem is. The URL provided doesn't work.
              This is unfortunately a rather complicated matter.

              In the meantime the following stand is.
              I have upgraded from vb 5.2.5 to 5.3.3.3 again, the upgrade has been finished without any problems.
              But I can't log in to the admin area: http://test.die_seite. de/forum533/core/admincp/
              No error message, the login mask is simply reloaded!
              It is very likely that it is related to our CMS.
              The forum is located in the closed area.

              At this point I have the following docking at vbulletin.
              As mentioned in my first thread, we are working with a CMS,
              From the CMS, the header is taken over into the forum.
              The login process takes place in the CMS, after the forum has been called up this data must be transferred to the forum.
              Unfortunately, this CMS does not ask for any plugis or extension for the logidata, i. e. the user is logged in or not to transfer from the CMS to vbulletin!

              Would it be possible that the vbulletin team could tell us where to transfer the login data to vbulletin Forum version 5.3.3?
              can / must, so that the user can move around in the forum and stay logged in?
              This customization could send you on my email.

              Comment


              • #8
                We can't provide any support for using logins from an external script on vBulletin.
                There is an article explaining the basics here:
                https://www.vbulletin.com/forum/blog...n-your-website
                However doing this isn't a trivial exercise and it is completely outside the scope of our support.
                MARK.B | vBULLETIN SUPPORT

                TalkNewsUK - My vBulletin 5.6.2 Demo
                AdminAmmo - My Cloud Demo

                Comment


                • #9
                  Solution to my case.
                  The problem was due to the paths that are stored in the database.
                  We have changed the entire database "forum_vb533", after the paths of forum vb 5.2.5 and converted it to version 5.3.3, which
                  Forum works again.

                  Comment

                  Related Topics

                  Collapse

                  Working...
                  X