Announcement

Collapse
No announcement yet.

vB-5.3.3: sending mass emails to user using batch/queue does not work

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • m97forum
    replied
    Perfect - that did the job

    Thank you.
    Stefan

    Leave a comment:


  • Wayne Luke
    replied
    truncate table mailqueue;

    Leave a comment:


  • m97forum
    replied
    Hey Wayne,

    thanks for your reply.
    Concerning 2a: what do I need to do in order to delete the messages from the DB. Can you please provide me the SQLs?

    Thanks and have a nice day.
    Stefan

    Leave a comment:


  • Wayne Luke
    replied
    1) Just disable it by unchecking the box.

    2)
    a) You can only delete contents of the email queue directly in the database.
    c) You cannot. You can specify that a task runs up to 6 times per hour.

    Leave a comment:


  • m97forum
    replied
    Hello Wayne,

    1. I cannot delete the queueprocessor tasks. The scheduled tasks admin allows to "Edit" and "Run" tasks only - deletion is not provided. Any way to do that?

    2.
    a) The Email queue currently contains 2.914 mails. Since these messages (say: their content) has been delivered already using instant transmission, I need to delete those messages first. How do I do that?
    b) I set the batch size to 250 mails - so it may take some time, but that's ok for now.
    c) how do I make the email batch scheduled task to run every 5th minute? every 10th minutes seems to be a bit too much waiting...

    Thanks.
    Stefan

    Leave a comment:


  • Wayne Luke
    replied
    And how many emails do you have queued? You can see this on the AdminCP Home Page. If you have many emails queued, it sends 10 per batch by default. It could take days or weeks to work through it at 10 emails every 10 minutes. The only emails that aren't queued are registration and password reset emails.

    queuprocessor.php is a vBulletin 4.X file and not a valid vBulletin 5 file. You should delete that task from the scheduled task list.

    Leave a comment:


  • m97forum
    replied
    Hey,

    thanks for your help.

    I just tried sending an email. The target group consists of two members (the page closed quickly, but it seemed to be the correct members). After waiting for 15 minutes, not a single email has arrived. Turning queuing and cronmail off, the mail arrived within seconds.
    The host provider allows at least 500 mails / round, but I would like to use the queuing feature, because:
    1. the user experience for the mass emails' author is much better (he seems not to have to wait as long)
    2. I cannot tell, if all email providers on the receiving side are fine with as many emails coming in at the same time

    Finally, why wouldn't it work?
    Which jobs do need to be set up for this to work?

    I manually started the Email Batch Sender, but no effect.
    Manually starting the queueprocessor task lead to the following error:

    queueprocessor
    Warning: include_once(..././includes/cron/queueprocessor.php): failed to open stream: No such file or directory in .../admincp/cronadmin.php on line 107 Warning: include_once(): Failed opening '..././includes/cron/queueprocessor.php' for inclusion (include_path='.:/usr/local/lib/php') in .../admincp/cronadmin.php on line 107

    Please note: this vB-5.3.3 installation has been upgraded from 3.8.1 -> 4.2.5 -> 5.3.1 -> 5.3.3 just 2 days ago - so maybe the queueprocessor task is a left over from the 3.8.1 installation.

    Thanks again for your help.
    Stefan

    Leave a comment:


  • Wayne Luke
    replied
    By default, the queue system sends 10 emails every 10 minutes. This includes most emails from the system. You can adjust the emails per batch under Settings -> Options -> Email Options.

    You can see the number of items in the queue on the AdminCP home page. There is no way to view all queued items in the AdminCP. You would have to look at the database directly.

    If you do not need to use the queue due to hosting demands, I recommend turning it off.

    Leave a comment:


  • vB-5.3.3: sending mass emails to user using batch/queue does not work

    Hello,

    sending an Email to Users (AdminCP -> Users -> Send Email to Users) works fine, as long as I do not active the queueing / batch features. Enabling those features lead to a very quick usage of the Send Email to Users feature, but no message gets received by an user (I checked about 5 users).

    The queueprocessor and Sender for E-Mail queue scheduled tasks are enabled (AdminCP -> Scheduled tasks -> Administer...).

    Notification, password reminder and private message mails are send anyway.

    The Transaction log shows a lot of action in the email.php.

    Can you help me out? Which scheduled jobs need to be enabled for it? Can I check somehow, which jobs are currently in the queue?

    Thanks a lot.
    Stefan
widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
Working...
X