Announcement

Collapse
No announcement yet.

going to https lost adminpanel

Collapse
This topic is closed.
X
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • going to https lost adminpanel

    So i tried the proedure as described and change the http to https in site urls
    upon saving i lost admin panel
    i then did;
    back > change back ; no use
    edit .htaccess to allow ssl rewrite ; no use
    replace .htaccess with stock one ; no use
    turn ssl off ; no use

    I have all the access i need, but am unable to bring back the admin panel, is there a way to control settings other than to adminpanel?
    or does anyone have an idea what causes this/solve this?

    server debian, apapache2 with mod_ssl, valid cert;

    forums currently closed

  • #2
    Please follow our guide here:
    https://www.vbulletin.com/forum/arti...forum-to-https

    You need to complete EVERY step that is relevant to your version.

    Also "lost admin panel" doesn't tell us anything about the problem.
    MARK.B | vBULLETIN SUPPORT

    TalkNewsUK - My vBulletin 5.5.6 Demo
    AdminAmmo - My Cloud Demo

    Comment


    • #3
      lost adminpanel = 404 NOT FOUND url not on this server, which also goes for links to forums etc,
      I followed all steps except for step :
      (all steps prior done)
      Go to vBulletin Options > vBulletin Options > Site Name / URL / Contact Details.
      Edit these three settings: 'vBulletin URL'; 'Login URL'; 'Core URL' and add the 's' into the URL.
      For example, if your URL is http://www.contoso.com/forum, change it to https://www.contoso.com/forum
      done that for all 3 lines, and upon "save" i got a 404 reply

      from there i did the following;
      changed the default-ssl.conf with and without certs
      Changed the .htaccess to standard (cp txt) to activating ssl (rewrite) back and forth
      changed urls manually, removing or adding the s, in one instance i can get to login screen for adminpanle if i actually add core to the url, but that is where it ends, 404 after that again

      site acessible (locked state) https://www.pacersdigest.com

      thanks for your time and attention, perhaps i was not clear with "lost admin panel" (one day i make that my 404 screen ;P ) however as i stated the last 2 steps could not be done, considering i dont get the options.php back as i should.

      Comment


      • #4
        I'm still getting a "Deceptive Site" warning on your site. This can lead to firewalls/anti-virus software also blocking pages that they determine are holding malicious code (rightly or wrongly) and failing to load the page as a result.

        Have you completed the process to have your site de-listed as malicious since your site was upgraded recently?
        Vote for:

        - *Admin Settable Paid Subscription Reminder Timeframe*
        -
        *PM - Add ability to reply to originator only*
        - Add Admin ability to auto-subscribe users to specific channel(s)
        - Highlight the correct navigation tab when you are on a custom page
        - "Quick Route" Interface...
        - Allow to use custom icons for individual forums

        Comment


        • #5
          if i pay for support, are people less denigrating?
          Two replies and twice you're implying i'm an idiot; not the best of plans.
          P.S. in order to complete de-listing you need to have a site up and running, but also you can bypass the warning, and the site should work, which it doesn't. and finally I am not to sure hte upgrade solved the mailicous warning, (in fact i'm 98% sure it didn't do anyting for it) since have long since concluded that hte posts that relay to twitter feeds and such are the ones causing hte warning in the first place.

          Comment


          • #6
            There was actually a malicious plugin that I removed as part of the upgrade. Links to Twitter posts/feeds won't cause this unless you've had feedback from Google to say that specifically?

            Have you completed the forms listed on this page:

            http://mzl.la/1BAVoBE
            Vote for:

            - *Admin Settable Paid Subscription Reminder Timeframe*
            -
            *PM - Add ability to reply to originator only*
            - Add Admin ability to auto-subscribe users to specific channel(s)
            - Highlight the correct navigation tab when you are on a custom page
            - "Quick Route" Interface...
            - Allow to use custom icons for individual forums

            Comment


            • #7
              Trevor, sorry for snapping at you but in my defense, please please talk to me like an adult that knows his way around a server and vb.
              I have been using vb for a great deal of years, and the fact paid for the upgrade only means that i didn't have the time to do it. not that i'm incapable.
              No I have not completed anything as yet, as A: I'm to busy and asked someone else to do so for me, but he's to busy too, B: when i started setting up the certificate and move the https i encountered a problem that shut me out of the admin panel, (see above post)
              All i want to know for now is;
              A: is there a way to reverse the change to https in the admin panel without access to the panel.
              B: i have reversed all the cert stuff on the server as it also hosts a forgotten mail server, which uses tls on a self signed cert which clashes with the website cert atm.
              C: currently both are down, and i don't have the time to go on a search and rescue on the server to solve;
              D: for now it is my plan to move the site to another server that only hosts another website that doesn't requre ssl/tls and has more capacity.

              I am looking at the minimum for clues, options etc and chases down long winding roads that are not part of the core problem are not on my path today.

              I mean it when i say i am sorry for being "touchy" but as excuse i'm extremely busy IRL.

              Comment


              • #8
                You will need to update the URLs in the database if you've no access to the AdminCP. You need to check the following in the 'setting' table:

                - bburl
                - frontendurl
                - frontendurl_login

                You'll also need to edit the same values in the 'datastore' table (Options row)

                If you're struggling to do this or find the time to do it, please fill out a support ticket at:

                http://members.vbulletin.com/members...ontactform.php

                Please include a complete description of the problem and be sure to include the login info to your Admin CP, phpMyAdmin and FTP in the 'Sensitive Data' field.
                Vote for:

                - *Admin Settable Paid Subscription Reminder Timeframe*
                -
                *PM - Add ability to reply to originator only*
                - Add Admin ability to auto-subscribe users to specific channel(s)
                - Highlight the correct navigation tab when you are on a custom page
                - "Quick Route" Interface...
                - Allow to use custom icons for individual forums

                Comment


                • #9
                  thank you, i will open a ticket because i am really w ay to busy to go play sql at the moment, considering i'm a cli guy, and i have a number of telephone conferences going today, i better let someone else concentrate on this,
                  1 question left before ticket creation, do I move the site prior or after?

                  Comment


                  • #10
                    I would move as is - make sure all is OK on the new server then make the change to https once you're sure. If you do two things at once and there's an issue, it's not as easy to track down which of the changes have caused it.
                    Vote for:

                    - *Admin Settable Paid Subscription Reminder Timeframe*
                    -
                    *PM - Add ability to reply to originator only*
                    - Add Admin ability to auto-subscribe users to specific channel(s)
                    - Highlight the correct navigation tab when you are on a custom page
                    - "Quick Route" Interface...
                    - Allow to use custom icons for individual forums

                    Comment


                    • #11
                      I was thinking the same, will move it in the next 2 hours, install the cert, then make the ticket, thanks Trevor

                      Comment


                      • #12

                        Ok this site has been down long enough, I have sqldump from before upgrade, one from day things went ape.... and one made after changing https to http in dbase as mentioned above, so that should be ok
                        then I have copied all content of the site folder to a backup folder, so now the question raises;

                        1. can re-install site like this, without problems?
                        2. if things go wrong is copying the site folders back enough to restore ?(I understand if something goes wrong with the dbase i have to restore that, but in my book i'm not yet doing anything with the database as the current should be ok)

                        thanks for anyone answering

                        Comment


                        • #13
                          1) Why are you editing the database directly? This shouldn't really be considered a course of action. Doing so can make your site unusable.

                          2) Making the change to HTTPS should not affect the AdminCP in any way.

                          To answer your questions:
                          1) You would lose all your existing data if you reinstalled.
                          2) No. The site folders do not contain the database where all information about your installation is stored. The files themselves have nothing to do with whether your site runs on HTTPS or not.
                          Translations provided by Google.

                          Wayne Luke
                          The Rabid Badger - a vBulletin Cloud demonstration site.
                          vBulletin 5 API - Full / Mobile
                          Vote for your favorite feature requests and the bugs you want to see fixed.

                          Comment


                          • #14
                            Ichanged them in the database based upon this post;
                            You will need to update the URLs in the database if you've no access to the AdminCP. You need to check the following in the 'setting' table:

                            - bburl
                            - frontendurl
                            - frontendurl_login

                            You'll also need to edit the same values in the 'datastore' table (Options row)


                            as posted by Trevor

                            Comment


                            • #15
                              Wayne

                              can we try and work together to get the site back up again? I'd way prefer that over the teling off and such, only reason I'm proposing things is because the site is down and when I have a spare moment (albeit far and few between) i "TRY" things that "may" fix it. so far it was unsuccessfull but nonetheless the solution is out there!

                              if we communicate like intelligent beings I am sure we can solve the problem, and have all my users happy and my site back online, and no I'm not losing income as it is and has been fully sponsored by me and I made a conscious choice not to do ads.

                              But NBA starting again this week, so lots to discuss

                              Comment

                              Related Topics

                              Collapse

                              Working...
                              X