Announcement

Collapse
No announcement yet.

Mass prune problem

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Mass prune problem

    Hi,

    I tried without success to delete the spammer group on our forums.
    I checked all that's necessary but the system says I do not?
    Bernard

  • #2
    I cannot recreate the issue on my test installation. Try setting the date to yesterday.

    I've tried this on two different installations on different servers and can't recreate the problem.

    What version of PHP are you using?
    Translations provided by Google.

    Wayne Luke
    The Rabid Badger - a vBulletin Cloud customization and demonstration site.
    vBulletin 5 Documentation - Updated every Friday. Report issues here.
    vBulletin 5 API - Full / Mobile
    I am not currently available for vB Messenger Chats.

    Comment


    • #3
      Originally posted by Wayne Luke View Post
      I cannot recreate the issue on my test installation. Try setting the date to yesterday.

      I've tried this on two different installations on different servers and can't recreate the problem.

      What version of PHP are you using?
      7.0.16
      Bernard

      Comment


      • #4
        How many users are you trying to delete? Is it more than a thousand, a few hundred? The problem is the URL generated to delete the users is longer than your web server allows so it is ignoring everything past a certain number of characters and one of the required fields is the last part of the URL so it is never received by vbulletin.

        Some servers have abnormally small max URL length set but most of the time people deleting hundreds or thousands (or more) users run into this issue. The best option is to use the other fields like join date to reduce the number of users deleted at any one time. In my experience the sweet spot is around 1,000 users but it can vary server to server and forum to forum, (If userids are 5 or 6 characters long it will be less users than if userids are 4 characters long.) It will be some trial and error, but you can find a safe number and run the task several times to delete all the users you need to delete.

        The same issue existed in the VB 3/4 prune user tool.

        Comment


        • #5
          Over 3700 members/spammers
          Bernard

          Comment


          • #6
            So change the join date so that say only 700 users are found, then try deleting 700 at once.

            Then try again, if it works, try to find a date where you can get between 900 and 1000 users.

            You will need the change the date several times to get all the users. You can't delete 3,700 at once on most servers.

            Comment


            • #7
              Hi,

              There is another problem when I'm in the message center and try to delete unapproved/spammers posts:
              Even if there is only one post selected: When I delete the post with sending the spammer info to antispam services I get this =>
              Bernard

              Comment

              widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
              Working...
              X