Announcement

Collapse
No announcement yet.

Another SLL issue

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Mark.B
    replied
    The advice remains the same. That is not a path called by vBulletin. You need to speak to your hosts.

    Leave a comment:


  • Lexus!
    replied
    It's a long time ago, but we are trying again. Now, still the same issue..

    Code:
     
     [Wed Mar 06 07:58:39.581467 2019] [php7:warn] [pid 9337] [client xxx.xxx.xxx.xxx:9931] PHP Warning:  require_once(/home/dc015/domains/config.php): failed to open stream: No such file or directory in /home/dc015/domains/wijhebbensarcoidose.nl/public_html/includes/vb5/config.php on line 65 [Wed Mar 06 07:58:39.581531 2019] [php7:error] [pid 9337] [client xxx.xxx.xxx.xxx:9931] PHP Fatal error:  require_once(): Failed opening required '/home/dc015/domains/config.php'
    This error only appears when accessing https:// in stead of http://

    Today I installed vBulletin on a different domain, on the same server. https://www.lexusonline.nl/forum/. Works like a charm, also with SSL. So the server should be ok. I compared the htaccess, config.php, core/includes/config.php and did not see strange differences.

    Leave a comment:


  • Wayne Luke
    replied
    Only if you have edited it. However since the site works without SSL and using HTTP, the file is fine. There are not specific files for HTTP and HTTPS. That file processes the files that can be edited so the system works. Still, the fact of the matter is that the server is trying to load a file from a non-existent location on your server. Specifically this path:
    Code:
     /home/dc015/domains/config.php
    We would not call this path in the software. Only your hosting provider can determine why it is calling the file with this truncated path instead of the full path that is required. Until that is resolved, you will continue to get a PHP fatal error under HTTPS and the 500 server error will be shown. There should be absolutely no difference running vBulletin under HTTP or HTTPS. On a properly configured server, if one works then the other will.

    Leave a comment:


  • Lexus!
    replied
    I understand you've thousands of sites running vBulletin under SSL. But I thought we checked the proper functioning of the path with the provided files? Every time I set the forum to https, the error 500 comes up directly.

    In the following folder I found another config.php, is it possible there is something wrong with this one? We use this forumsoftware from early in the beginning, so maybe there are old, incompatible files or settings left over?

    Code:
    /home/dc015/domains/wijhebbensarcoidose.nl/public_html/includes/vb5/config.php

    Leave a comment:


  • Wayne Luke
    replied
    You're hosting provider will need to figure out why the path isn't working properly. Something is providing the incorrect path. We have thousands of sites running vBulletin under SSL without issue including every single vBulletin Cloud site and this site without modifying the software.

    Leave a comment:


  • Lexus!
    replied
    Originally posted by Wayne Luke View Post

    When vBulletin builds a directory name, it asks the server what our current directory is. The most common method to do this is the __DIR__ constant in PHP. From there, we can traverse the vBulletin file structure as needed because we know where everything is. We expect the value to be correct. If the file is in /home/dc015/domains/wijhebbensarcoidose.nl/public_html/core/includes/ that is the answer that we expect. If the server returns /home/dc015/domains/, our software has to assume it is true. Now if there are permission issues where PHP cannot see some subdirectories for whatever reason, they won't be included in the returned path. PHP thinks it is in /home/dc015/domains/.

    This is not something under our control and a pure server configuration issue that comes down to the user that PHP executes under and the permissions granted. It has nothing to do with pointers unless the PHP user does not have access to an endpoint for some reason.

    Please note that in many environments, PHP is not a distinct user and is accessed using the same user as the web server. However, if the server is using something like SUEXEC, these users will be different and must have their own permissions.

    Unzip the attached file and put it in the /core/ directory. Load it in your browser. What is the output?
    Thank you, glad there are still some options to check

    The output is: /home/dc015/domains/wijhebbensarcoidose.nl/public_html/core

    Originally posted by Wayne Luke View Post
    You can also try adding your path to the /core/includes/config.php.

    Find this code:
    PHP Code:
    // ******** FULL PATH TO FORUMS DIRECTORY ******
    // On a few systems it may be necessary to input the full path to your forums directory
    // for vBulletin to function normally. You can ignore this setting unless vBulletin
    // tells you to fill this in. Do not include a trailing slash!
    // Example Unix:
    // $config['Misc']['forumpath'] = '/home/users/public_html/forums';
    // Example Win32:
    // $config['Misc']['forumpath'] = 'c:\program files\apache group\apache\htdocs\vb3';
    $config['Misc']['forumpath'] = ''
    And change it to:
    PHP Code:
    // ******** FULL PATH TO FORUMS DIRECTORY ******
    // On a few systems it may be necessary to input the full path to your forums directory
    // for vBulletin to function normally. You can ignore this setting unless vBulletin
    // tells you to fill this in. Do not include a trailing slash!
    // Example Unix:
    // $config['Misc']['forumpath'] = '/home/users/public_html/forums';
    // Example Win32:
    // $config['Misc']['forumpath'] = 'c:\program files\apache group\apache\htdocs\vb3';
    $config['Misc']['forumpath'] = '/home/dc015/domains/wijhebbensarcoidose.nl/public_html'
    I just tried to change this setting, but also then (when switching to https urls) the error 500 comes up. In the Direct Admin log I still see these errors:
    Code:
    [Fri Aug 18 10:33:28.443168 2017] [:error] [pid 15966] [client ip:60559] PHP Warning:  require_once(/home/dc015/domains/config.php): failed to open stream: No such file or directory in /home/dc015/domains/wijhebbensarcoidose.nl/public_html/includes/vb5/config.php on line 65
    [Fri Aug 18 10:33:28.443331 2017] [:error] [pid 15966] [client ip:60559] PHP Fatal error:  require_once(): Failed opening required '/home/dc015/domains/config.php' (include_path='.:/usr/local/php56/lib/php') in /home/dc015/domains/wijhebbensarcoidose.nl/public_html/includes/vb5/config.php on line 65
    After saving the settings changing 3 urls from http to https, I get the screen with comment settings successfully saved. After the redirect, I got a white, empty screen in the admin. The menu still exists, but the content frame is empty. When I try to open the admin on a new page, I get the error 500.

    Then I have 2 ways to recover the forum. The first is restoring a backup, the second (I discovered today.. lol) is going 2 pages back in the browser where I set the setting, change the https back to http, and save. Trying to recover the setting after closing the browser is not possible.

    Leave a comment:


  • Wayne Luke
    replied
    You can also try adding your path to the /core/includes/config.php.

    Find this code:
    PHP Code:
    // ******** FULL PATH TO FORUMS DIRECTORY ******
    // On a few systems it may be necessary to input the full path to your forums directory
    // for vBulletin to function normally. You can ignore this setting unless vBulletin
    // tells you to fill this in. Do not include a trailing slash!
    // Example Unix:
    // $config['Misc']['forumpath'] = '/home/users/public_html/forums';
    // Example Win32:
    // $config['Misc']['forumpath'] = 'c:\program files\apache group\apache\htdocs\vb3';
    $config['Misc']['forumpath'] = ''
    And change it to:
    PHP Code:
    // ******** FULL PATH TO FORUMS DIRECTORY ******
    // On a few systems it may be necessary to input the full path to your forums directory
    // for vBulletin to function normally. You can ignore this setting unless vBulletin
    // tells you to fill this in. Do not include a trailing slash!
    // Example Unix:
    // $config['Misc']['forumpath'] = '/home/users/public_html/forums';
    // Example Win32:
    // $config['Misc']['forumpath'] = 'c:\program files\apache group\apache\htdocs\vb3';
    $config['Misc']['forumpath'] = '/home/dc015/domains/wijhebbensarcoidose.nl/public_html'

    Leave a comment:


  • Wayne Luke
    replied
    Originally posted by Lexus! View Post
    Yes, I renamed (and updated) both config files, but that doesn't help.

    My hoster looked to this topic and tells me this can't be a server issue. SSL works fine, there is a virtual pointer from https to http.

    I still think it's strange the log file shows me vBulletin is looking for a config file that place. It's looking 2 folders above the normal root:

    Code:
    Log file: /home/dc015/domains/config.php
    
    Should be: /home/dc015/domains/wijhebbensarcoidose.nl/public_html/config.php
    Or: /home/dc015/domains/wijhebbensarcoidose.nl/public_html/core/includes/config.php
    But, now I'm in the middle of a discussion, pointing to eachother while I can't figure out the problem or be able to run my forum with SSL. I hope you can find something else this can cause these issue.
    When vBulletin builds a directory name, it asks the server what our current directory is. The most common method to do this is the __DIR__ constant in PHP. From there, we can traverse the vBulletin file structure as needed because we know where everything is. We expect the value to be correct. If the file is in /home/dc015/domains/wijhebbensarcoidose.nl/public_html/core/includes/ that is the answer that we expect. If the server returns /home/dc015/domains/, our software has to assume it is true. Now if there are permission issues where PHP cannot see some subdirectories for whatever reason, they won't be included in the returned path. PHP thinks it is in /home/dc015/domains/.

    This is not something under our control and a pure server configuration issue that comes down to the user that PHP executes under and the permissions granted. It has nothing to do with pointers unless the PHP user does not have access to an endpoint for some reason.

    Please note that in many environments, PHP is not a distinct user and is accessed using the same user as the web server. However, if the server is using something like SUEXEC, these users will be different and must have their own permissions.

    Unzip the attached file and put it in the /core/ directory. Load it in your browser. What is the output?
    Attached Files

    Leave a comment:


  • Mark.B
    replied
    Hosts ALAWAYS say "it's a software issue" so that's not going to have any bearing on it to be honest. If the software had a bug, which is what they are implying, we'd have hundreds if not thousands of customers reporting it.

    It's important to ensure no changes are made to any of the configuration files beyond the database information. There are lines within them that contain paths and sometimes people seem to change these. They should all be default. Even if it looks wrong. Changes to these paths can cause the errors you are seeing.

    It may be worth downloading fresh copies of the two config files, reconfiguring the core config file with the database info, and uploading these with no other changes.

    Leave a comment:


  • Lexus!
    replied
    Yes, I renamed (and updated) both config files, but that doesn't help.

    My hoster looked to this topic and tells me this can't be a server issue. SSL works fine, there is a virtual pointer from https to http.

    I still think it's strange the log file shows me vBulletin is looking for a config file that place. It's looking 2 folders above the normal root:

    Code:
    Log file: /home/dc015/domains/config.php
    
    Should be: /home/dc015/domains/wijhebbensarcoidose.nl/public_html/config.php
    Or: /home/dc015/domains/wijhebbensarcoidose.nl/public_html/core/includes/config.php
    But, now I'm in the middle of a discussion, pointing to eachother while I can't figure out the problem or be able to run my forum with SSL. I hope you can find something else this can cause these issue.
    Last edited by Lexus!; Mon 14th Aug '17, 11:47pm.

    Leave a comment:


  • Wayne Luke
    replied
    If you renamed config.php.bkp to config.php and /core/includes/config.php.new to /core/includes/config.php and the server cannot find the files it is a either a permission error on the server. Or the server has some sort of security settings preventing the web server from viewing the files. Neither of these are something we can solve for you. Only your hosting provider or server administrator can help you resolve server errors.

    That the software worked before trying to move to SSL points to server configuration issues. vBulletin doesn't actually care or do anything different on SSL or Non-SSL. The only thing you have to do in vBulletin is updating your URLs so the software points to the correct version you want. This doesn't change any behavior or require any changes to files if it worked previously.

    Leave a comment:


  • Lexus!
    replied
    Originally posted by Glenn Vergara View Post
    It is looking for the config.php in the wrong directory '/home/dc015/domains/config.php' .
    True, that's wat I understand from the logs..

    Originally posted by Wayne Luke View Post
    There are two config.php files... One in the root directory of vBulletin and one in /core/includes.
    I also found these two config.php files.
    Based on earlier posts, the config.php in root is replaced by the bkp version.
    Like I wrote earlier, I tried to edit the forumpath variable in the config.php in /core/includes, but that didn't change the search path in the logs. Now it's empty again, like it was.

    So both of you were right, but what can I do?

    Leave a comment:


  • Wayne Luke
    replied
    There are two config.php files... One in the root directory of vBulletin and one in /core/includes.

    Leave a comment:


  • Glenn Vergara
    replied
    It is looking for the config.php in the wrong directory '/home/dc015/domains/config.php' .

    Leave a comment:


  • Lexus!
    replied
    I tried, but also renaming the .bkp to php results in the same error 500. The Direct Admin logs say:
    Code:
    [Fri Aug 04 12:01:57.961535 2017] [:error] [pid 27943] [client ip:53957] PHP Warning: require_once(/home/dc015/domains/config.php): failed to open stream: No such file or directory in /home/dc015/domains/wijhebbensarcoidose.nl/public_html/includes/vb5/config.php on line 65
    [Fri Aug 04 12:01:57.961715 2017] [:error] [pid 27943] [client ip:53957] PHP Fatal error: require_once(): Failed opening required '/home/dc015/domains/config.php' (include_path='.:/usr/local/php56/lib/php') in /home/dc015/domains/wijhebbensarcoidose.nl/public_html/includes/vb5/config.php on line 65
    I even tried to change the internal forum path in the config.php in core/includes, but that didn't work either and gives the same errors.

    It seems to be a path issue, but where to correct?

    Leave a comment:

Related Topics

Collapse

Working...
X