Announcement

Collapse
No announcement yet.

http to https login issue

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • blade00
    started a topic http to https login issue

    http to https login issue

    Hi, I tried to switch from http to https protocol, the SSL certificate has already been installed from the hoster.
    When I try to change the 3 addresses from http to https on vbulletin admin options (name site/address/contact details) I can't log in anymore and the log in box doesn't work too. Could anyone please help me with this issue?

  • MDawg
    replied
    Figured it out!

    Needed to add these to the mysite directory
    RewriteEngine On
    RewriteCond %{SERVER_PORT} 80
    RewriteRule ^(.*)$ https://www.mysite.com/$1 [R=301,L]

    and this to the mysite/forums directory
    RewriteEngine On
    RewriteCond %{SERVER_PORT} 80
    RewriteRule ^(.*)$ https://www.mysite.com/forums/$1 [R=301,L]

    And the same to each of the other three ones (other three sites)!
    Last edited by MDawg; Sat 3rd Feb '18, 9:02am.

    Leave a comment:


  • MDawg
    replied
    I did talk to HostGator, they said that the redirection of non-https to https is via coding. I assume they mean via .htaccess ?

    The problem is that I have four sites on this VPS server, and now redirection is getting really screwy. The .htaccess seem to be conflicting. I added a post to my ticket 1653216 to explain this.
    Last edited by MDawg; Sun 4th Feb '18, 6:55am.

    Leave a comment:


  • Mark.B
    replied
    I've set your vB5 site to https and I can log in just fine.

    Make sure you clear your browser cache and restart the browser.

    What you should now do is ask your hosts to arrange redirection of non-https to https. Otherwise you will get log in issues.

    Obviously you do need to now access the site via https://, using http won't work, hence the need for the redirect.

    Leave a comment:


  • MDawg
    replied
    I did place all of those details into the ticket in the bottom secure area.

    Leave a comment:


  • Mark.B
    replied
    Originally posted by MDawg View Post
    Could someone please take a look at ticket #1653216 I posted here only because it was an emergency and I needed to revert the site.

    Right now with all three set at http the problem is that with https the forum does not load at all. I mean, obviously because the settings are http, but when I try to change them to https I have problems.
    We will need as a minimum the admincp login and ftp credentials, please add these to the ticket, otherwise when someone picks it up they are just going to ask for these. We need access to the system to see what's going on.

    Leave a comment:


  • MDawg
    replied
    Could someone please take a look at ticket #1653216 I posted here only because it was an emergency and I needed to revert the site.

    Right now with all three set at http the problem is that with https the forum does not load at all. I mean, obviously because the settings are http, but when I try to change them to https I have problems.

    Leave a comment:


  • Wayne Luke
    replied
    Your .htaccess is broken or the /admincp/ directory is missing from your site.

    Leave a comment:


  • MDawg
    replied
    Okay I removed the PW protection for the directories for now, accessed. I followed all those steps.

    However, still there is something strange going on, as although I can access ACP via direct
    /core/admincp/
    if I am logged into the site and click on the admincp, it does not work, still get 401 missing error.

    So, rather than mess with it, I reverted all three to http (NOT https) and I basically have the same thing going on as was described in this thread if I try to change the three URLs to https - inability to login.


    Leave a comment:


  • blade00
    replied
    I think you can put tools.php into install directory and go to /core/install/itools.php by browser

    Leave a comment:


  • Wayne Luke
    replied
    Try using /admincp/tools.php. Can you access it that way?

    Leave a comment:


  • MDawg
    replied
    Originally posted by Mark.B View Post

    Yes you need all three changed. You will need to correct this using tools.php:

    1) Upload /core/install
    2) Upload tools.php in your do_not_upload directory to /core/admincp
    3) Run /core/admincp/tools.php in your browser and enter your customer number
    4) Go to Other Tools > Location of Website
    5) Enter the correct URL, make sure the core URL option is ticked, and save
    6) Verify that the site loads ok
    7) Delete /core/admincp/tools.php
    8) Delete /core/install
    9) Verify that the admincp works ok, WITHOUT /core/ in the URL
    Trying. My admincp is password protected directory and for some reason cannot get into it via
    /core/admincp/tools.php
    no matter how many times I enter the correct username/PW.

    (I AM able to access the password protected directory via
    /core/admincp
    but not via /core/admincp/tools.php )

    Leave a comment:


  • blade00
    replied
    Thank you very much Mark, I really appreciate your job!

    Leave a comment:


  • Mark.B
    replied
    Originally posted by MDawg View Post
    Mark B. Can you please take a look at my ticket
    Ticketid: 1653216


    Basically I did only the first one: 'vBulletin URL' I did not change anything else...is that the root of the problem? Now I cannot access ACP and seems like no one can login.

    Go to vBulletin Options > vBulletin Options > Site Name / URL / Contact Details.
    Edit these three settings: 'vBulletin URL'; 'Login URL'; 'Core URL' and add the 's' into the URL.
    For example, if your URL is http://www.contoso.com/forum, change it to https://www.contoso.com/forum
    NOTE: Do not remove the word 'core' at the end of the core URL. You will break your site!

    Then go to Settings > Options > Server Settings & Optimization Options > Use Remote jQuery
    Set this to Google.

    The key to all three vBulletin versions is that all you do in the URL settings is change http to https. Do not alter any other part of the URL.

    Once you have changed these settings, go to AdminCP > Maintenance > General Update Tools, and rebuild the styles. (In vB3 this is AdminCP > Maintenance > Update Counters). Leave the default settings and just run this update tool.
    Yes you need all three changed. You will need to correct this using tools.php:

    1) Upload /core/install
    2) Upload tools.php in your do_not_upload directory to /core/admincp
    3) Run /core/admincp/tools.php in your browser and enter your customer number
    4) Go to Other Tools > Location of Website
    5) Enter the correct URL, make sure the core URL option is ticked, and save
    6) Verify that the site loads ok
    7) Delete /core/admincp/tools.php
    8) Delete /core/install
    9) Verify that the admincp works ok, WITHOUT /core/ in the URL

    Leave a comment:


  • MDawg
    replied
    Mark B. Can you please take a look at my ticket
    Ticketid: 1653216


    Basically I did only the first one: 'vBulletin URL' I did not change anything else...is that the root of the problem? Now I cannot access ACP and seems like no one can login.

    Go to vBulletin Options > vBulletin Options > Site Name / URL / Contact Details.
    Edit these three settings: 'vBulletin URL'; 'Login URL'; 'Core URL' and add the 's' into the URL.
    For example, if your URL is http://www.contoso.com/forum, change it to https://www.contoso.com/forum
    NOTE: Do not remove the word 'core' at the end of the core URL. You will break your site!

    Then go to Settings > Options > Server Settings & Optimization Options > Use Remote jQuery
    Set this to Google.

    The key to all three vBulletin versions is that all you do in the URL settings is change http to https. Do not alter any other part of the URL.

    Once you have changed these settings, go to AdminCP > Maintenance > General Update Tools, and rebuild the styles. (In vB3 this is AdminCP > Maintenance > Update Counters). Leave the default settings and just run this update tool.

    Leave a comment:

Related Topics

Collapse

Working...
X