Announcement

Collapse
No announcement yet.

http to https login issue

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • #31
    So what is blocking the login box when under HTTPS? What do your logs say? vBulletin doesn't really care. Especially in vBulletin 5 because we made the entire system work in a protocol-less manner and it will rely 100% on the LOGIN URL specified in the AdminCP. You cannot mix HTTP and HTTPS. It is all or nothing so all three URLs need to be HTTPS.

    From there, your server handles everything. It handles send the URL to the software so we can interpret it. It handles what files can be loaded and what is blocked.

    What does your server administrator say about HTTPS handling?
    Translations provided by Google.

    Wayne Luke
    The Rabid Badger - a vBulletin Cloud customization and demonstration site.
    vBulletin 5 Documentation - Updated every Friday. Report issues here.
    vBulletin 5 API - Full / Mobile
    I am not currently available for vB Messenger Chats.

    Comment


    • #32
      I still have the same issue, the server administrator says that It's not an hoster issue as all the other sites have not issues with https (I have to say that I also have a wordpress site with them and It perfectly works with https). It seems to be a vbulletin issue...

      Comment


      • #33
        Ah, another host blaming the software.....

        If there was an issue with vBulletin, we would have hundreds of customers reporting it.

        Are you fully redirecting http to https? This is essential.
        MARK.B | vBULLETIN SUPPORT

        TalkNewsUK - My vBulletin 5.5.2 Demo
        AdminAmmo - My Cloud Demo

        Comment


        • #34
          Sorry I did changed the 3 urls and activated https with full redirect htaccess but the login box doesn't work, I can't understand why..

          Comment


          • #35
            Has the third URL still got /core at the end? It MUST have that.
            MARK.B | vBULLETIN SUPPORT

            TalkNewsUK - My vBulletin 5.5.2 Demo
            AdminAmmo - My Cloud Demo

            Comment


            • #36
              Yes, It has, I followed all the instructions but still have the issue.

              Comment


              • #37
                This is the htaccess modification my hoster asks:

                RewriteEngine On
                RewriteCond %{HTTP:X-Forwarded-Proto} !https
                RewriteCond %{HTTP_HOST} ^www.
                RewriteCond %{HTTPS} off
                RewriteRule ^ https://%{HTTP_HOST}%{REQUEST_URI} [L,R=301,NE]

                Comment


                • #38
                  now I set back https, you can see how the login box appears on fiattipoclub .it

                  Comment


                  • #39
                    Your site doesn't work at all on https. It doesn't load properly using https.
                    MARK.B | vBULLETIN SUPPORT

                    TalkNewsUK - My vBulletin 5.5.2 Demo
                    AdminAmmo - My Cloud Demo

                    Comment


                    • #40
                      You are right, but it's because I changed again to http in order to keep the forum working

                      Comment


                      • #41
                        Originally posted by blade00 View Post
                        This is the htaccess modification my hoster asks:

                        RewriteEngine On
                        RewriteCond %{HTTP:X-Forwarded-Proto} !https
                        RewriteCond %{HTTP_HOST} ^www.
                        RewriteCond %{HTTPS} off
                        RewriteRule ^ https://%{HTTP_HOST}%{REQUEST_URI} [L,R=301,NE]
                        We actually include similar in the default .htaccess file. You need to use our .htaccess. Do not replace it with one from your hosting provider. If you do not use our .htaccess rewrites than your site will not work properly. Any hosting provider worth your money should have been able to review the existing file, seen the existing rules, and uncomment them for you.

                        To enable the redirect you simply need to uncomment these lines by removing the #:
                        Code:
                            #RewriteCond %{HTTPS} !=on
                            #RewriteRule .* https://%{SERVER_NAME}%{REQUEST_URI} [R=301,L]
                        Translations provided by Google.

                        Wayne Luke
                        The Rabid Badger - a vBulletin Cloud customization and demonstration site.
                        vBulletin 5 Documentation - Updated every Friday. Report issues here.
                        vBulletin 5 API - Full / Mobile
                        I am not currently available for vB Messenger Chats.

                        Comment


                        • #42
                          Thank you Wayne Luke, if I try to use the standard rules that you wrote, it seems not to work the redirect (the site goes down), I don't understand why...

                          Comment


                          • #43
                            Originally posted by blade00 View Post
                            Thank you Wayne Luke, if I try to use the standard rules that you wrote, it seems not to work the redirect (the site goes down), I don't understand why...
                            This is something you would need to take up with your host.

                            The code we provide in the .htaccess file should work on most servers, but it is down to the individual server configuration, over which we have no control.

                            You should speak to your hosts about this.
                            MARK.B | vBULLETIN SUPPORT

                            TalkNewsUK - My vBulletin 5.5.2 Demo
                            AdminAmmo - My Cloud Demo

                            Comment


                            • #44
                              I ask it to my host and come back here with their answer, thanks!

                              Comment


                              • #45
                                Change "!=on" to "off" then it will match your host's overly verbose rules.
                                Translations provided by Google.

                                Wayne Luke
                                The Rabid Badger - a vBulletin Cloud customization and demonstration site.
                                vBulletin 5 Documentation - Updated every Friday. Report issues here.
                                vBulletin 5 API - Full / Mobile
                                I am not currently available for vB Messenger Chats.

                                Comment

                                Related Topics

                                Collapse

                                Working...
                                X