Announcement

Collapse
No announcement yet.

http to https login issue

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • #16
    I understand the issue. I don't know what the solution is because you keep changing back to HTTP and I cannot experience the issue or try to debug it. At this point in time, you'll just have to stay on HTTP until you can leave it on HTTPS for an extended period of time to let us try to diagnose the problem.
    Translations provided by Google.

    Wayne Luke
    The Rabid Badger - a vBulletin Cloud customization and demonstration site.
    vBulletin 5 Documentation - Updated every Friday. Report issues here.
    vBulletin 5 API - Full / Mobile
    I am not currently available for vB Messenger Chats.

    Comment


    • #17
      Ok, i set again https and I'll leave it until your replay, thank you

      Comment


      • #18
        I don't have an answer but can replicate the issue. Please make sure your hosting company isn't blocking this URL for any reason:
        https://www.fiattipoclub.it/auth/login-form?vb_login_redirected=1&url=aHR0cHM6Ly93d3cuZmlhdHRpcG9jbHViLml0

        The string on the end is going to change based on the page the person accesses the login form from. Should be the same login URL as HTTP in general. You can turn off HTTPS for now.
        Translations provided by Google.

        Wayne Luke
        The Rabid Badger - a vBulletin Cloud customization and demonstration site.
        vBulletin 5 Documentation - Updated every Friday. Report issues here.
        vBulletin 5 API - Full / Mobile
        I am not currently available for vB Messenger Chats.

        Comment


        • #19
          thank you, I ask to the hoster and I come back here with their answer!

          Comment


          • #20
            I found here an other discussion for the same issue: https://www.vbulletin.com/forum/foru...rect-login-url

            Are we sure that excluded for cloud solution It's possible to set https on vbulletin 5? The hosting company say to check with VB support as there's no limitations or blocks for any urls...

            Comment


            • #21
              This site isn't using vBulletin Cloud and it is using HTTPS. vBulletin Cloud uses the same software you download and has the same features you have available. We hide some features in Cloud using the Permission system and the architecture it runs on is a little different from your standard website. There shouldn't be any problem running the software under HTTPS.

              I don't know what is causing your issue. If I go to https://www.fiattipoclub.it/auth/ it should give me an "Invalid Page URL" error from vBulletin. Instead, it redirects to your homepage. If you find out why this is redirecting, you will probably be closer to fixing your issue.
              Translations provided by Google.

              Wayne Luke
              The Rabid Badger - a vBulletin Cloud customization and demonstration site.
              vBulletin 5 Documentation - Updated every Friday. Report issues here.
              vBulletin 5 API - Full / Mobile
              I am not currently available for vB Messenger Chats.

              Comment


              • #22
                Do you think It may be an .htaccess issue? I've never modified the source code, It's just VB installed on the server...
                Last edited by blade00; Fri 21st Jul '17, 8:54am.

                Comment


                • #23
                  Post the entire contents of your .htaccess file and I'll review it.
                  Translations provided by Google.

                  Wayne Luke
                  The Rabid Badger - a vBulletin Cloud customization and demonstration site.
                  vBulletin 5 Documentation - Updated every Friday. Report issues here.
                  vBulletin 5 API - Full / Mobile
                  I am not currently available for vB Messenger Chats.

                  Comment


                  • #24
                    <IfModule mod_rewrite.c>
                    RewriteEngine On
                    #This file is included for Mac users, who can't see the .htaccess file. This should be renamed to .htaccess, without extension,
                    #when deployed to the web server.

                    #In some cases where you have other mod_rewrite rules, you may need to comment out the following line
                    #and change it to match your folder name. This resets the other mod_rewrite rules for just this directory
                    #If your site was www.example.com/forum, the setting would be /forum/
                    RewriteBase /

                    # Send css calls directly to the correct file VBV-7807
                    RewriteRule ^css.php$ core/css.php [NC,L]

                    # Redirect old install path to core.
                    RewriteRule ^install/ core/install/ [NC,L]

                    # Main Redirect
                    RewriteCond %{REQUEST_URI} !\.(gif|jpg|jpeg|png|css)$
                    RewriteCond %{REQUEST_FILENAME} !-f
                    RewriteCond %{REQUEST_FILENAME} !-d
                    RewriteRule ^(.*)$ index.php?routestring=$1 [L,QSA]

                    # Because admincp is an actual directory.
                    RewriteRule ^(admincp/)$ index.php?routestring=$1 [L,QSA]

                    </IfModule>

                    <IfModule mod_deflate.c>
                    AddOutputFilterByType DEFLATE application/atom+xml \
                    text/javascript \
                    application/x-javascript \
                    application/javascript \
                    application/json \
                    application/rss+xml \
                    application/vnd.ms-fontobject \
                    application/x-font-ttf \
                    application/xhtml+xml \
                    application/xml \
                    font/opentype \
                    image/svg+xml \
                    image/x-icon \
                    text/css \
                    text/html \
                    text/plain \
                    text/x-component \
                    text/xml
                    </IfModule>

                    <IfModule mod_expires.c>
                    ExpiresActive On
                    ExpiresByType application/x-javascript A1209600
                    ExpiresByType text/javascript A1209600
                    ExpiresByType application/javascript A1209600
                    ExpiresByType text/css A31536000
                    ExpiresByType image/x-icon A2592000
                    ExpiresByType image/icon A2592000
                    ExpiresByType application/x-ico A2592000
                    ExpiresByType application/ico A2592000
                    ExpiresByType image/gif A2592000
                    ExpiresByType image/jpeg A1209600
                    ExpiresByType image/jpg A1209600
                    ExpiresByType image/png A1209600
                    ExpiresByType application/x-shockwave-flash A1209600
                    ExpiresByType font/ttf A2592000
                    ExpiresByType font/otf A2592000
                    ExpiresByType font/x-woff A2592000
                    ExpiresByType image/svg+xml A2592000
                    ExpiresByType font/truetype A2592000
                    ExpiresByType font/opentype A2592000
                    ExpiresByType application/x-font-woff A2592000
                    ExpiresByType application/vnd.ms-fontobject A2592000
                    </IfModule>

                    <IfModule mod_headers.c>
                    Header set Connection keep-alive
                    <filesmatch "\.(ico|flv|gif|swf|eot|woff|otf|ttf|svg)$">
                    Header set Cache-Control "max-age=2592000, public"
                    </filesmatch>
                    <filesmatch "\.(jpg|jpeg|png)$">
                    Header set Cache-Control "max-age=1209600, public"
                    </filesmatch>
                    <filesmatch "\.(eot|woff|otf|ttf|svg)$">
                    Header set Cache-Control "max-age=2592000, public"
                    </filesmatch>
                    # css and js should use private for proxy caching https://developers.google.com/speed/...geProxyCaching
                    <filesmatch "\.(css)$">
                    Header set Cache-Control "max-age=31536000, private"
                    </filesmatch>
                    <filesmatch "\.(js)$">
                    Header set Cache-Control "max-age=1209600, private"
                    </filesmatch>
                    </IfModule>

                    Comment


                    • #25
                      Did you find anything wrong on my htaccess? Thank you

                      Comment


                      • #26
                        I still have the same issue. Could anyone help me? Thanks

                        Comment


                        • #27
                          What's going on with the login box?

                          You have some sort of add-on that's putting social media icons up there...disable that and revert any template changes.

                          Also there's a rogue letter 'p' next to the password field. That shouldn't be there, and implies something is interfering with the login form.

                          Click image for larger version

Name:	Capture.JPG
Views:	18
Size:	20.7 KB
ID:	4375451
                          MARK.B | vBULLETIN SUPPORT

                          TalkNewsUK - My vBulletin 5.5.2 Demo
                          AdminAmmo - My Cloud Demo

                          Comment


                          • #28
                            already tried to remove the plugin, the issue doesn't disappeared. The "P" is shown with IE, this is the screenshot by Google Chrome. My issue is that when I activate https, I see the error shown on post n. 12 of this topic. Thanks.

                            Click image for larger version  Name:	image_70081.jpg Views:	1 Size:	110.6 KB ID:	4375478

                            Comment


                            • #29
                              See that "Non sicuro" message in your Address Bar? It means that something is being loaded from a non-secure server. If your login URL is not set to a secure URL, this will prevent people from logging in. You need to make sure every resource (html, images, css, javascript) are loaded from secure URLs.
                              Translations provided by Google.

                              Wayne Luke
                              The Rabid Badger - a vBulletin Cloud customization and demonstration site.
                              vBulletin 5 Documentation - Updated every Friday. Report issues here.
                              vBulletin 5 API - Full / Mobile
                              I am not currently available for vB Messenger Chats.

                              Comment


                              • #30
                                The "non sicuro" message is due to the fact that I can't set https because It doesn't work. Now the site is set on http, If I set https, "non sicuro" disappears but login box doesn't work as I wrote before...

                                Comment

                                Related Topics

                                Collapse

                                Working...
                                X