Announcement

Collapse
No announcement yet.

Full screen with Youtube - is it possible?

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Full screen with Youtube - is it possible?

    The full screen button is disabled on all embedded YouTube videos. Does anyone know how or if this can be fixed?


    Mark
    Admin for hobbysquawk.com
    VB 5.5.4.1
    PHP 7.3.10
    Maria DB 10.2.27

  • #2
    Edit the template bbcode_video

    Find:
    Code:
    <vb:elseif condition="$provider == 'youtube'" />
    <iframe class="restrain" title="YouTube video player" width="<vb:if condition="isset($width) AND $width > 0">{vb:raw width}<vb:else />640</vb:if>" height="<vb:if condition="$height">{vb:raw height}<vb:else />390</vb:if>" src="//www.youtube.com/embed/{vb:raw code}?wmode={vb:raw vboptions.player_wmode}&autoplay=1"></iframe>
    <vb:elseif condition="$provider == 'youtube_share'" />
    <iframe class="restrain" title="YouTube video player" width="<vb:if condition="isset($width) AND $width > 0">{vb:raw width}<vb:else />640</vb:if>" height="<vb:if condition="$height">{vb:raw height}<vb:else />390</vb:if>" src="//www.youtube.com/embed/{vb:raw code}?wmode={vb:raw vboptions.player_wmode}&autoplay=1"></iframe>
    Add the red code (two instances):
    Code:
    <vb:elseif condition="$provider == 'youtube'" />
    <iframe class="restrain" title="YouTube video player" width="<vb:if condition="isset($width) AND $width > 0">{vb:raw width}<vb:else />640</vb:if>" height="<vb:if condition="$height">{vb:raw height}<vb:else />390</vb:if>" src="//www.youtube.com/embed/{vb:raw code}?wmode={vb:raw vboptions.player_wmode}&autoplay=1" allowFullScreen></iframe>
    <vb:elseif condition="$provider == 'youtube_share'" />
    <iframe class="restrain" title="YouTube video player" width="<vb:if condition="isset($width) AND $width > 0">{vb:raw width}<vb:else />640</vb:if>" height="<vb:if condition="$height">{vb:raw height}<vb:else />390</vb:if>" src="//www.youtube.com/embed/{vb:raw code}?wmode={vb:raw vboptions.player_wmode}&autoplay=1" allowFullScreen></iframe>
    Then run AdminCP > Maintenance > Clear System Cache.
    MARK.B | vBULLETIN SUPPORT

    TalkNewsUK - My vBulletin 5.5.6 Demo
    AdminAmmo - My Cloud Demo

    Comment


    • #3
      You *may* find to get this to work you might have to put your site into debug mode (instructions HERE), then go to the admincp and refresh it. Run AdminCP > Rebuild > Rebuild Video BB Codes. Then take your site out of debug mode again.
      MARK.B | vBULLETIN SUPPORT

      TalkNewsUK - My vBulletin 5.5.6 Demo
      AdminAmmo - My Cloud Demo

      Comment


      • #4
        There is a JIRA to have this fixed here: http://tracker.vbulletin.com/browse/VBV-17003
        Translations provided by Google.

        Wayne Luke
        The Rabid Badger - a vBulletin Cloud demonstration site.
        vBulletin 5 API - Full / Mobile
        Vote for your favorite feature requests and the bugs you want to see fixed.

        Comment


        • #5
          Mark, the fixed worked and I didnt have to put the site in debug mode.
          I do have one followup question about embedding YouTube videos:
          1. when we use the editor (underlined A) and use the insert video feature everything look good and proper. Here is an example: https://www.hobbysquawk.com/forum/mo...3696#post63696

          2. when we use the Post Link (chain link icon above) and add the link of a YouTube video, the video thumbnail is fine, BUT when you click on the video it plays in a really small, almost square window. Here is an example: https://www.hobbysquawk.com/forum/mo...3761#post63761

          Do you know how we can fix #2?
          Admin for hobbysquawk.com
          VB 5.5.4.1
          PHP 7.3.10
          Maria DB 10.2.27

          Comment


          • #6
            I think the second issue (which relates to link content types) is a known bug. I'll see if I can find the JIRA for it.
            MARK.B | vBULLETIN SUPPORT

            TalkNewsUK - My vBulletin 5.5.6 Demo
            AdminAmmo - My Cloud Demo

            Comment


            • #7
              Here it is....fixed in 5.2.7, hopefully:

              VBV-16725
              MARK.B | vBULLETIN SUPPORT

              TalkNewsUK - My vBulletin 5.5.6 Demo
              AdminAmmo - My Cloud Demo

              Comment


              • #8
                ok, for some reason I thought it was fixed in 5.2.6. We will wait patiently.
                Admin for hobbysquawk.com
                VB 5.5.4.1
                PHP 7.3.10
                Maria DB 10.2.27

                Comment


                • #9
                  This issue could be simply fixed by adding this in css_additional template.

                  Code:
                  .videocontainer {
                      float: none;
                  }

                  GIPHY for vB5 AutoLinker Auto-Create Flag Report Topic Social Icons in Postbit Clear Cache Cron DragDrop Upload Topic AJAX AutoUpdate Custom Avatars Selector Stop Links in Posts...and more!

                  Comment


                  • #10
                    deleted. posted in wrong group. sorry!
                    Last edited by storrm; Sun 25th Jun '17, 3:55am.

                    Comment

                    Related Topics

                    Collapse

                    Working...
                    X